summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.5.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.5.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.5.imx.bb144
1 files changed, 144 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.5.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.5.imx.bb
new file mode 100644
index 00000000..03bfa129
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.5.imx.bb
@@ -0,0 +1,144 @@
1# This recipe is for the i.MX fork of gstreamer1.0-plugins-base. For ease of
2# maintenance, the top section is a verbatim copy of an OE-core
3# recipe. The second section customizes the recipe for i.MX.
4
5########### OE-core copy ##################
6# Upstream hash: bb6ddc3691ab04162ec5fd69a2d5e7876713fd15
7
8require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
9
10DESCRIPTION = "'Base' GStreamer plugins and helper libraries"
11HOMEPAGE = "https://gstreamer.freedesktop.org/"
12BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues"
13LICENSE = "GPL-2.0-or-later & LGPL-2.0-or-later"
14LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d"
15
16SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
17 file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \
18 file://0003-viv-fb-Make-sure-config.h-is-included.patch \
19 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \
20 file://0004-glimagesink-Downrank-to-marginal.patch \
21 file://4ef5c91697a141fea7317aff7f0f28e5a861db99.patch \
22 "
23SRC_URI[sha256sum] = "29e53229a84d01d722f6f6db13087231cdf6113dd85c25746b9b58c3d68e8323"
24
25S = "${WORKDIR}/gst-plugins-base-${PV}"
26
27DEPENDS += "iso-codes util-linux zlib"
28
29inherit gobject-introspection
30
31PACKAGES_DYNAMIC =+ "^libgst.*"
32
33# opengl packageconfig factored out to make it easy for distros
34# and BSP layers to choose OpenGL APIs/platforms/window systems
35PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
36
37PACKAGECONFIG ??= " \
38 ${GSTREAMER_ORC} \
39 ${PACKAGECONFIG_GL} \
40 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
41 jpeg ogg pango png theora vorbis \
42 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \
43"
44
45OPENGL_APIS = 'opengl gles2'
46OPENGL_PLATFORMS = 'egl'
47
48X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
49X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled"
50X11DISABLEOPTS = "-Dx11=disabled -Dxvideo=disabled -Dxshm=disabled"
51
52PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib"
53PACKAGECONFIG[cdparanoia] = "-Dcdparanoia=enabled,-Dcdparanoia=disabled,cdparanoia"
54PACKAGECONFIG[jpeg] = "-Dgl-jpeg=enabled,-Dgl-jpeg=disabled,jpeg"
55PACKAGECONFIG[ogg] = "-Dogg=enabled,-Dogg=disabled,libogg"
56PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus"
57PACKAGECONFIG[pango] = "-Dpango=enabled,-Dpango=disabled,pango"
58PACKAGECONFIG[png] = "-Dgl-png=enabled,-Dgl-png=disabled,libpng"
59PACKAGECONFIG[theora] = "-Dtheora=enabled,-Dtheora=disabled,libtheora"
60PACKAGECONFIG[tremor] = "-Dtremor=enabled,-Dtremor=disabled,tremor"
61PACKAGECONFIG[visual] = "-Dlibvisual=enabled,-Dlibvisual=disabled,libvisual"
62PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis"
63PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
64
65# OpenGL API packageconfigs
66PACKAGECONFIG[opengl] = ",,virtual/libgl libglu"
67PACKAGECONFIG[gles2] = ",,virtual/libgles2"
68
69# OpenGL platform packageconfigs
70PACKAGECONFIG[egl] = ",,virtual/egl"
71
72# OpenGL window systems (except for X11)
73PACKAGECONFIG[gbm] = ",,virtual/libgbm libgudev libdrm"
74PACKAGECONFIG[wayland] = ",,wayland-native wayland wayland-protocols libdrm"
75PACKAGECONFIG[dispmanx] = ",,virtual/libomxil"
76PACKAGECONFIG[viv-fb] = ",,virtual/libgles2 virtual/libg2d"
77
78OPENGL_WINSYS = "${@bb.utils.filter('PACKAGECONFIG', 'x11 gbm wayland dispmanx egl viv-fb', d)}"
79
80EXTRA_OEMESON += " \
81 -Ddoc=disabled \
82 -Dgl-graphene=disabled \
83 ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \
84 ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \
85 ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \
86"
87
88FILES:${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h"
89FILES:${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
90
91def get_opengl_cmdline_list(switch_name, options, d):
92 selected_options = []
93 if bb.utils.contains('DISTRO_FEATURES', 'opengl', True, False, d):
94 for option in options.split():
95 if bb.utils.contains('PACKAGECONFIG', option, True, False, d):
96 selected_options += [option]
97 if selected_options:
98 return '-D' + switch_name + '=' + ','.join(selected_options)
99 else:
100 return ''
101
102CVE_PRODUCT += "gst-plugins-base"
103
104########### End of OE-core copy ###########
105
106########### i.MX overrides ################
107
108DEFAULT_PREFERENCE = "-1"
109
110SRC_URI:remove = " \
111 https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
112 file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \
113 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \
114 file://0004-glimagesink-Downrank-to-marginal.patch \
115 file://4ef5c91697a141fea7317aff7f0f28e5a861db99.patch \
116"
117GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https"
118SRCBRANCH = "MM_04.06.04_2112_L5.15.y"
119SRC_URI:prepend = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} "
120SRCREV = "d8f5d6e1d477a299ccb7f4ba7aacd36ff5e39f8b"
121
122S = "${WORKDIR}/git"
123
124inherit use-imx-headers
125
126PACKAGECONFIG_GL:imxgpu2d = \
127 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl viv-fb', '', d)}"
128PACKAGECONFIG_GL:imxgpu3d = \
129 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl viv-fb', '', d)}"
130PACKAGECONFIG_GL:use-mainline-bsp = \
131 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl gbm', '', d)}"
132
133PACKAGECONFIG_REMOVE ?= "jpeg"
134PACKAGECONFIG:remove = "${PACKAGECONFIG_REMOVE}"
135PACKAGECONFIG:append:imxgpu2d = " g2d"
136
137PACKAGECONFIG[g2d] = ",,virtual/libg2d"
138PACKAGECONFIG[viv-fb] = ",,virtual/libgles2"
139
140EXTRA_OEMESON += "-Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}""
141
142COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
143
144########### End of i.MX overrides #########