summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb103
1 files changed, 103 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
new file mode 100644
index 00000000..5e69e42b
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
@@ -0,0 +1,103 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
2
3DESCRIPTION = "'Base' GStreamer plugins and helper libraries"
4HOMEPAGE = "https://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues"
6LICENSE = "GPLv2+ & LGPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d"
8
9GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https"
10SRCBRANCH = "MM_04.06.01_2105_L5.10.y"
11SRC_URI = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \
12 file://0003-viv-fb-Make-sure-config.h-is-included.patch \
13 file://0004-glimagesink-Downrank-to-marginal.patch \
14 file://4ef5c91697a141fea7317aff7f0f28e5a861db99.patch \
15 "
16SRCREV = "69554a26c932481acb7c5691038c367eca60e5bc"
17
18S = "${WORKDIR}/git"
19
20DEPENDS += "iso-codes util-linux zlib"
21DEPENDS_append_imxgpu2d = " virtual/libg2d"
22
23inherit gobject-introspection use-imx-headers
24
25DEFAULT_PREFERENCE = "-1"
26
27PACKAGES_DYNAMIC =+ "^libgst.*"
28
29# opengl packageconfig factored out to make it easy for distros
30# and BSP layers to choose OpenGL APIs/platforms/window systems
31PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
32
33PACKAGECONFIG ??= " \
34 ${GSTREAMER_ORC} \
35 ${PACKAGECONFIG_GL} \
36 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
37 jpeg ogg pango png theora vorbis \
38 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \
39"
40
41OPENGL_APIS = 'opengl gles2'
42OPENGL_PLATFORMS = 'egl'
43OPENGL_WINSYS = 'x11 wayland gbm viv-fb'
44
45X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
46X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled"
47X11DISABLEOPTS = "-Dx11=disabled -Dxvideo=disabled -Dxshm=disabled"
48
49PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib"
50PACKAGECONFIG[cdparanoia] = "-Dcdparanoia=enabled,-Dcdparanoia=disabled,cdparanoia"
51PACKAGECONFIG[jpeg] = "-Dgl-jpeg=enabled,-Dgl-jpeg=disabled,jpeg"
52PACKAGECONFIG[ogg] = "-Dogg=enabled,-Dogg=disabled,libogg"
53PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus"
54PACKAGECONFIG[pango] = "-Dpango=enabled,-Dpango=disabled,pango"
55PACKAGECONFIG[png] = "-Dgl-png=enabled,-Dgl-png=disabled,libpng"
56PACKAGECONFIG[theora] = "-Dtheora=enabled,-Dtheora=disabled,libtheora"
57PACKAGECONFIG[tremor] = "-Dtremor=enabled,-Dtremor=disabled,tremor"
58PACKAGECONFIG[visual] = "-Dlibvisual=enabled,-Dlibvisual=disabled,libvisual"
59PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis"
60PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
61
62# OpenGL API packageconfigs
63PACKAGECONFIG[opengl] = ",,virtual/libgl libglu"
64PACKAGECONFIG[gles2] = ",,virtual/libgles2"
65
66# OpenGL platform packageconfigs
67PACKAGECONFIG[egl] = ",,virtual/egl"
68
69# OpenGL window systems (except for X11)
70PACKAGECONFIG[gbm] = ",,virtual/libgbm libgudev libdrm"
71PACKAGECONFIG[wayland] = ",,wayland-native wayland wayland-protocols libdrm"
72PACKAGECONFIG[dispmanx] = ",,virtual/libomxil"
73PACKAGECONFIG[viv-fb] = ",,virtual/libgles2 virtual/libg2d"
74
75OPENGL_WINSYS = "${@bb.utils.filter('PACKAGECONFIG', 'x11 gbm wayland dispmanx egl viv-fb', d)}"
76
77EXTRA_OEMESON += " \
78 -Ddoc=disabled \
79 -Dgl-graphene=disabled \
80 ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \
81 ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \
82 ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \
83 -Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}" \
84"
85
86FILES_${PN} += "${libdir}/gstreamer-1.0/include"
87FILES_${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h"
88FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
89
90def get_opengl_cmdline_list(switch_name, options, d):
91 selected_options = []
92 if bb.utils.contains('DISTRO_FEATURES', 'opengl', True, False, d):
93 for option in options.split():
94 if bb.utils.contains('PACKAGECONFIG', option, True, False, d):
95 selected_options += [option]
96 if selected_options:
97 return '-D' + switch_name + '=' + ','.join(selected_options)
98 else:
99 return ''
100
101CVE_PRODUCT += "gst-plugins-base"
102
103COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"