summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.12.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.12.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.12.imx.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.12.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.12.imx.bb
new file mode 100644
index 00000000..26d1df50
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.12.imx.bb
@@ -0,0 +1,69 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
2
3LICENSE = "GPLv2+ & LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \
5 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
6 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607"
7
8GST1.0-PLUGINS-BASE_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-base.git;protocol=https"
9SRCBRANCH = "MM_04.03.04_1801_L4.9.51_MX8M_GA"
10
11SRC_URI = " \
12 ${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} \
13 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
14 file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
15 file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \
16 file://0003-riff-add-missing-include-directories-when-calling-in.patch \
17 file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \
18"
19SRCREV = "3a615cab2e22e133048157ba107dc6c24e08c7e0"
20
21EXTRA_AUTORECONF = ""
22
23S = "${WORKDIR}/git"
24
25# Enable pango lib
26PACKAGECONFIG_append = " pango "
27
28# ion allocator will be enabled only when detecting the ion.h exists, which is built out from kernel.
29# Now, ion allocator can be supported on all i.MX platform
30DEPENDS_append = " iso-codes util-linux virtual/kernel"
31
32inherit gettext
33
34PACKAGES_DYNAMIC =+ "^libgst.*"
35
36PACKAGECONFIG ??= " \
37 ${GSTREAMER_ORC} \
38 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
39 ogg pango theora vorbis \
40"
41
42X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
43X11ENABLEOPTS = "--enable-x --enable-xvideo --enable-xshm"
44X11DISABLEOPTS = "--disable-x --disable-xvideo --disable-xshm"
45
46PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
47PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia"
48PACKAGECONFIG[ivorbis] = "--enable-ivorbis,--disable-ivorbis,tremor"
49PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg"
50PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus"
51PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
52PACKAGECONFIG[theora] = "--enable-theora,--disable-theora,libtheora"
53PACKAGECONFIG[visual] = "--enable-libvisual,--disable-libvisual,libvisual"
54PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis"
55PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
56
57EXTRA_OECONF += " \
58 --enable-zlib \
59"
60
61CACHED_CONFIGUREVARS_append_x86 = " ac_cv_header_emmintrin_h=no ac_cv_header_xmmintrin_h=no"
62
63FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
64
65do_compile_prepend() {
66 export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs:${B}/gst-libs/gst/rtp/.libs"
67}
68
69COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"