summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb163
1 files changed, 163 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
new file mode 100644
index 00000000..5d93176b
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
@@ -0,0 +1,163 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
2
3DEPENDS_append_imxgpu2d = " virtual/libg2d"
4DEPENDS_append_mx8 = " libdrm"
5
6PACKAGECONFIG_append_mx8 = " kms tinycompress"
7
8DEFAULT_PREFERENCE = "-1"
9
10PACKAGE_ARCH_imxpxp = "${MACHINE_SOCARCH}"
11PACKAGE_ARCH_mx8 = "${MACHINE_SOCARCH}"
12
13GST1.0-PLUGINS-BAD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-bad.git;protocol=https"
14SRCBRANCH = "MM_04.06.01_2105_L5.10.y"
15
16SRC_URI = " \
17 ${GST1.0-PLUGINS-BAD_SRC};branch=${SRCBRANCH} \
18"
19SRCREV = "227af57d23cb6b3564fc94446ab2c9fe8c8cff22"
20
21S = "${WORKDIR}/git"
22
23LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
24LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d \
25 file://COPYING.LIB;md5=21682e4e8fea52413fd26c60acb907e5 "
26
27DEPENDS += "gstreamer1.0-plugins-base"
28
29inherit gobject-introspection
30
31PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}"
32PACKAGECONFIG_GL_imxpxp = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
33
34PACKAGECONFIG ??= " \
35 ${GSTREAMER_ORC} \
36 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
37 ${@bb.utils.filter('DISTRO_FEATURES', 'directfb', d)} \
38 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
39 ${PACKAGECONFIG_GL} \
40 bz2 closedcaption curl dash dtls hls rsvg sbc smoothstreaming sndfile \
41 ttml uvch264 webp \
42"
43
44PACKAGECONFIG[assrender] = "-Dassrender=enabled,-Dassrender=disabled,libass"
45PACKAGECONFIG[bluez] = "-Dbluez=enabled,-Dbluez=disabled,bluez5"
46PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
47PACKAGECONFIG[closedcaption] = "-Dclosedcaption=enabled,-Dclosedcaption=disabled,pango cairo"
48PACKAGECONFIG[curl] = "-Dcurl=enabled,-Dcurl=disabled,curl"
49PACKAGECONFIG[dash] = "-Ddash=enabled,-Ddash=disabled,libxml2"
50PACKAGECONFIG[dc1394] = "-Ddc1394=enabled,-Ddc1394=disabled,libdc1394"
51PACKAGECONFIG[directfb] = "-Ddirectfb=enabled,-Ddirectfb=disabled,directfb"
52PACKAGECONFIG[dtls] = "-Ddtls=enabled,-Ddtls=disabled,openssl"
53PACKAGECONFIG[faac] = "-Dfaac=enabled,-Dfaac=disabled,faac"
54PACKAGECONFIG[faad] = "-Dfaad=enabled,-Dfaad=disabled,faad2"
55PACKAGECONFIG[fluidsynth] = "-Dfluidsynth=enabled,-Dfluidsynth=disabled,fluidsynth"
56PACKAGECONFIG[hls] = "-Dhls=enabled -Dhls-crypto=nettle,-Dhls=disabled,nettle"
57# the gl packageconfig enables OpenGL elements that haven't been ported
58# to -base yet. They depend on the gstgl library in -base, so we do
59# not add GL dependencies here, since these are taken care of in -base.
60PACKAGECONFIG[gl] = "-Dgl=enabled,-Dgl=disabled,"
61PACKAGECONFIG[gles2] = ",,virtual/libgles2"
62PACKAGECONFIG[kms] = "-Dkms=enabled,-Dkms=disabled,libdrm"
63PACKAGECONFIG[libde265] = "-Dlibde265=enabled,-Dlibde265=disabled,libde265"
64PACKAGECONFIG[libmms] = "-Dlibmms=enabled,-Dlibmms=disabled,libmms"
65PACKAGECONFIG[libssh2] = "-Dcurl-ssh2=enabled,-Dcurl-ssh2=disabled,libssh2"
66PACKAGECONFIG[modplug] = "-Dmodplug=enabled,-Dmodplug=disabled,libmodplug"
67PACKAGECONFIG[msdk] = "-Dmsdk=enabled,-Dmsdk=disabled,intel-mediasdk"
68PACKAGECONFIG[neon] = "-Dneon=enabled,-Dneon=disabled,neon"
69PACKAGECONFIG[openal] = "-Dopenal=enabled,-Dopenal=disabled,openal-soft"
70PACKAGECONFIG[opencv] = "-Dopencv=enabled,-Dopencv=disabled,opencv"
71PACKAGECONFIG[openh264] = "-Dopenh264=enabled,-Dopenh264=disabled,openh264"
72PACKAGECONFIG[openjpeg] = "-Dopenjpeg=enabled,-Dopenjpeg=disabled,openjpeg"
73PACKAGECONFIG[openmpt] = "-Dopenmpt=enabled,-Dopenmpt=disabled,libopenmpt"
74# the opus encoder/decoder elements are now in the -base package,
75# but the opus parser remains in -bad
76PACKAGECONFIG[opusparse] = "-Dopus=enabled,-Dopus=disabled,libopus"
77PACKAGECONFIG[resindvd] = "-Dresindvd=enabled,-Dresindvd=disabled,libdvdread libdvdnav"
78PACKAGECONFIG[rsvg] = "-Drsvg=enabled,-Drsvg=disabled,librsvg"
79PACKAGECONFIG[rtmp] = "-Drtmp=enabled,-Drtmp=disabled,rtmpdump"
80PACKAGECONFIG[sbc] = "-Dsbc=enabled,-Dsbc=disabled,sbc"
81PACKAGECONFIG[sctp] = "-Dsctp=enabled,-Dsctp=disabled,usrsctp"
82PACKAGECONFIG[smoothstreaming] = "-Dsmoothstreaming=enabled,-Dsmoothstreaming=disabled,libxml2"
83PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1"
84PACKAGECONFIG[srtp] = "-Dsrtp=enabled,-Dsrtp=disabled,libsrtp"
85PACKAGECONFIG[tinyalsa] = "-Dtinyalsa=enabled,-Dtinyalsa=disabled,tinyalsa"
86PACKAGECONFIG[tinycompress] = "-Dtinycompress=enabled,-Dtinycompress=disabled,tinycompress"
87PACKAGECONFIG[ttml] = "-Dttml=enabled,-Dttml=disabled,libxml2 pango cairo"
88PACKAGECONFIG[uvch264] = "-Duvch264=enabled,-Duvch264=disabled,libusb1 libgudev"
89PACKAGECONFIG[voaacenc] = "-Dvoaacenc=enabled,-Dvoaacenc=disabled,vo-aacenc"
90PACKAGECONFIG[voamrwbenc] = "-Dvoamrwbenc=enabled,-Dvoamrwbenc=disabled,vo-amrwbenc"
91PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-loader"
92PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols libdrm"
93PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp"
94PACKAGECONFIG[webrtc] = "-Dwebrtc=enabled,-Dwebrtc=disabled,libnice"
95PACKAGECONFIG[webrtcdsp] = "-Dwebrtcdsp=enabled,-Dwebrtcdsp=disabled,webrtc-audio-processing"
96PACKAGECONFIG[zbar] = "-Dzbar=enabled,-Dzbar=disabled,zbar"
97
98# these plugins currently have no corresponding library in OE-core or meta-openembedded:
99# aom androidmedia applemedia bs2b chromaprint d3dvideosink
100# directsound dts fdkaac gme gsm iq kate ladspa lv2 mpeg2enc
101# mplex musepack nvdec nvenc ofa openexr openni2 opensles
102# soundtouch spandsp srt teletext vdpau wasapi wildmidi winks
103# winscreencap wpe x265
104
105EXTRA_OEMESON += " \
106 -Ddecklink=enabled \
107 -Ddvb=enabled \
108 -Dfbdev=enabled \
109 -Dipcpipeline=enabled \
110 -Dnetsim=enabled \
111 -Dshm=enabled \
112 -Daom=disabled \
113 -Dandroidmedia=disabled \
114 -Dapplemedia=disabled \
115 -Dbs2b=disabled \
116 -Dchromaprint=disabled \
117 -Dd3dvideosink=disabled \
118 -Ddirectsound=disabled \
119 -Ddts=disabled \
120 -Dfdkaac=disabled \
121 -Dflite=disabled \
122 -Dgme=disabled \
123 -Dgsm=disabled \
124 -Diqa=disabled \
125 -Dkate=disabled \
126 -Dladspa=disabled \
127 -Dlv2=disabled \
128 -Dmpeg2enc=disabled \
129 -Dmplex=disabled \
130 -Dmsdk=disabled \
131 -Dmusepack=disabled \
132 -Dofa=disabled \
133 -Dopenexr=disabled \
134 -Dopenmpt=disabled \
135 -Dopenni2=disabled \
136 -Dopensles=disabled \
137 -Dsoundtouch=disabled \
138 -Dspandsp=disabled \
139 -Dsrt=disabled \
140 -Dteletext=disabled \
141 -Dwasapi=disabled \
142 -Dwildmidi=disabled \
143 -Dwinks=disabled \
144 -Dwinscreencap=disabled \
145 -Dwpe=disabled \
146 -Dx265=disabled \
147 -Dzbar=disabled \
148 ${@bb.utils.contains("TUNE_FEATURES", "mx32", "-Dyadif=disabled", "", d)} \
149"
150
151export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}"
152
153ARM_INSTRUCTION_SET_armv4 = "arm"
154ARM_INSTRUCTION_SET_armv5 = "arm"
155
156FILES_${PN}-freeverb += "${datadir}/gstreamer-1.0/presets/GstFreeverb.prs"
157FILES_${PN}-opencv += "${datadir}/gst-plugins-bad/1.0/opencv*"
158FILES_${PN}-transcode += "${datadir}/gstreamer-1.0/encoding-profiles"
159FILES_${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs"
160# include fragment shaders
161FILES_${PN}-opengl += "/usr/share/*.fs"
162
163COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"