summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.4.x.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.4.x.patch')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.4.x.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.4.x.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.4.x.patch
new file mode 100644
index 00000000..525f4a45
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.4.x.patch
@@ -0,0 +1,27 @@
1From a4df38174d33dc1e620ea535e16cac406ff59da2 Mon Sep 17 00:00:00 2001
2From: Nicola Murino <nicola.murino@gmail.com>
3Date: Fri, 31 Jul 2020 23:38:56 +0200
4Subject: [PATCH] opencv: allow compilation against 4.4.x
5
6Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1482>
7
8Upstream-Status: Backport [https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/commit/8544f3928ea46d2da3f27dc65576e8baf42a46d]
9Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
10
11---
12 ext/opencv/meson.build | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build
16index a26403482..b3270e540 100644
17--- a/ext/opencv/meson.build
18+++ b/ext/opencv/meson.build
19@@ -65,7 +65,7 @@ if opencv_found
20 endif
21 endforeach
22 else
23- opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.2.0'], required : false)
24+ opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.5.0'], required : false)
25 opencv_found = opencv_dep.found()
26 if opencv_found
27 foreach h : libopencv4_headers