diff options
Diffstat (limited to 'recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.7.bb')
-rw-r--r-- | recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.7.bb | 77 |
1 files changed, 77 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.7.bb b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.7.bb new file mode 100644 index 00000000..7d8ef0a9 --- /dev/null +++ b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.7.bb | |||
@@ -0,0 +1,77 @@ | |||
1 | # Copyright (C) 2014,2015 Freescale Semiconductor | ||
2 | # Copyright (C) 2012-2015 O.S. Systems Software LTDA. | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "Gstreamer freescale plugins" | ||
6 | LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1" | ||
7 | SECTION = "multimedia" | ||
8 | |||
9 | DEPENDS = "libfslcodec libfslparser virtual/kernel gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" | ||
10 | DEPENDS_append_mx6q = " imx-lib imx-vpu libfslvpuwrap" | ||
11 | DEPENDS_append_mx6dl = " imx-lib imx-vpu libfslvpuwrap" | ||
12 | DEPENDS_append_mx6sl = " imx-lib" | ||
13 | DEPENDS_append_mx6sx = " imx-lib" | ||
14 | DEPENDS_append_mx6ul = " imx-lib" | ||
15 | DEPENDS_append_mx7 = " imx-lib" | ||
16 | |||
17 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | ||
18 | file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | ||
19 | file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" | ||
20 | |||
21 | SRC_URI = "${FSL_MIRROR}/gst1.0-fsl-plugins-${PV}.tar.gz" | ||
22 | SRC_URI[md5sum] = "81e2dbd702ea2cd7904fc54981ea3d19" | ||
23 | SRC_URI[sha256sum] = "fc287a672e2f040c2697af618b2f6ed319202a6dfbb731cbfb7987b41de2d62b" | ||
24 | |||
25 | S = "${WORKDIR}/gst1.0-fsl-plugins-${PV}" | ||
26 | |||
27 | inherit autotools pkgconfig | ||
28 | |||
29 | # Make sure kernel sources are available | ||
30 | do_configure[depends] += "virtual/kernel:do_shared_workdir" | ||
31 | |||
32 | PLATFORM_mx6 = "MX6" | ||
33 | PLATFORM_mx6sl = "MX6SL" | ||
34 | PLATFORM_mx6sx = "MX6SX" | ||
35 | PLATFORM_mx6ul = "MX6UL" | ||
36 | PLATFORM_mx7= "MX7D" | ||
37 | |||
38 | # Todo add a mechanism to map possible build targets | ||
39 | EXTRA_OECONF = "PLATFORM=${PLATFORM} \ | ||
40 | CPPFLAGS="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" \ | ||
41 | CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR}" | ||
42 | |||
43 | PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine" | ||
44 | |||
45 | # Add codec list that the beep plugin run-time depended | ||
46 | BEEP_RDEPENDS = "libfslcodec-aac libfslcodec-mp3 libfslcodec-oggvorbis" | ||
47 | RDEPENDS_${PN} += "libfslparser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " | ||
48 | |||
49 | PACKAGECONFIG ?= "" | ||
50 | PACKAGECONFIG_mx6q = "overlaysink" | ||
51 | PACKAGECONFIG_mx6dl = "overlaysink" | ||
52 | PACKAGECONFIG_mx6sx = "overlaysink" | ||
53 | PACKAGECONFIG_mx6sl = "overlaysink" | ||
54 | |||
55 | # FIXME: Add all features | ||
56 | # feature from excluded mm packages | ||
57 | PACKAGECONFIG[ac3] += ",,libfslac3codec,libfslac3codec" | ||
58 | # feature from special mm packages | ||
59 | PACKAGECONFIG[aacp] += ",,libfslaacpcodec,libfslaacpcodec" | ||
60 | MSDEPENDS = "libfslmsparser libfslmscodec" | ||
61 | PACKAGECONFIG[wma10dec] += ",,${MSDEPENDS},${MSDEPENDS}" | ||
62 | PACKAGECONFIG[wma8enc] += "--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}" | ||
63 | OVDEPENDS = "virtual/libg2d" | ||
64 | PACKAGECONFIG[overlaysink] += "--enable-overlaysink,--disable-overlaysink, ${OVDEPENDS}" | ||
65 | |||
66 | FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}" | ||
67 | |||
68 | FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug" | ||
69 | FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc" | ||
70 | FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" | ||
71 | FILES_${PN}-gplay = "${bindir}/gplay-1.0" | ||
72 | FILES_${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}" | ||
73 | FILES_${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}" | ||
74 | FILES_${PN}-grecorder = "${bindir}/grecorder-1.0" | ||
75 | FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" | ||
76 | |||
77 | COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)" | ||