diff options
Diffstat (limited to 'recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.5.bb')
-rw-r--r-- | recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.5.bb | 71 |
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.5.bb b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.5.bb new file mode 100644 index 00000000..5be79bef --- /dev/null +++ b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.5.bb | |||
@@ -0,0 +1,71 @@ | |||
1 | # Copyright (C) 2014,2015 Freescale Semiconductor | ||
2 | # Copyright (C) 2012-2015 O.S. Systems Software LTDA. | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "Gstreamer freescale plugins" | ||
6 | LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1" | ||
7 | SECTION = "multimedia" | ||
8 | |||
9 | DEPENDS = "libfslcodec libfslparser virtual/kernel gstreamer1.0 gstreamer1.0-plugins-base" | ||
10 | DEPENDS_append_mx6q = " imx-lib imx-vpu libfslvpuwrap" | ||
11 | DEPENDS_append_mx6dl = " imx-lib imx-vpu libfslvpuwrap" | ||
12 | DEPENDS_append_mx6sl = " imx-lib" | ||
13 | DEPENDS_append_mx6sx = " imx-lib" | ||
14 | DEPENDS_append_mx7 = " imx-lib" | ||
15 | |||
16 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | ||
17 | file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | ||
18 | file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" | ||
19 | |||
20 | SRC_URI = "${FSL_MIRROR}/gst1.0-fsl-plugins-${PV}.tar.gz" | ||
21 | SRC_URI[md5sum] = "2ff9d2ddca37a9e119ea137188ef12a3" | ||
22 | SRC_URI[sha256sum] = "481aaa11ba443cf33fea5a958fe9f2b278a6815ee92c13407016f9a2407df4d6" | ||
23 | |||
24 | S = "${WORKDIR}/gst1.0-fsl-plugins-${PV}" | ||
25 | |||
26 | inherit autotools pkgconfig | ||
27 | |||
28 | # Make sure kernel sources are available | ||
29 | do_configure[depends] += "virtual/kernel:do_shared_workdir" | ||
30 | |||
31 | PLATFORM_mx6 = "MX6" | ||
32 | PLATFORM_mx6sl = "MX6SL" | ||
33 | PLATFORM_mx6sx = "MX6SX" | ||
34 | PLATFORM_mx7= "MX7D" | ||
35 | |||
36 | # Todo add a mechanism to map possible build targets | ||
37 | EXTRA_OECONF = "PLATFORM=${PLATFORM} \ | ||
38 | CPPFLAGS="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" \ | ||
39 | CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR}" | ||
40 | |||
41 | PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl" | ||
42 | |||
43 | # Add codec list that the beep plugin run-time depended | ||
44 | BEEP_RDEPENDS = "libfslcodec-aac libfslcodec-mp3 libfslcodec-oggvorbis" | ||
45 | RDEPENDS_${PN} += "libfslparser ${BEEP_RDEPENDS}" | ||
46 | |||
47 | PACKAGECONFIG ?= "" | ||
48 | PACKAGECONFIG_mx6 = "overlaysink" | ||
49 | |||
50 | # FIXME: Add all features | ||
51 | # feature from excluded mm packages | ||
52 | PACKAGECONFIG[ac3] += ",,libfslac3codec,libfslac3codec" | ||
53 | # feature from special mm packages | ||
54 | PACKAGECONFIG[aacp] += ",,libfslaacpcodec,libfslaacpcodec" | ||
55 | MSDEPENDS = "libfslmsparser libfslmscodec" | ||
56 | PACKAGECONFIG[wma10dec] += ",,${MSDEPENDS},${MSDEPENDS}" | ||
57 | PACKAGECONFIG[wma8enc] += "--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}" | ||
58 | OVDEPENDS = "virtual/libg2d" | ||
59 | PACKAGECONFIG[overlaysink] += "--enable-overlaysink,--disable-overlaysink, ${OVDEPENDS}" | ||
60 | |||
61 | FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}" | ||
62 | RDEPENDS_${PN} += "gstreamer1.0-plugins-good-id3demux" | ||
63 | |||
64 | FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug" | ||
65 | FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc" | ||
66 | FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" | ||
67 | FILES_${PN}-gplay = "${bindir}/gplay-1.0" | ||
68 | FILES_${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}" | ||
69 | FILES_${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}" | ||
70 | |||
71 | COMPATIBLE_MACHINE = "(mx6|mx7)" | ||