summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.6.bb24
1 files changed, 16 insertions, 8 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.6.bb b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
index 4810ca11..d75e24f7 100644
--- a/recipes-kernel/linux/linux-fslc-imx_6.6.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
@@ -28,20 +28,28 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v6.6.23 31# tag: v6.6.51
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
35# ------------------------------------------------------------------------------ 35# ------------------------------------------------------------------------------
36# tag: lf-6.6.3-1.0.00 36# tag: lf-6.6.23-2.0.0
37# 37#
38# ------------------------------------------------------------------------------ 38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s)) 39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------ 40# ------------------------------------------------------------------------------
41# - f67cb9a5b4fb7 Revert "net: stmmac: fix FPE events losing" 41
42# - 1918c2eb8b07f Revert "dmaengine: fsl-edma: fix DMA channel leak in eDMAv4" 42# $ git log --oneline --no-merges v6.6.23.. ^mainline/linux-6.6.y ^NXP/lf-6.6.y
43# - 42289407ee38f Revert "dmaengine: fsl-edma: Add judgment on enabling round robin arbitration" 43# - 4d8a7fb526c1 imx8mp: Remove obsolete device tree file
44# - 952f79923f055 Revert "dmaengine: fsl-edma: Do not suspend and resume the masked dma channel when the system is sleeping" 44# - e420d14b057f MLK-25922-4 arm64: dts: imx93: add lpspi support
45# - 965390eee531 Revert "dmaengine: fsl-edma: add address for channel mux register in fsl_edma_chan"
46# - a1553c4e0862 Revert "dmaengine: fsl-edma: add i.MX8ULP edma support"
47# - 652e34468562 Revert "dmaengine: fsl-edma: clean up unused "fsl,imx8qm-adma" compatible string"
48# - f4114b5ea07c Revert "dmaengine: fsl-edma: change the memory access from local into remote mode in i.MX 8QM"
49# - 97e602775143 Revert "arm64: dts: imx8-ss-conn: fix usdhc wrong lpcg clock order"
50# - dd280fd310dd arm64: imx_v8_defconfig: Enable CONFIG_GPIO_VF610
51# - 7a31ed76b4ee drm/imx: lcdifv3: Fix videomode settings
52# - fb5da09f0eae i2c: imx: Remove unnecessary clock reconfiguration
45# 53#
46# NOTE to upgraders: 54# NOTE to upgraders:
47# This recipe should NOT collect individual patches, they should be applied to 55# This recipe should NOT collect individual patches, they should be applied to
@@ -53,14 +61,14 @@ require linux-imx.inc
53 61
54KBRANCH = "6.6-2.0.x-imx" 62KBRANCH = "6.6-2.0.x-imx"
55SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 63SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
56SRCREV = "dd280fd310dd5fabbff7393175ee9d7a6aea6b34" 64SRCREV = "d023c381fa6161a7af966abaad8e7d9a997f07e7"
57 65
58# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 66# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
59# required by kernel-yocto.bbclass. 67# required by kernel-yocto.bbclass.
60# 68#
61# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 69# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
62# should be updated once patchlevel is merged. 70# should be updated once patchlevel is merged.
63LINUX_VERSION = "6.6.23" 71LINUX_VERSION = "6.6.51"
64 72
65KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" 73KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
66KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" 74KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"