diff options
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig | 1 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig | 10 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx_5.15.bb | 12 |
3 files changed, 17 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig b/recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig index f4697de8..582625f2 100644 --- a/recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig +++ b/recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig | |||
@@ -147,6 +147,7 @@ CONFIG_BLK_DEV_MD=m | |||
147 | CONFIG_BLK_DEV_DM=m | 147 | CONFIG_BLK_DEV_DM=m |
148 | CONFIG_DM_CRYPT=m | 148 | CONFIG_DM_CRYPT=m |
149 | CONFIG_NETDEVICES=y | 149 | CONFIG_NETDEVICES=y |
150 | CONFIG_TUN=y | ||
150 | # CONFIG_NET_VENDOR_BROADCOM is not set | 151 | # CONFIG_NET_VENDOR_BROADCOM is not set |
151 | CONFIG_CS89x0_PLATFORM=y | 152 | CONFIG_CS89x0_PLATFORM=y |
152 | # CONFIG_NET_VENDOR_FARADAY is not set | 153 | # CONFIG_NET_VENDOR_FARADAY is not set |
diff --git a/recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig b/recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig index c00288d1..74dc82cb 100644 --- a/recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig +++ b/recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig | |||
@@ -843,6 +843,8 @@ CONFIG_STAGING_MEDIA=y | |||
843 | CONFIG_VIDEO_HANTRO=m | 843 | CONFIG_VIDEO_HANTRO=m |
844 | CONFIG_VIDEO_IMX_CAPTURE=y | 844 | CONFIG_VIDEO_IMX_CAPTURE=y |
845 | CONFIG_IMX8_MEDIA_DEVICE=m | 845 | CONFIG_IMX8_MEDIA_DEVICE=m |
846 | CONFIG_MHDP_HDMIRX=y | ||
847 | CONFIG_MHDP_HDMIRX_CEC=y | ||
846 | CONFIG_FSL_DPAA2=y | 848 | CONFIG_FSL_DPAA2=y |
847 | CONFIG_FSL_PPFE=y | 849 | CONFIG_FSL_PPFE=y |
848 | CONFIG_FSL_PPFE_UTIL_DISABLED=y | 850 | CONFIG_FSL_PPFE_UTIL_DISABLED=y |
@@ -893,6 +895,7 @@ CONFIG_EXTCON_PTN5150=m | |||
893 | CONFIG_EXTCON_USB_GPIO=y | 895 | CONFIG_EXTCON_USB_GPIO=y |
894 | CONFIG_EXTCON_USBC_CROS_EC=y | 896 | CONFIG_EXTCON_USBC_CROS_EC=y |
895 | CONFIG_IIO=y | 897 | CONFIG_IIO=y |
898 | CONFIG_FXLS8962AF_I2C=m | ||
896 | CONFIG_IMX8QXP_ADC=y | 899 | CONFIG_IMX8QXP_ADC=y |
897 | CONFIG_MAX9611=m | 900 | CONFIG_MAX9611=m |
898 | CONFIG_QCOM_SPMI_VADC=m | 901 | CONFIG_QCOM_SPMI_VADC=m |
@@ -901,6 +904,7 @@ CONFIG_IIO_CROS_EC_SENSORS_CORE=m | |||
901 | CONFIG_IIO_CROS_EC_SENSORS=m | 904 | CONFIG_IIO_CROS_EC_SENSORS=m |
902 | CONFIG_FXAS21002C=y | 905 | CONFIG_FXAS21002C=y |
903 | CONFIG_FXOS8700_I2C=y | 906 | CONFIG_FXOS8700_I2C=y |
907 | CONFIG_RPMSG_IIO_PEDOMETER=m | ||
904 | CONFIG_IIO_ST_LSM6DSX=y | 908 | CONFIG_IIO_ST_LSM6DSX=y |
905 | CONFIG_IIO_CROS_EC_LIGHT_PROX=m | 909 | CONFIG_IIO_CROS_EC_LIGHT_PROX=m |
906 | CONFIG_SENSORS_ISL29018=y | 910 | CONFIG_SENSORS_ISL29018=y |
@@ -1038,3 +1042,9 @@ CONFIG_CORESIGHT_SOURCE_ETM4X=y | |||
1038 | CONFIG_MEMTEST=y | 1042 | CONFIG_MEMTEST=y |
1039 | CONFIG_TLS=y | 1043 | CONFIG_TLS=y |
1040 | CONFIG_TLS_DEVICE=y | 1044 | CONFIG_TLS_DEVICE=y |
1045 | |||
1046 | # enable Trusted Keys based on CAAM | ||
1047 | CONFIG_TRUSTED_KEYS=m | ||
1048 | CONFIG_TRUSTED_KEYS_TPM=n | ||
1049 | CONFIG_TRUSTED_KEYS_TEE=n | ||
1050 | CONFIG_TRUSTED_KEYS_CAAM=y | ||
diff --git a/recipes-kernel/linux/linux-imx_5.15.bb b/recipes-kernel/linux/linux-imx_5.15.bb index 751e4c9f..8bd3065c 100644 --- a/recipes-kernel/linux/linux-imx_5.15.bb +++ b/recipes-kernel/linux/linux-imx_5.15.bb | |||
@@ -20,19 +20,19 @@ DEPENDS += "lzop-native bc-native" | |||
20 | # UPGRADE NOTE: | 20 | # UPGRADE NOTE: |
21 | # The linux-imx kernel build uses a defconfig maintained in the layer. That | 21 | # The linux-imx kernel build uses a defconfig maintained in the layer. That |
22 | # defconfig is a copy of a defconfig maintained by NXP in the source. | 22 | # defconfig is a copy of a defconfig maintained by NXP in the source. |
23 | # | defconfig in layer | copied from NXP kernel source | | 23 | # | SOURCE | LAYER | |
24 | # | linux-imx/imx-nxp-bsp/defconfig | arch/arm/configs/imx_v7_defconfig | | 24 | # | arch/arm/configs/imx_v7_defconfig | linux-imx/imx-nxp-bsp/defconfig | |
25 | # | linux-imx/mx8-nxp-bsp/defconfig | arch/arm64/configs/imx_v8_defconfig | | 25 | # | arch/arm64/configs/imx_v8_defconfig | linux-imx/mx8-nxp-bsp/defconfig | |
26 | SRCBRANCH = "lf-5.15.y" | 26 | SRCBRANCH = "lf-5.15.y" |
27 | LOCALVERSION = "-5.15.5_1.0.0" | 27 | LOCALVERSION = "-5.15.32_2.0.0" |
28 | SRCREV = "c1084c2773fc1005ed140db625399d5334d94a28" | 28 | SRCREV = "fa6c3168595c02bd9d5366fcc28c9e7304947a3d" |
29 | 29 | ||
30 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition | 30 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition |
31 | # required by kernel-yocto.bbclass. | 31 | # required by kernel-yocto.bbclass. |
32 | # | 32 | # |
33 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and | 33 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and |
34 | # should be updated once patchlevel is merged. | 34 | # should be updated once patchlevel is merged. |
35 | LINUX_VERSION = "5.15.5" | 35 | LINUX_VERSION = "5.15.32" |
36 | 36 | ||
37 | DEFAULT_PREFERENCE = "1" | 37 | DEFAULT_PREFERENCE = "1" |
38 | 38 | ||