diff options
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/dtc/dtc-145_git.bb | 20 | ||||
-rw-r--r-- | recipes-kernel/dtc/files/0001-Fix-compiler-warnings-seen-with-musl.patch | 55 | ||||
-rw-r--r-- | recipes-kernel/dtc/files/make_install.patch | 17 |
3 files changed, 0 insertions, 92 deletions
diff --git a/recipes-kernel/dtc/dtc-145_git.bb b/recipes-kernel/dtc/dtc-145_git.bb deleted file mode 100644 index 2d4097bb..00000000 --- a/recipes-kernel/dtc/dtc-145_git.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | require recipes-kernel/dtc/dtc.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = " \ | ||
4 | file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
5 | file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c \ | ||
6 | " | ||
7 | |||
8 | SRCREV = "22a65c5331c22979d416738eb756b9541672e00d" | ||
9 | |||
10 | SRC_URI += "file://0001-Fix-compiler-warnings-seen-with-musl.patch \ | ||
11 | " | ||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | # only install the dtc binary renamed to dtc-145 | ||
15 | do_install () { | ||
16 | install -d ${D}/${bindir} | ||
17 | install -m 755 dtc ${D}/${bindir}/dtc-145 | ||
18 | } | ||
19 | |||
20 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-kernel/dtc/files/0001-Fix-compiler-warnings-seen-with-musl.patch b/recipes-kernel/dtc/files/0001-Fix-compiler-warnings-seen-with-musl.patch deleted file mode 100644 index 418a6498..00000000 --- a/recipes-kernel/dtc/files/0001-Fix-compiler-warnings-seen-with-musl.patch +++ /dev/null | |||
@@ -1,55 +0,0 @@ | |||
1 | From 50034ca2600ae07203f397af6d78e2e9ff16bc02 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 6 Oct 2018 18:12:23 -0700 | ||
4 | Subject: [PATCH] Fix compiler warnings seen with musl | ||
5 | |||
6 | Fixes | ||
7 | |||
8 | checks.c:975:16: error: format '%ld' expects argument of type 'long | ||
9 | int', but argument 6 has type 'unsigned int' [-Werror=format=] | ||
10 | FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple | ||
11 | of %ld in node %s", | ||
12 | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
13 | prop->name, prop->val.len, sizeof(cell_t), node->fullpath); | ||
14 | ~~~~~~~~~~~~~~ | ||
15 | checks.c:96:23: note: in definition of macro 'FAIL' | ||
16 | check_msg((c), dti, __VA_ARGS__); \ | ||
17 | ^~~~~~~~~~~ | ||
18 | checks.c: In function 'check_interrupts_property': | ||
19 | checks.c:1166:16: error: format '%ld' expects argument of type 'long | ||
20 | int', but argument 6 has type 'unsigned int' [-Werror=format=] | ||
21 | FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple | ||
22 | of %ld in node %s", | ||
23 | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
24 | irq_prop->name, irq_prop->val.len, sizeof(cell_t), | ||
25 | ~~~~~~~~~~~~~~ | ||
26 | |||
27 | Upstream-Status: Backport [adapted from an upstream fix] | ||
28 | |||
29 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
30 | --- | ||
31 | checks.c | 4 ++-- | ||
32 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
33 | |||
34 | diff --git a/checks.c b/checks.c | ||
35 | index 902f2e3..08a3a29 100644 | ||
36 | --- a/checks.c | ||
37 | +++ b/checks.c | ||
38 | @@ -972,7 +972,7 @@ static void check_property_phandle_args(struct check *c, | ||
39 | int cell, cellsize = 0; | ||
40 | |||
41 | if (prop->val.len % sizeof(cell_t)) { | ||
42 | - FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %ld in node %s", | ||
43 | + FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %zu in node %s", | ||
44 | prop->name, prop->val.len, sizeof(cell_t), node->fullpath); | ||
45 | return; | ||
46 | } | ||
47 | @@ -1163,7 +1163,7 @@ static void check_interrupts_property(struct check *c, | ||
48 | return; | ||
49 | |||
50 | if (irq_prop->val.len % sizeof(cell_t)) | ||
51 | - FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %ld in node %s", | ||
52 | + FAIL(c, dti, "property '%s' size (%d) is invalid, expected multiple of %zu in node %s", | ||
53 | irq_prop->name, irq_prop->val.len, sizeof(cell_t), | ||
54 | node->fullpath); | ||
55 | |||
diff --git a/recipes-kernel/dtc/files/make_install.patch b/recipes-kernel/dtc/files/make_install.patch deleted file mode 100644 index ccf17b38..00000000 --- a/recipes-kernel/dtc/files/make_install.patch +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | Upstream-Status: Inappropriate [configuration] | ||
2 | |||
3 | Index: git/Makefile | ||
4 | =================================================================== | ||
5 | --- git.orig/Makefile | ||
6 | +++ git/Makefile | ||
7 | @@ -168,8 +168,8 @@ install-bin: all $(SCRIPTS) | ||
8 | install-lib: all | ||
9 | @$(VECHO) INSTALL-LIB | ||
10 | $(INSTALL) -d $(DESTDIR)$(LIBDIR) | ||
11 | - $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR) | ||
12 | - ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname) | ||
13 | + $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname) | ||
14 | + ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/$(notdir $(LIBFDT_lib)) | ||
15 | ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/libfdt.$(SHAREDLIB_EXT) | ||
16 | $(INSTALL) -m 644 $(LIBFDT_archive) $(DESTDIR)$(LIBDIR) | ||
17 | |||