diff options
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/ceetm/ceetm/0001-Makefile-update-CFLAGS.patch | 31 | ||||
-rw-r--r-- | recipes-kernel/ceetm/ceetm_git.bb | 11 |
2 files changed, 37 insertions, 5 deletions
diff --git a/recipes-kernel/ceetm/ceetm/0001-Makefile-update-CFLAGS.patch b/recipes-kernel/ceetm/ceetm/0001-Makefile-update-CFLAGS.patch new file mode 100644 index 00000000..13697886 --- /dev/null +++ b/recipes-kernel/ceetm/ceetm/0001-Makefile-update-CFLAGS.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From fb1fe93a2bab083652a65804be5ddd37a7e86a9f Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Wed, 14 Aug 2019 04:05:14 +0200 | ||
4 | Subject: [PATCH] Makefile: update CFLAGS | ||
5 | |||
6 | *fix the below error: | ||
7 | |error: json_print.h: No such file or directory | ||
8 | |||
9 | Upstream-Status: Inappropriate [embedded specific] | ||
10 | |||
11 | Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com> | ||
12 | --- | ||
13 | Makefile | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/Makefile b/Makefile | ||
17 | index f89700c..49243d8 100644 | ||
18 | --- a/Makefile | ||
19 | +++ b/Makefile | ||
20 | @@ -8,7 +8,7 @@ LDFLAGS += -Wl,-export-dynamic | ||
21 | # if you are not using flex-builder. Download the iproute2 sources for the | ||
22 | # desired version and point to those instead. | ||
23 | ifneq ($(IPROUTE2_DIR),) | ||
24 | -CFLAGS += -I$(IPROUTE2_DIR) -I$(IPROUTE2_DIR)/include | ||
25 | +CFLAGS += -I$(IPROUTE2_DIR) -I$(IPROUTE2_DIR)/include -I$(IPROUTE2_DIR)/usr/include/ -I$(IPROUTE2_DIR)/usr/include/include | ||
26 | endif | ||
27 | |||
28 | MODDESTDIR := $(DESTDIR)/usr/lib/tc | ||
29 | -- | ||
30 | 2.7.4 | ||
31 | |||
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb index 8613e507..68fb67e0 100644 --- a/recipes-kernel/ceetm/ceetm_git.bb +++ b/recipes-kernel/ceetm/ceetm_git.bb | |||
@@ -4,16 +4,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bac620b9883d38a84dfb73ca7122d915" | |||
4 | 4 | ||
5 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ceetm;nobranch=1" | 5 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ceetm;nobranch=1" |
6 | SRCREV = "6a7f2ec2091df2f4380cb8d25a36c399aed5af1b" | 6 | SRCREV = "6a7f2ec2091df2f4380cb8d25a36c399aed5af1b" |
7 | 7 | SRC_URI_append = " file://0001-Makefile-update-CFLAGS.patch \ | |
8 | " | ||
8 | DEPENDS = "iproute2" | 9 | DEPENDS = "iproute2" |
9 | 10 | ||
10 | S = "${WORKDIR}/git" | 11 | S = "${WORKDIR}/git" |
11 | 12 | ||
12 | EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" IPROUTE2_DIR="{STAGING_DIR_TARGET}"' | 13 | export IPROUTE2_DIR="${STAGING_DIR_TARGET}" |
14 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | ||
15 | export CROSS_COMPILE="${WRAP_TARGET_PREFIX}" | ||
13 | 16 | ||
14 | do_compile_prepend () { | 17 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
15 | cp ${RECIPE_SYSROOT}/usr/include/include/json_print.h ${RECIPE_SYSROOT}/usr/include | ||
16 | } | ||
17 | 18 | ||
18 | do_install(){ | 19 | do_install(){ |
19 | mkdir -p ${D}/${libdir}/tc | 20 | mkdir -p ${D}/${libdir}/tc |