summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch25
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.14.bb3
2 files changed, 27 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch b/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch
new file mode 100644
index 00000000..3cd25014
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch
@@ -0,0 +1,25 @@
1From 844ce11967bca7b7f68c6cb459e02c9a10f32574 Mon Sep 17 00:00:00 2001
2From: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
3Date: Tue, 3 Jul 2018 15:06:29 +0800
4Subject: [PATCH] fix gcc8 build error
5
6---
7 Makefile | 2 ++
8 1 file changed, 2 insertions(+)
9
10diff --git a/Makefile b/Makefile
11index d6db01a..85d9d6c 100644
12--- a/Makefile
13+++ b/Makefile
14@@ -422,6 +422,8 @@ LINUXINCLUDE := \
15 KBUILD_AFLAGS := -D__ASSEMBLY__
16 KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
17 -fno-strict-aliasing -fno-common -fshort-wchar \
18+ -Wno-packed-not-aligned \
19+ -Wno-tautological-compare \
20 -Werror-implicit-function-declaration \
21 -Wno-format-security \
22 -std=gnu89
23--
241.8.3.1
25
diff --git a/recipes-kernel/linux/linux-qoriq_4.14.bb b/recipes-kernel/linux/linux-qoriq_4.14.bb
index f4af8d52..bceacf35 100644
--- a/recipes-kernel/linux/linux-qoriq_4.14.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.14.bb
@@ -7,8 +7,9 @@ LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" 7LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
8 8
9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ 9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \
10 file://0001-fix-gcc8-build-error.patch \
10" 11"
11SRCREV = "dfe1b1320d85c5eea99af54dfbf5e9923c3392cc" 12SRCREV = "b09b730fcb1cbcbaa71ff8a84eafd1c2454f7e55"
12 13
13S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
14 15