summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx_6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-imx_6.1.bb')
-rw-r--r--recipes-kernel/linux/linux-imx_6.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx_6.1.bb b/recipes-kernel/linux/linux-imx_6.1.bb
new file mode 100644
index 00000000..ca298c4c
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx_6.1.bb
@@ -0,0 +1,40 @@
1# Copyright 2013-2016 (C) Freescale Semiconductor
2# Copyright 2017-2023 (C) NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5#
6# SPDX-License-Identifier: MIT
7#
8
9SUMMARY = "Linux Kernel provided and supported by NXP"
10DESCRIPTION = "Linux Kernel provided and supported by NXP with focus on \
11i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
12
13require recipes-kernel/linux/linux-imx.inc
14
15LICENSE = "GPL-2.0-only"
16LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
17
18DEPENDS += "lzop-native bc-native"
19
20# UPGRADE NOTE:
21# The linux-imx kernel build uses a defconfig maintained in the layer. That
22# defconfig is a copy of a defconfig maintained by NXP in the source.
23# | SOURCE | LAYER |
24# | arch/arm/configs/imx_v7_defconfig | linux-imx/imx-nxp-bsp/defconfig |
25# | arch/arm64/configs/imx_v8_defconfig | linux-imx/mx8-nxp-bsp/defconfig |
26# | arch/arm64/configs/imx_v8_defconfig | linux-imx/mx9-nxp-bsp/defconfig |
27SRCBRANCH = "lf-6.1.y"
28LOCALVERSION = "-6.1.1-1.0.0"
29SRCREV = "29549c7073bf72cfb2c4614d37de45ec36b60475"
30
31# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
32# required by kernel-yocto.bbclass.
33#
34# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
35# should be updated once patchlevel is merged.
36LINUX_VERSION = "6.1.1"
37
38DEFAULT_PREFERENCE = "1"
39
40COMPATIBLE_MACHINE = "(imx-nxp-bsp)"