summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx_5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-imx_5.4.bb')
-rw-r--r--recipes-kernel/linux/linux-imx_5.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx_5.4.bb b/recipes-kernel/linux/linux-imx_5.4.bb
new file mode 100644
index 00000000..8c56b986
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx_5.4.bb
@@ -0,0 +1,33 @@
1# Copyright 2013-2016 (C) Freescale Semiconductor
2# Copyright 2017-2020 (C) NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5#
6# SPDX-License-Identifier: MIT
7#
8
9SUMMARY = "Linux Kernel provided and supported by NXP"
10DESCRIPTION = "Linux Kernel provided and supported by NXP with focus on \
11i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
12
13require recipes-kernel/linux/linux-imx.inc
14
15LICENSE = "GPLv2"
16LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
17
18DEPENDS += "lzop-native bc-native"
19
20SRCBRANCH = "imx_5.4.24_2.1.0"
21LOCALVERSION = "-2.1.0"
22SRCREV = "babac008e5cf168abca1a85bda2e8071ca27a5c0"
23
24# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
25# required by kernel-yocto.bbclass.
26#
27# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
28# should be updated once patchlevel is merged.
29LINUX_VERSION = "5.4.24"
30
31DEFAULT_PREFERENCE = "1"
32
33COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"