summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx_5.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-imx_5.15.bb')
-rw-r--r--recipes-kernel/linux/linux-imx_5.15.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx_5.15.bb b/recipes-kernel/linux/linux-imx_5.15.bb
new file mode 100644
index 00000000..751e4c9f
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx_5.15.bb
@@ -0,0 +1,39 @@
1# Copyright 2013-2016 (C) Freescale Semiconductor
2# Copyright 2017-2021 (C) NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5#
6# SPDX-License-Identifier: MIT
7#
8
9SUMMARY = "Linux Kernel provided and supported by NXP"
10DESCRIPTION = "Linux Kernel provided and supported by NXP with focus on \
11i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
12
13require recipes-kernel/linux/linux-imx.inc
14
15LICENSE = "GPL-2.0-only"
16LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
17
18DEPENDS += "lzop-native bc-native"
19
20# UPGRADE NOTE:
21# The linux-imx kernel build uses a defconfig maintained in the layer. That
22# defconfig is a copy of a defconfig maintained by NXP in the source.
23# | defconfig in layer | copied from NXP kernel source |
24# | linux-imx/imx-nxp-bsp/defconfig | arch/arm/configs/imx_v7_defconfig |
25# | linux-imx/mx8-nxp-bsp/defconfig | arch/arm64/configs/imx_v8_defconfig |
26SRCBRANCH = "lf-5.15.y"
27LOCALVERSION = "-5.15.5_1.0.0"
28SRCREV = "c1084c2773fc1005ed140db625399d5334d94a28"
29
30# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
31# required by kernel-yocto.bbclass.
32#
33# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
34# should be updated once patchlevel is merged.
35LINUX_VERSION = "5.15.5"
36
37DEFAULT_PREFERENCE = "1"
38
39COMPATIBLE_MACHINE = "(imx-nxp-bsp)"