summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb')
-rw-r--r--recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb b/recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb
new file mode 100644
index 00000000..7ffd3c7a
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb
@@ -0,0 +1,18 @@
1# Copyright (C) 2014-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3
4SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
5DESCRIPTION = "Linux Kernel provided and supported by Freescale that produces a \
6Manufacturing Tool compatible Linux Kernel to be used in updater environment"
7
8require linux-imx_${PV}.bb
9require linux-mfgtool.inc
10
11KERNEL_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
12MODULE_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
13do_package[vardepsexclude] = "DATETIME"
14
15do_deploy () {
16 install -d ${DEPLOY_DIR_IMAGE}
17 install arch/arm/boot/zImage ${DEPLOY_DIR_IMAGE}/zImage_mfgtool
18}