summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx-headers_6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-imx-headers_6.1.bb')
-rw-r--r--recipes-kernel/linux/linux-imx-headers_6.1.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-headers_6.1.bb b/recipes-kernel/linux/linux-imx-headers_6.1.bb
new file mode 100644
index 00000000..cec22c1b
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-headers_6.1.bb
@@ -0,0 +1,78 @@
1# Copyright 2017-2023 NXP
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Installs i.MX-specific kernel headers"
5DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \
6New headers are installed in ${includedir}/imx."
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
9
10SRC_URI = "git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
11SRCBRANCH = "lf-6.1.y"
12LOCALVERSION = "-6.1.1-1.0.0"
13SRCREV = "29549c7073bf72cfb2c4614d37de45ec36b60475"
14
15S = "${WORKDIR}/git"
16
17do_configure[noexec] = "1"
18
19do_compile[noexec] = "1"
20
21IMX_UAPI_HEADERS = " \
22 dma-buf.h \
23 hantrodec.h \
24 hx280enc.h \
25 ipu.h \
26 imx_vpu.h \
27 mxc_asrc.h \
28 mxc_dcic.h \
29 mxc_mlb.h \
30 mxc_sim_interface.h \
31 mxc_v4l2.h \
32 mxcfb.h \
33 pxp_device.h \
34 pxp_dma.h \
35 version.h \
36 videodev2.h \
37"
38
39do_install() {
40 # We install all headers inside of B so we can copy only the
41 # i.MX-specific ones, and there is no risk of a new header to be
42 # installed by mistake.
43 oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix}
44
45 ################################################
46 # BEGIN Copy of exceptional logic from linux-libc-headers
47 # Kernel should not be exporting this header
48 rm -f ${B}${exec_prefix}/include/scsi/scsi.h
49
50 # The ..install.cmd conflicts between various configure runs
51 find ${B}${includedir} -name ..install.cmd | xargs rm -f
52 # END Copy from linux-libc-headers
53 ################################################
54
55 # Install i.MX-specific headers only
56 for h in ${IMX_UAPI_HEADERS}; do
57 install -D -m 0644 ${B}${includedir}/linux/$h \
58 ${D}${includedir}/imx/linux/$h
59 done
60}
61
62# Allow to build empty main package, this is required in order for -dev package
63# to be propagated into the SDK
64#
65# Without this setting the RDEPENDS in other recipes fails to find this
66# package, therefore causing the -dev package also to be skipped effectively not
67# populating it into SDK
68ALLOW_EMPTY:${PN} = "1"
69
70INHIBIT_DEFAULT_DEPS = "1"
71DEPENDS += "unifdef-native bison-native rsync-native"
72
73PACKAGE_ARCH = "${MACHINE_SOCARCH}"
74
75# Restrict this recipe to NXP BSP only, this recipe is not compatible
76# with mainline BSP
77COMPATIBLE_HOST = '(null)'
78COMPATIBLE_HOST:use-nxp-bsp = '.*'