summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx-headers_5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-imx-headers_5.4.bb')
-rw-r--r--recipes-kernel/linux/linux-imx-headers_5.4.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-headers_5.4.bb b/recipes-kernel/linux/linux-imx-headers_5.4.bb
new file mode 100644
index 00000000..54c4e8cb
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-headers_5.4.bb
@@ -0,0 +1,77 @@
1# Copyright 2017-2019 NXP
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Installs i.MX-specific kernel headers"
5DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \
6New headers are installed in ${includedir}/imx."
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
9
10SRCBRANCH = "imx_5.4.24_2.1.0"
11LOCALVERSION = "-2.1.0"
12SRC_URI = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
13SRCREV = "dea2fede7e024ee7029b13e8d82a00ec14427777"
14
15S = "${WORKDIR}/git"
16
17do_configure[noexec] = "1"
18
19do_compile[noexec] = "1"
20
21IMX_UAPI_HEADERS = " \
22 dma-buf.h \
23 hantrodec.h \
24 hx280enc.h \
25 ion.h \
26 ipu.h \
27 isl29023.h \
28 mxc_asrc.h \
29 mxc_dcic.h \
30 mxc_mlb.h \
31 mxc_sim_interface.h \
32 mxc_v4l2.h \
33 mxcfb.h \
34 pxp_device.h \
35 pxp_dma.h \
36 videodev2.h \
37"
38
39do_install() {
40 # We install all headers inside of B so we can copy only the
41 # whitelisted ones, and there is no risk of a new header to be
42 # installed by mistake.
43 oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix}
44
45 # Kernel should not be exporting this header
46 rm -f ${D}${exec_prefix}/include/scsi/scsi.h
47
48 # The ..install.cmd conflicts between various configure runs
49 find ${D}${includedir} -name ..install.cmd | xargs rm -f
50
51 # FIXME: The ion.h is still on staging so "promote" it for now
52 cp ${S}/drivers/staging/android/uapi/ion.h ${B}${includedir}/linux
53
54 # Install whitelisted headers only
55 for h in ${IMX_UAPI_HEADERS}; do
56 install -D -m 0644 ${B}${includedir}/linux/$h \
57 ${D}${includedir}/imx/linux/$h
58 done
59}
60
61# Allow to build empty main package, this is required in order for -dev package
62# to be propagated into the SDK
63#
64# Without this setting the RDEPENDS in other recipes fails to find this
65# package, therefore causing the -dev package also to be skipped effectively not
66# populating it into SDK
67ALLOW_EMPTY_${PN} = "1"
68
69INHIBIT_DEFAULT_DEPS = "1"
70DEPENDS += "unifdef-native bison-native rsync-native"
71
72PACKAGE_ARCH = "${MACHINE_SOCARCH}"
73
74# Restrict this recipe to NXP BSP only, this recipe is not compatible
75# with mainline BSP
76COMPATIBLE_HOST = '(null)'
77COMPATIBLE_HOST_use-nxp-bsp = '.*'