summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx-headers_5.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-imx-headers_5.15.bb')
-rw-r--r--recipes-kernel/linux/linux-imx-headers_5.15.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-headers_5.15.bb b/recipes-kernel/linux/linux-imx-headers_5.15.bb
new file mode 100644
index 00000000..b7fea42c
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-headers_5.15.bb
@@ -0,0 +1,75 @@
1# Copyright 2017-2021 NXP
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Installs i.MX-specific kernel headers"
5DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \
6New headers are installed in ${includedir}/imx."
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
9
10SRCBRANCH = "lf-5.15.y"
11LOCALVERSION = "-5.15.5-1.0.0"
12SRC_URI = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
13SRCREV = "c1084c2773fc1005ed140db625399d5334d94a28"
14
15S = "${WORKDIR}/git"
16
17do_configure[noexec] = "1"
18
19do_compile[noexec] = "1"
20
21IMX_UAPI_HEADERS = " \
22 dma-buf.h \
23 hantrodec.h \
24 hx280enc.h \
25 ipu.h \
26 isl29023.h \
27 imx_vpu.h \
28 mxc_asrc.h \
29 mxc_dcic.h \
30 mxc_mlb.h \
31 mxc_sim_interface.h \
32 mxc_v4l2.h \
33 mxcfb.h \
34 pxp_device.h \
35 pxp_dma.h \
36 version.h \
37 videodev2.h \
38"
39
40do_install() {
41 # We install all headers inside of B so we can copy only the
42 # whitelisted ones, and there is no risk of a new header to be
43 # installed by mistake.
44 oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix}
45
46 # Kernel should not be exporting this header
47 rm -f ${D}${exec_prefix}/include/scsi/scsi.h
48
49 # The ..install.cmd conflicts between various configure runs
50 find ${D}${includedir} -name ..install.cmd | xargs rm -f
51
52 # Install whitelisted headers only
53 for h in ${IMX_UAPI_HEADERS}; do
54 install -D -m 0644 ${B}${includedir}/linux/$h \
55 ${D}${includedir}/imx/linux/$h
56 done
57}
58
59# Allow to build empty main package, this is required in order for -dev package
60# to be propagated into the SDK
61#
62# Without this setting the RDEPENDS in other recipes fails to find this
63# package, therefore causing the -dev package also to be skipped effectively not
64# populating it into SDK
65ALLOW_EMPTY:${PN} = "1"
66
67INHIBIT_DEFAULT_DEPS = "1"
68DEPENDS += "unifdef-native bison-native rsync-native"
69
70PACKAGE_ARCH = "${MACHINE_SOCARCH}"
71
72# Restrict this recipe to NXP BSP only, this recipe is not compatible
73# with mainline BSP
74COMPATIBLE_HOST = '(null)'
75COMPATIBLE_HOST:use-nxp-bsp = '.*'