summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc_6.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-fslc_6.6.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc_6.6.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-fslc_6.6.bb b/recipes-kernel/linux/linux-fslc_6.6.bb
new file mode 100644
index 00000000..3365f778
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc_6.6.bb
@@ -0,0 +1,39 @@
1# Copyright (C) 2012-2019 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms)
3#
4# SPDX-License-Identifier: MIT
5#
6
7SUMMARY = "FSL Community BSP Linux mainline based kernel with backported features and fixes"
8DESCRIPTION = "Linux kernel based on mainline kernel used by FSL Community BSP in order to \
9provide support for some backported features and fixes, or because it was applied in linux-next \
10and takes some time to become part of a stable version, or because it is not applicable for \
11upstreaming."
12
13require linux-imx.inc
14
15SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
16
17# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
18# required by kernel-yocto.bbclass.
19#
20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
21# should be updated once patchlevel is merged.
22LINUX_VERSION = "6.6"
23
24KBRANCH = "6.6.x+fslc"
25SRCREV = "34836895e19e910f736b06d7dbe522f4a33857f8"
26
27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
28KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
29KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
30KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v6_v7_defconfig"
31KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v6_v7_defconfig"
32KBUILD_DEFCONFIG:mx8-generic-bsp = "defconfig"
33KBUILD_DEFCONFIG:mx9-generic-bsp = "defconfig"
34KBUILD_DEFCONFIG:mxs-generic-bsp = "mxs_defconfig"
35KBUILD_DEFCONFIG:vf-generic-bsp = "imx_v6_v7_defconfig"
36
37LOCALVERSION = "-fslc"
38
39COMPATIBLE_MACHINE = "(imx-generic-bsp)"