summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc-imx_6.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-fslc-imx_6.6.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.6.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.6.bb b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
new file mode 100644
index 00000000..6e31c1e2
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
@@ -0,0 +1,78 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2#
3# SPDX-License-Identifier: MIT
4#
5
6SUMMARY = "Linux Kernel provided by NXP and supported by Community"
7DESCRIPTION = "Linux Kernel provided by NXP as the part of release distribution. \
8Main focus is set on i.MX Family Reference Boards. \
9It includes support for many NXP Proprietary IPs (GPU, VPU, IPU). \
10Latest stable Kernel patchlevel is applied and maintained by Community."
11
12###############################################################################
13# This recipe (and corresponding kernel repository and branch) receives updates
14# from 3 different sources:
15# 1. Stable [linux-6.1.y] branch updates of korg;
16# 2. NXP-specific updates via branch [lf-6.1.y] shared via GitHub NXP repo;
17# 3. Critical patches, which are not (yet) integrated into either of 2 above
18# sources, but are required to be applied to the kernel tree.
19#
20# Therefore, there is a need to keep track on the patches which are introduced
21# from every source. This could be achieved in this recipe by filling the
22# below list with the information once the update is performed from any source.
23#
24# Once the critical patch gets merged into the stable branch, or NXP-specific
25# patches would be covered by the tag - individual entries from sections below
26# could be removed.
27#
28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------
31# tag: v6.1.70
32#
33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s))
35# ------------------------------------------------------------------------------
36# tag: lf-6.1.55-2.2.0
37#
38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------
41# - 77a660738af5 Revert "net: stmmac: fix FPE events losing"
42# - d9e9cb8ce9bc hx280enc_vc8000e: fix misplaced #endif
43# - 3f1f2ea72955 mxc: gpu-viv: change _QuerySignal() return type to gceSTATUS
44# - b73c6797ee42 ARM: imx_v7_defconfig: Remove KERNEL_LZO config
45# - ec33c7fc43be touchscreen: Kconfig: add I2C dependency for CT36X
46# - 6c41233a2cfb pwm: pwm-adp5585: fix get_state callback prototype
47# - 9c7540ecb891 pwm: pwm-rpmsg-imx: fix get_state callback prototype
48#
49# NOTE to upgraders:
50# This recipe should NOT collect individual patches, they should be applied to
51# the linux-fslc kernel tree on the corresponding branch, and tracking
52# information should be properly filled in above.
53###############################################################################
54
55require linux-imx.inc
56
57KBRANCH = "6.6-1.0.x-imx"
58SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
59SRCREV = "ccf0a99701a701fb48a04e31ffe3f9d585a8374a"
60
61# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
62# required by kernel-yocto.bbclass.
63#
64# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
65# should be updated once patchlevel is merged.
66LINUX_VERSION = "6.6.3"
67
68KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
69KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"
70KBUILD_DEFCONFIG:mx8-generic-bsp = "imx_v8_defconfig"
71KBUILD_DEFCONFIG:mx9-generic-bsp = "imx_v8_defconfig"
72
73# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
74LOCALVERSION = "-lf-6.6.y"
75
76DEFAULT_PREFERENCE = "1"
77
78COMPATIBLE_MACHINE = "(imx-nxp-bsp)"