summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc-imx_6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-fslc-imx_6.1.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.1.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.1.bb b/recipes-kernel/linux/linux-fslc-imx_6.1.bb
new file mode 100644
index 00000000..8e8b5424
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc-imx_6.1.bb
@@ -0,0 +1,68 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2#
3# SPDX-License-Identifier: MIT
4#
5
6SUMMARY = "Linux Kernel provided by NXP and supported by Community"
7DESCRIPTION = "Linux Kernel provided by NXP as the part of release distribution. \
8Main focus is set on i.MX Family Reference Boards. \
9It includes support for many NXP Proprietary IPs (GPU, VPU, IPU). \
10Latest stable Kernel patchlevel is applied and maintained by Community."
11
12###############################################################################
13# This recipe (and corresponding kernel repository and branch) receives updates
14# from 3 different sources:
15# 1. Stable [linux-6.1.y] branch updates of korg;
16# 2. NXP-specific updates via branch [lf-6.1.y] shared via GitHub NXP repo;
17# 3. Critical patches, which are not (yet) integrated into either of 2 above
18# sources, but are required to be applied to the kernel tree.
19#
20# Therefore, there is a need to keep track on the patches which are introduced
21# from every source. This could be achieved in this recipe by filling the
22# below list with the information once the update is performed from any source.
23#
24# Once the critical patch gets merged into the stable branch, or NXP-specific
25# patches would be covered by the tag - individual entries from sections below
26# could be removed.
27#
28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------
31# tag: v6.1.24
32#
33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s))
35# ------------------------------------------------------------------------------
36# tag: lf-6.1.1-1.0.0
37#
38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------
41#
42# NOTE to upgraders:
43# This recipe should NOT collect individual patches, they should be applied to
44# the linux-fslc kernel tree on the corresponding branch, and tracking
45# information should be properly filled in above.
46###############################################################################
47
48include linux-fslc.inc
49
50LICENSE = "GPL-2.0-only"
51LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
52
53KBRANCH = "6.1-1.0.x-imx"
54SRCREV = "897d73a656fe33d0c4549c5de1d07797f99d6871"
55
56# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
57# required by kernel-yocto.bbclass.
58#
59# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
60# should be updated once patchlevel is merged.
61LINUX_VERSION = "6.1.24"
62
63# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
64LOCALVERSION = "-6.1.24-1.0.0"
65
66DEFAULT_PREFERENCE = "1"
67
68COMPATIBLE_MACHINE = "(imx-nxp-bsp)"