summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc-imx_5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-fslc-imx_5.4.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.4.bb103
1 files changed, 0 insertions, 103 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
deleted file mode 100644
index 83621e1b..00000000
--- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb
+++ /dev/null
@@ -1,103 +0,0 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2#
3# SPDX-License-Identifier: MIT
4#
5
6SUMMARY = "Linux Kernel provided by NXP and supported by Community"
7DESCRIPTION = "Linux Kernel provided by NXP as the part of release distribution. \
8Main focus is set on i.MX Family Reference Boards. \
9It includes support for many NXP Proprietary IPs (GPU, VPU, IPU). \
10Latest stable Kernel patchlevel is applied and maintained by Community."
11
12###############################################################################
13# This recipe (and corresponding kernel repository and branch) receives updates
14# from 3 different sources:
15# 1. Stable [linux-5.4.y] branch updates of korg;
16# 2. NXP-specific updates via branch [5.4-2.2.x-imx] shared via CodeAurora forum;
17# 3. Critical patches, which are not (yet) integrated into either of 2 above
18# sources, but are required to be applied to the kernel tree.
19#
20# Therefore, there is a need to keep track on the patches which are introduced
21# from every source. This could be achieved in this recipe by filling the
22# below list with the information once the update is performed from any source.
23#
24# Once the critical patch gets merged into the stable branch, or NXP-specific
25# patches would be covered by the tag - individual entries from sections below
26# could be removed.
27#
28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------
31# tag: v5.4.147
32#
33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s))
35# ------------------------------------------------------------------------------
36# tag: rel_imx_5.4.70_2.3.2
37#
38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------
41# 48afde5dc8ee LF-2692: clk: imx: scu: Do not enable runtime PM for CPU clks
42# dc760ca6a531 MLK-25468: seco_mu: hook v2x reset event
43# fee1ade052eb MPSDK-172 remoteproc: imx_rproc: Re-building communication channels when a remote crashes
44# b93083071e9f MLK-23277: 8qm: Fix SW workaround for i.MX8QM TKT340553
45# edfc37d93d8d MLK-25444: arch: arm64: dts: imx8dxl: Fix lcdif nodes
46# 319f1755edf3 MLK-25105-2: dts: arm64: imx8mp-ab2: use AK5552 compatible for sound card
47# 1e306d7fbb17 MLK-25105-1: dts: arm64: imx8mp-ab2: ensure SAI3 RX not in sync with TX
48# 67355ffc4af7 MLK-25103: ASoC: wm8524: avoid EPROBE_DEFER log
49# 090f71d23f8f clk: imx: add mux ops for i.MX8M composite clk
50# a7466010c566 LF-3623: media: imx8: isi: fix Can't match soc version
51# 398435ef11d7 MLK-25427 arm64: dts: imx8mp: add power-domains to irqsteer hdmi
52# 3125360c70f2 LF-3132: dmaengine: imx-sdma: raise up channel0 priority after resume
53# eddc2ac1d148 MLK-25116-2: dmaengine: imx-sdma: correct iram_pool check point
54# c53ff3924c06 MLK-25116-1: dmaengine: imx-sdma: save iram pool for bd allocated
55# 09370995212a MLK-25426 remoteproc: imx_rproc: fix firmware reload
56# b598b85172f7 irq-imx-irqsteer: fix compile error if CONFIG_PM_SLEEP is not set
57# 845099bfd0b8 fbdev: fix fbinfo flag dropped upstream
58# 847bfb09bb3b arm64: dts: imx8m: change ocotp node name on i.MX8M SoCs
59# d7ca6973c6d4 arm64: dts: imx8mm: Remove incorrect fallback compatible for ocotp
60# 539d19f12066 arm: imx: include i.MX6SX DDR freq implementation for i.MX6UL
61# 169b71ce3f8a arm: imx: do not include smp_wfe_imx6.S for i.MX6SX
62# 60be4c625594 arm: imx: enable HAVE_IMX_BUSFREQ for i.MX6
63# f393781fa575 arm: imx: do not build busfreq without HAVE_IMX_BUSFREQ
64# e0e74faf6af4 ARM: dts: imx6ul-kontron-n6x1x-s: Remove an obsolete comment and fix indentation
65# ad24781aecc3 ARM: dts: imx6ul-kontron-n6x1x-s: Add vbus-supply and overcurrent polarity to usb nodes
66# d56aa09ed0e0 ARM: dts: imx6ul-kontron-n6x1x: Add 'chosen' node with 'stdout-path'
67# 923bc9e57b24 ARM: dts: Add support for two more Kontron evalkit boards 'N6311 S' and 'N6411 S'
68# f952a6404d10 ARM: dts: imx6ul-kontron-n6310-s: Move common nodes to a separate file
69# 1fdb6565a632 ARM: dts: Add support for two more Kontron SoMs N6311 and N6411
70# 4fb833f01c30 ARM: dts: imx6ul-kontron-n6310: Move common SoM nodes to a separate file
71# 54c975dabcde ARM: imx: Fix boot crash if ocotp is not found
72# 1041cd02b33c ARM: imx: Correct ocotp id for serial number support of i.MX6ULL/ULZ SoCs
73# 974b100d789c soc: imx-scu: Using existing serial_number instead of UID
74# 6fbfed9afe99 soc: imx8: Using existing serial_number instead of UID
75# 64d8ea803af5 ARM: imx: Add serial number support for i.MX6/7 SoCs
76#
77# NOTE to upgraders:
78# This recipe should NOT collect individual patches, they should be applied to
79# the linux-fslc kernel tree on the corresponding branch, and tracking
80# information should be properly filled in above.
81###############################################################################
82
83include linux-fslc.inc
84
85LICENSE = "GPLv2"
86LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
87
88KBRANCH = "5.4-2.3.x-imx"
89SRCREV = "aad410850445424f566e57a419527b6e2d3ab42d"
90
91# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
92# required by kernel-yocto.bbclass.
93#
94# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
95# should be updated once patchlevel is merged.
96LINUX_VERSION = "5.4.147"
97
98# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
99LOCALVERSION = "-5.4.70-2.3.0"
100
101DEFAULT_PREFERENCE = "1"
102
103COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"