summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc-imx_5.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-fslc-imx_5.15.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.15.bb87
1 files changed, 87 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.15.bb b/recipes-kernel/linux/linux-fslc-imx_5.15.bb
new file mode 100644
index 00000000..23acf357
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc-imx_5.15.bb
@@ -0,0 +1,87 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2#
3# SPDX-License-Identifier: MIT
4#
5
6SUMMARY = "Linux Kernel provided by NXP and supported by Community"
7DESCRIPTION = "Linux Kernel provided by NXP as the part of release distribution. \
8Main focus is set on i.MX Family Reference Boards. \
9It includes support for many NXP Proprietary IPs (GPU, VPU, IPU). \
10Latest stable Kernel patchlevel is applied and maintained by Community."
11
12###############################################################################
13# This recipe (and corresponding kernel repository and branch) receives updates
14# from 3 different sources:
15# 1. Stable [linux-5.15.y] branch updates of korg;
16# 2. NXP-specific updates via branch [5.10-2.1.x-imx] shared via CodeAurora forum;
17# 3. Critical patches, which are not (yet) integrated into either of 2 above
18# sources, but are required to be applied to the kernel tree.
19#
20# Therefore, there is a need to keep track on the patches which are introduced
21# from every source. This could be achieved in this recipe by filling the
22# below list with the information once the update is performed from any source.
23#
24# Once the critical patch gets merged into the stable branch, or NXP-specific
25# patches would be covered by the tag - individual entries from sections below
26# could be removed.
27#
28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------
31# tag: v5.15.44
32#
33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s))
35# ------------------------------------------------------------------------------
36# tag: lf-5.15.5-1.0.0
37#
38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------
41# 78a61d752a68 ("staging: fsl_ppfe: reduce MAC address filtering loglevel to debug")
42# 119775ff0b40 ("staging: fsl_ppfe: assign correct OF nodes to individual ports")
43# f696b8a03198 ("staging: fsl_ppfe: handle all RGMII modes in pfe_eth_adjust_link")
44# 069a8e1cde93 ("PCI: dwc: PCI_IMX6 must depend on PCIE_DW")
45# ea15f0d0fd08 ("usb: chipidea: fix missing chipidea.h include")
46# a30d0e4c26da ("ARM: imx: select MAILBOX with IMX_MBOX")
47# 162f5592d475 ("gpu: drm: allow enabling DRM_IMX on Layerscape SoCs")
48# af7065ca8e07 ("ARM: dts: imx7s: revert LCDIF AXI clock to IMX7D_LCDIF_PIXEL_ROOT_CLK")
49# df227a18343f ("ARM: imx: add missing debug_ll_io_init to i.MX6UL map_io")
50# c874471ab39e ("i2c: imx: remove unneeded libata include")
51# 651e1f69ef7b ("i2c: imx: fix lockdep issue")
52# bee6315aac16 ("i2c: imx: avoid taking clk_prepare mutex in PM callbacks (again)")
53# 6a8f8108c8ce ("arch/arm64/boot/dts/freescale: fix file permissions on dts files")
54# 11f0faaa75ec ("irq-imx-irqsteer: fix compile error if CONFIG_PM_SLEEP is not set")
55# d17efc542bf0 ("arm: imx: include i.MX6SX DDR freq implementation for i.MX6UL")
56# d99fa7fc4edc ("arm: imx: do not include smp_wfe_imx6.S for i.MX6SX")
57# a5a2dd0a75fc ("arm: imx: enable HAVE_IMX_BUSFREQ for i.MX6")
58# f40d20ee44da ("arm: imx: do not build busfreq without HAVE_IMX_BUSFREQ")
59# 96bb4e4ffa01 ("ARM: dts: imx7s: fix ARM timer definition")
60#
61# NOTE to upgraders:
62# This recipe should NOT collect individual patches, they should be applied to
63# the linux-fslc kernel tree on the corresponding branch, and tracking
64# information should be properly filled in above.
65###############################################################################
66
67include linux-fslc.inc
68
69LICENSE = "GPL-2.0-only"
70LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
71
72KBRANCH = "5.15-1.0.x-imx"
73SRCREV = "b50631283754487dee1b9f5f8dd827d6e3d628c1"
74
75# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
76# required by kernel-yocto.bbclass.
77#
78# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
79# should be updated once patchlevel is merged.
80LINUX_VERSION = "5.15.44"
81
82# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
83LOCALVERSION = "-5.15.5-1.0.0"
84
85DEFAULT_PREFERENCE = "1"
86
87COMPATIBLE_MACHINE = "(imx-nxp-bsp)"