diff options
Diffstat (limited to 'recipes-kernel/kernel-modules')
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-ceetm_git.bb | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-ceetm_git.bb b/recipes-kernel/kernel-modules/kernel-module-ceetm_git.bb new file mode 100644 index 00000000..5d89531f --- /dev/null +++ b/recipes-kernel/kernel-modules/kernel-module-ceetm_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "CEETM TC QDISC" | ||
2 | LICENSE = "GPLv2 & BSD" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287" | ||
4 | |||
5 | inherit module qoriq_build_64bit_kernel | ||
6 | |||
7 | SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;nobranch=1" | ||
8 | SRCREV = "ecf55c9ca0cd42a212653e1f99c19cd611e3a008" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}" | ||
13 | export KERNEL_PATH = "${STAGING_KERNEL_DIR}" | ||
14 | |||
15 | do_configure[depends] += "virtual/kernel:do_shared_workdir" | ||
16 | do_configure_prepend () { | ||
17 | sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/ceetm_module/Makefile | ||
18 | } | ||
19 | |||
20 | do_install(){ | ||
21 | mkdir -p ${D}/usr/driver/ceetm | ||
22 | mkdir -p ${D}/${libdir}/tc | ||
23 | cp ${S}/bin/ceetm.ko ${D}/usr/driver/ceetm | ||
24 | cp ${S}/bin/q_ceetm.so ${D}/${libdir}/tc/. | ||
25 | } | ||
26 | |||
27 | FILES_${PN} += "/usr/driver/ceetm ${libdir}/tc" | ||
28 | INHIBIT_PACKAGE_STRIP = "1" | ||
29 | |||
30 | COMPATIBLE_MACHINE = "(e6500-64b|t1040rdb|t1040rdb-64b|t1042rdb|t1042rdb-64b)" | ||