summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb
new file mode 100644
index 00000000..343cce41
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb
@@ -0,0 +1,26 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2# Copyright (C) 2017-2021 NXP
3
4SUMMARY = "Kernel loadable module for Vivante GPU"
5DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
6allowing flexibility to use a newer graphics release with an older kernel."
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
9
10SRCBRANCH = "lf-5.10.y"
11LOCALVERSION = "-5.10.52-2.1.0"
12KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https"
13SRC_URI = " \
14 ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
15 file://Add-makefile.patch \
16"
17SRCREV = "d46e3cd94bdd2c13b6511e008ad9719b0727637d"
18
19S = "${WORKDIR}/git"
20
21inherit module
22
23EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
24
25KERNEL_MODULE_AUTOLOAD = "galcore"
26COMPATIBLE_MACHINE = "(imx)"