diff options
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 12 |
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index 5030e7a3..f8cf1bce 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -18,6 +18,17 @@ USE_VIV_LIBGL_mx6q = "yes" | |||
18 | USE_VIV_LIBGL_mx6dl = "yes" | 18 | USE_VIV_LIBGL_mx6dl = "yes" |
19 | USE_VIV_LIBGL_mx6sx = "yes" | 19 | USE_VIV_LIBGL_mx6sx = "yes" |
20 | 20 | ||
21 | # FIXME: mesa should support 'x11-no-tls' option | ||
22 | python () { | ||
23 | overrides = d.getVar("OVERRIDES", True).split(":") | ||
24 | if "mx6" not in overrides: | ||
25 | return | ||
26 | |||
27 | extra_oeconf = d.getVar("EXTRA_OECONF", True) | ||
28 | extra_oeconf = extra_oeconf.replace("--enable-glx-tls", "--enable-glx") | ||
29 | d.setVar("EXTRA_OECONF", extra_oeconf) | ||
30 | } | ||
31 | |||
21 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary | 32 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary |
22 | do_install_append_mx6 () { | 33 | do_install_append_mx6 () { |
23 | if [ "${USE_VIV_LIBGL}" = "yes" ]; then | 34 | if [ "${USE_VIV_LIBGL}" = "yes" ]; then |
@@ -26,4 +37,3 @@ do_install_append_mx6 () { | |||
26 | ${D}${includedir}/GL/glext.h | 37 | ${D}${includedir}/GL/glext.h |
27 | fi | 38 | fi |
28 | } | 39 | } |
29 | EXTRA_OECONF_mx6 := "${@'${EXTRA_OECONF}'.replace('--enable-glx-tls','--enable-glx')}" | ||