summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston_5.0.0.imx.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/recipes-graphics/wayland/weston_5.0.0.imx.bb b/recipes-graphics/wayland/weston_5.0.0.imx.bb
index 9f32d94a..e9f354f0 100644
--- a/recipes-graphics/wayland/weston_5.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_5.0.0.imx.bb
@@ -102,6 +102,9 @@ PACKAGECONFIG[imxg2d] = "--enable-imxg2d,--disable-imxg2d,virtual/libg2d"
102# Weston with OpenGL support 102# Weston with OpenGL support
103PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl" 103PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl"
104 104
105# Set to install a default weston.ini file
106WESTON_INI_INSTALL_FILE = "${B}/weston.ini"
107
105do_install_append() { 108do_install_append() {
106 # Weston doesn't need the .la files to load modules, so wipe them 109 # Weston doesn't need the .la files to load modules, so wipe them
107 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la 110 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la
@@ -120,13 +123,8 @@ do_install_append() {
120 fi 123 fi
121 124
122 # install default weston.ini 125 # install default weston.ini
123 if [ -n "${@bb.utils.filter('BBFILE_COLLECTIONS', 'aglprofilegraphical', d)}" ]; then 126 if [ "${WESTON_INI_INSTALL_FILE}" != "" ]; then
124 if [ "${@bb.utils.filter('BBFILE_COLLECTIONS', 'ivi', d)}" ]; then 127 install -D -m 0644 ${WESTON_INI_INSTALL_FILE} ${D}${sysconfdir}/xdg/weston/weston.ini
125 WESTON_INI_SRCDIR=${B}/ivi-shell
126 else
127 WESTON_INI_SRCDIR=${B}
128 fi
129 install -D -m 0644 ${WESTON_INI_SRCDIR}/weston.ini ${D}${sysconfdir}/xdg/weston/weston.ini
130 fi 128 fi
131} 129}
132 130