diff options
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb | 2 | ||||
-rw-r--r-- | recipes-graphics/xorg-driver/xorg-driver-common.inc | 40 | ||||
-rw-r--r-- | recipes-graphics/xorg-driver/xorg-driver-video.inc | 4 |
3 files changed, 1 insertions, 45 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb b/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb index 038c421d..996a9c7f 100644 --- a/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb +++ b/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | require xorg-driver-video.inc | 1 | require recipes-graphics/xorg-driver/xorg-driver-video.inc |
2 | LIC_FILES_CHKSUM = "file://COPYING;md5=d8cbd99fff773f92e844948f74ef0df8" | 2 | LIC_FILES_CHKSUM = "file://COPYING;md5=d8cbd99fff773f92e844948f74ef0df8" |
3 | 3 | ||
4 | DESCRIPTION = "X.Org X server -- fbdev display driver" | 4 | DESCRIPTION = "X.Org X server -- fbdev display driver" |
diff --git a/recipes-graphics/xorg-driver/xorg-driver-common.inc b/recipes-graphics/xorg-driver/xorg-driver-common.inc deleted file mode 100644 index c0f4a15a..00000000 --- a/recipes-graphics/xorg-driver/xorg-driver-common.inc +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | DESCRIPTION = "X driver" | ||
2 | HOMEPAGE = "http://www.x.org" | ||
3 | SECTION = "x11/drivers" | ||
4 | LICENSE = "MIT-X" | ||
5 | INC_PR = "r15" | ||
6 | |||
7 | DEPENDS = "randrproto virtual/xserver-xf86 xproto" | ||
8 | |||
9 | SRC_URI = "${XORG_MIRROR}/individual/driver/${BPN}-${PV}.tar.bz2" | ||
10 | |||
11 | S = "${WORKDIR}/${BPN}-${PV}" | ||
12 | |||
13 | FILES_${PN} += " ${libdir}/xorg/modules" | ||
14 | FILES_${PN}-dbg += "${libdir}/xorg/modules/*/.debug" | ||
15 | |||
16 | inherit autotools pkgconfig | ||
17 | |||
18 | TARGET_CPPFLAGS += "-I${STAGING_DIR_HOST}/usr/include/xorg" | ||
19 | |||
20 | # Another sucky behavor from Xorg configure scripts. | ||
21 | # They use AC_CHECK_FILE to check for DRI headers. Yuck! | ||
22 | # Of course this will blow up when cross compiling. | ||
23 | |||
24 | do_configure_prepend() { | ||
25 | incdir=${layout_includedir}/xorg | ||
26 | for f in dri.h sarea.h dristruct.h exa.h damage.h xf86Module.h; do | ||
27 | path="$incdir/$f" | ||
28 | if [ -f "${STAGING_DIR_HOST}/$path" ]; then | ||
29 | p=`echo "$path" | sed 'y%*+%pp%;s%[^_[:alnum:]]%_%g'` | ||
30 | eval "export ac_cv_file_$p=yes" | ||
31 | fi | ||
32 | done | ||
33 | } | ||
34 | |||
35 | # FIXME: We don't want to include the libtool archives (*.la) from modules | ||
36 | # directory, as they serve no useful purpose. Upstream should fix Makefile.am | ||
37 | do_install_append() { | ||
38 | find ${D}${libdir}/xorg/modules -regex ".*\.la$" | xargs rm -f -- | ||
39 | } | ||
40 | |||
diff --git a/recipes-graphics/xorg-driver/xorg-driver-video.inc b/recipes-graphics/xorg-driver/xorg-driver-video.inc deleted file mode 100644 index bce8c9a7..00000000 --- a/recipes-graphics/xorg-driver/xorg-driver-video.inc +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | include xorg-driver-common.inc | ||
2 | |||
3 | DEPENDS = "randrproto renderproto videoproto xextproto fontsproto xproto" | ||
4 | |||