summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-init/imxdrm/weston.config1
-rw-r--r--recipes-graphics/wayland/weston-init/mx8mm/weston.config1
-rw-r--r--recipes-graphics/wayland/weston/0001-weston.ini-using-argb8888-as-gbm-default-on-mscale-8.patch26
-rw-r--r--recipes-graphics/wayland/weston/0002-weston.ini-configure-desktop-shell-size-in-weston-co.patch28
-rw-r--r--recipes-graphics/wayland/weston/imx/weston.ini20
-rw-r--r--recipes-graphics/wayland/weston/mx8mq/weston.ini24
-rw-r--r--recipes-graphics/wayland/weston_5.0.0.imx.bb5
7 files changed, 58 insertions, 47 deletions
diff --git a/recipes-graphics/wayland/weston-init/imxdrm/weston.config b/recipes-graphics/wayland/weston-init/imxdrm/weston.config
index 5693d6cb..7c92cf11 100644
--- a/recipes-graphics/wayland/weston-init/imxdrm/weston.config
+++ b/recipes-graphics/wayland/weston-init/imxdrm/weston.config
@@ -1,3 +1,2 @@
1#!/bin/sh 1#!/bin/sh
2OPTARGS="--xwayland" 2OPTARGS="--xwayland"
3DESKTOP_SHELL_WINDOW=1920x1080
diff --git a/recipes-graphics/wayland/weston-init/mx8mm/weston.config b/recipes-graphics/wayland/weston-init/mx8mm/weston.config
index eb990e40..060aae09 100644
--- a/recipes-graphics/wayland/weston-init/mx8mm/weston.config
+++ b/recipes-graphics/wayland/weston-init/mx8mm/weston.config
@@ -1,3 +1,2 @@
1#!/bin/sh 1#!/bin/sh
2OPTARGS="--xwayland --use-g2d=1" 2OPTARGS="--xwayland --use-g2d=1"
3DESKTOP_SHELL_WINDOW=1920x1080
diff --git a/recipes-graphics/wayland/weston/0001-weston.ini-using-argb8888-as-gbm-default-on-mscale-8.patch b/recipes-graphics/wayland/weston/0001-weston.ini-using-argb8888-as-gbm-default-on-mscale-8.patch
new file mode 100644
index 00000000..e951ce12
--- /dev/null
+++ b/recipes-graphics/wayland/weston/0001-weston.ini-using-argb8888-as-gbm-default-on-mscale-8.patch
@@ -0,0 +1,26 @@
1From 4ab82e531d01c3c1f45a4f099d145cde2890a0d5 Mon Sep 17 00:00:00 2001
2From: Haihua Hu <jared.hu@nxp.com>
3Date: Wed, 4 Jul 2018 16:05:20 +0800
4Subject: [PATCH] weston.ini: using argb8888 as gbm default on mscale 850D
5
6mscale 850D video playback need using pixel alpha for graphic layer
7
8upstream status: imx specific
9Signed-off-by: Haihua Hu <jared.hu@nxp.com>
10
11---
12 weston.ini.in | 1 +
13 1 file changed, 1 insertion(+)
14
15Index: git/weston.ini.in
16===================================================================
17--- git.orig/weston.ini.in
18+++ git/weston.ini.in
19@@ -2,6 +2,7 @@
20 # i.MX: Disable idle timeout
21 idle-time=0
22 #use-g2d=1
23+gbm-format=argb8888
24
25 #[output]
26 #name=HDMI-A-1
diff --git a/recipes-graphics/wayland/weston/0002-weston.ini-configure-desktop-shell-size-in-weston-co.patch b/recipes-graphics/wayland/weston/0002-weston.ini-configure-desktop-shell-size-in-weston-co.patch
new file mode 100644
index 00000000..4aa32569
--- /dev/null
+++ b/recipes-graphics/wayland/weston/0002-weston.ini-configure-desktop-shell-size-in-weston-co.patch
@@ -0,0 +1,28 @@
1From 3012798d7e9c9e624024fc962d749a960289ad8b Mon Sep 17 00:00:00 2001
2From: Haihua Hu <jared.hu@nxp.com>
3Date: Wed, 11 Jul 2018 17:47:47 +0800
4Subject: [PATCH] weston.ini: configure desktop shell size in weston configure
5 file
6
7mscale 850D need set desktop shell to 1080p
8
9upstream status: imx specific
10Signed-off-by: Haihua Hu <jared.hu@nxp.com>
11
12---
13 weston.ini.in | 2 ++
14 1 file changed, 2 insertions(+)
15
16diff --git a/weston.ini.in b/weston.ini.in
17index bd8abe4..077155b 100644
18--- a/weston.ini.in
19+++ b/weston.ini.in
20@@ -8,6 +8,8 @@ gbm-format=argb8888
21 #mode=1920x1080@60
22 #transform=90
23
24+[shell]
25+size=1920x1080
26
27 #[output]
28 #name=HDMI-A-2
diff --git a/recipes-graphics/wayland/weston/imx/weston.ini b/recipes-graphics/wayland/weston/imx/weston.ini
deleted file mode 100644
index d6ad40df..00000000
--- a/recipes-graphics/wayland/weston/imx/weston.ini
+++ /dev/null
@@ -1,20 +0,0 @@
1[core]
2# i.MX: Disable idle timeout
3idle-time=0
4
5#[output]
6#name=HDMI-A-1
7#mode=1920x1080@60
8#transform=90
9
10#[output]
11#name=HDMI-A-2
12#mode=off
13# WIDTHxHEIGHT Resolution size width and height in pixels
14# off Disables the output
15# preferred Uses the preferred mode
16# current Uses the current crt controller mode
17#transform=90
18
19[screen-share]
20command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize
diff --git a/recipes-graphics/wayland/weston/mx8mq/weston.ini b/recipes-graphics/wayland/weston/mx8mq/weston.ini
deleted file mode 100644
index d1597a42..00000000
--- a/recipes-graphics/wayland/weston/mx8mq/weston.ini
+++ /dev/null
@@ -1,24 +0,0 @@
1[core]
2# i.MX: Disable idle timeout
3idle-time=0
4gbm-format=argb8888
5
6#[output]
7#name=HDMI-A-1
8#mode=1920x1080@60
9#transform=90
10
11[shell]
12size=1920x1080
13
14#[output]
15#name=HDMI-A-2
16#mode=off
17# WIDTHxHEIGHT Resolution size width and height in pixels
18# off Disables the output
19# preferred Uses the preferred mode
20# current Uses the current crt controller mode
21#transform=90
22
23[screen-share]
24command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize
diff --git a/recipes-graphics/wayland/weston_5.0.0.imx.bb b/recipes-graphics/wayland/weston_5.0.0.imx.bb
index 11da2872..032972fa 100644
--- a/recipes-graphics/wayland/weston_5.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_5.0.0.imx.bb
@@ -9,13 +9,16 @@ DEFAULT_PREFERENCE = "-1"
9 9
10SRCBRANCH = "weston-imx-5.0" 10SRCBRANCH = "weston-imx-5.0"
11SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} \ 11SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} \
12 file://weston.ini \
13 file://weston.png \ 12 file://weston.png \
14 file://weston.desktop \ 13 file://weston.desktop \
15 file://0001-make-error-portable.patch \ 14 file://0001-make-error-portable.patch \
16 file://xwayland.weston-start \ 15 file://xwayland.weston-start \
17 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ 16 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
18" 17"
18# Use argb8888 as gbm-format for i.MX8MQ only
19SRC_URI_append_mx8mq = " file://0001-weston.ini-using-argb8888-as-gbm-default-on-mscale-8.patch \
20 file://0002-weston.ini-configure-desktop-shell-size-in-weston-co.patch \
21"
19SRCREV = "fb563901657b296c7c7c86d26602a622429e334f" 22SRCREV = "fb563901657b296c7c7c86d26602a622429e334f"
20S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
21 24