diff options
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0001-dlsym-workaround-glibc-2.34-build-failure.patch | 33 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb | 7 |
2 files changed, 36 insertions, 4 deletions
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0001-dlsym-workaround-glibc-2.34-build-failure.patch b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0001-dlsym-workaround-glibc-2.34-build-failure.patch new file mode 100644 index 00000000..9f3410d7 --- /dev/null +++ b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0001-dlsym-workaround-glibc-2.34-build-failure.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From d11884c88eac803c174f759414d0162154450b6a Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.z@gmail.com> | ||
3 | Date: Thu, 2 Sep 2021 09:43:33 +0000 | ||
4 | Subject: [PATCH] dlsym: workaround glibc 2.34 build failure | ||
5 | |||
6 | As suggested in [1], upstream component does not have a solution for the | ||
7 | issue, and therefore for glibc version >= 2.34 dlsym wrappers should be | ||
8 | skipped. | ||
9 | |||
10 | Link: [1]: https://github.com/apitrace/apitrace/issues/756 | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> | ||
14 | --- | ||
15 | wrappers/dlsym.cpp | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/wrappers/dlsym.cpp b/wrappers/dlsym.cpp | ||
19 | index cdf5cfdb..4061afc4 100644 | ||
20 | --- a/wrappers/dlsym.cpp | ||
21 | +++ b/wrappers/dlsym.cpp | ||
22 | @@ -34,7 +34,7 @@ | ||
23 | #include "os.hpp" | ||
24 | |||
25 | |||
26 | -#ifdef __GLIBC__ | ||
27 | +#if defined(__GLIBC__) && !(__GLIBC__ == 2 && __GLIBC_MINOR__ >= 34) | ||
28 | |||
29 | |||
30 | #include <dlfcn.h> | ||
31 | -- | ||
32 | 2.17.1 | ||
33 | |||
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb index a6de94d2..dfa8dde7 100644 --- a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb +++ b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb | |||
@@ -4,7 +4,9 @@ LICENSE = "MIT" | |||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aeb969185a143c3c25130bc2c3ef9a50" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aeb969185a143c3c25130bc2c3ef9a50" |
5 | DEPENDS = "imx-gpu-viv zlib libpng procps" | 5 | DEPENDS = "imx-gpu-viv zlib libpng procps" |
6 | 6 | ||
7 | SRC_URI = "git://source.codeaurora.org/external/imx/apitrace-imx.git;protocol=https;branch=imx_9.0" | 7 | SRC_URI = "git://source.codeaurora.org/external/imx/apitrace-imx.git;protocol=https;branch=imx_9.0 \ |
8 | file://0001-dlsym-workaround-glibc-2.34-build-failure.patch \ | ||
9 | " | ||
8 | SRCREV = "c50e6a954e44998f2e3793a8de863e961f8008c6" | 10 | SRCREV = "c50e6a954e44998f2e3793a8de863e961f8008c6" |
9 | 11 | ||
10 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
@@ -44,6 +46,3 @@ FILES:${PN} += " \ | |||
44 | 46 | ||
45 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | 47 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |
46 | COMPATIBLE_MACHINE = "(imxgpu)" | 48 | COMPATIBLE_MACHINE = "(imxgpu)" |
47 | |||
48 | # see https://github.com/apitrace/apitrace/issues/756 | ||
49 | PNBLACKLIST[imx-gpu-apitrace] ?= "Upstream needs porting to glibc 2.34+" | ||