summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xwayland/xwayland_23.1.1.imx.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/xwayland/xwayland_23.1.1.imx.bbappend')
-rw-r--r--recipes-graphics/xwayland/xwayland_23.1.1.imx.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-graphics/xwayland/xwayland_23.1.1.imx.bbappend b/recipes-graphics/xwayland/xwayland_23.1.1.imx.bbappend
new file mode 100644
index 00000000..e1708a96
--- /dev/null
+++ b/recipes-graphics/xwayland/xwayland_23.1.1.imx.bbappend
@@ -0,0 +1,20 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3SRC_URI:append:imxgpu = " \
4 file://0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch \
5"
6
7OPENGL_PKGCONFIGS:remove:imxgpu = "${OPENGL_PKGCONFIGS_REMOVE_IMXGPU}"
8OPENGL_PKGCONFIGS_REMOVE_IMXGPU = ""
9OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx"
10OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx"
11OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx"
12
13
14# links with imx-gpu libs which are pre-built for glibc
15# gcompat will address it during runtime
16LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
17
18RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"
19
20PACKAGE_ARCH = "${MACHINE_SOCARCH}"