summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb b/recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb
deleted file mode 100644
index 1a272304..00000000
--- a/recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb
+++ /dev/null
@@ -1,65 +0,0 @@
1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
3# Copyright 2017-2018 NXP
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6require recipes-graphics/xorg-driver/xorg-driver-video.inc
7
8PE = "3"
9
10inherit autotools-brokensep update-rc.d pkgconfig
11
12DEPENDS += "virtual/xserver virtual/libx11 libgal-imx imx-gpu-viv virtual/libg2d pixman"
13
14LIC_FILES_CHKSUM = "file://COPYING-MIT;md5=b5e9d9f5c02ea831ab3ecf802bb7c4f3"
15
16SRCREV = "c828e8a7c38743e960967e7bb78c134cec31c102"
17SRCBRANCH = "imx_exa_viv6_g2d"
18SRC_URI = "git://source.codeaurora.org/external/imx/xf86-video-imx-vivante.git;protocol=https;branch=${SRCBRANCH} \
19 file://rc.autohdmi"
20
21S = "${WORKDIR}/git"
22
23INITSCRIPT_PACKAGES = "xserver-xorg-extension-viv-autohdmi"
24INITSCRIPT_NAME = "rc.autohdmi"
25INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
26
27EXTRA_OEMAKE += "prefix=${exec_prefix} \
28 sysroot=${STAGING_DIR_TARGET} \
29 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \
30 BUSID_HAS_NUMBER=1 \
31 BUILD_IN_YOCTO=1 \
32 XSERVER_GREATER_THAN_13=1"
33TARGET_CC_ARCH += "${LDFLAGS}"
34
35PACKAGES =+ "xserver-xorg-extension-viv-autohdmi"
36
37do_install:append () {
38 install -d ${D}${includedir}
39 cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir}
40 cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir}
41
42 install -d ${D}/${sysconfdir}/init.d
43 install -m 755 ${WORKDIR}/rc.autohdmi ${D}/${sysconfdir}/init.d/rc.autohdmi
44
45 find ${D}${includedir} -type f -exec chmod 660 {} \;
46}
47
48RDEPENDS:${PN} += "libvivante-dri-imx \
49 xserver-xorg-module-exa \
50 mesa-driver-swrast \
51 xserver-xorg-extension-dri \
52 xserver-xorg-extension-dri2 \
53 xserver-xorg-extension-glx"
54
55REALSOLIBS := "${SOLIBS}"
56SOLIBS = "${SOLIBSDEV}"
57
58FILES:${PN} = "${libdir}/*/*/*/vivante_drv${SOLIBS}"
59FILES:${PN}-dev = "${includedir} /usr/src ${libdir}/libfsl_x11_ext${SOLIBSDEV}"
60FILES:${PN}-dbg = "${libdir}/*/*/*/.debug ${libdir}/.debug/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/.debug/autohdmi"
61
62FILES:xserver-xorg-extension-viv-autohdmi = " ${libdir}/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/autohdmi ${sysconfdir}/init.d/rc.autohdmi"
63
64PACKAGE_ARCH = "${MACHINE_SOCARCH}"
65COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7ulp-nxp-bsp)"