summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston_9.0.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston_9.0.0.imx.bb')
-rw-r--r--recipes-graphics/wayland/weston_9.0.0.imx.bb25
1 files changed, 16 insertions, 9 deletions
diff --git a/recipes-graphics/wayland/weston_9.0.0.imx.bb b/recipes-graphics/wayland/weston_9.0.0.imx.bb
index 76296c8e..0ab2c6b2 100644
--- a/recipes-graphics/wayland/weston_9.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_9.0.0.imx.bb
@@ -3,7 +3,7 @@
3# recipe. The second section customizes the recipe for i.MX. 3# recipe. The second section customizes the recipe for i.MX.
4 4
5########### OE-core copy ################## 5########### OE-core copy ##################
6# Upstream hash: 0a882490fe75915c7a119f3498df6750be25f8e0 6# Upstream hash: c8aa0222ce2be647911114aaebcbb0d55d7caf87
7 7
8SUMMARY = "Weston, a Wayland compositor" 8SUMMARY = "Weston, a Wayland compositor"
9DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" 9DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
@@ -16,8 +16,11 @@ SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
16 file://weston.png \ 16 file://weston.png \
17 file://weston.desktop \ 17 file://weston.desktop \
18 file://xwayland.weston-start \ 18 file://xwayland.weston-start \
19 file://systemd-notify.weston-start \
19 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ 20 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
20 file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \ 21 file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \
22 file://0001-meson.build-fix-incorrect-header.patch \
23 file://0001-libweston-backend-drm-Re-order-gbm-destruction-at-DR.patch \
21" 24"
22 25
23SRC_URI:append:libc-musl = " file://dont-use-plane-add-prop.patch " 26SRC_URI:append:libc-musl = " file://dont-use-plane-add-prop.patch "
@@ -38,7 +41,7 @@ LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'lto', '-Wl,-z,undefs', '',
38 41
39WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}" 42WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}"
40 43
41EXTRA_OEMESON += "-Dbackend-default=auto -Dbackend-rdp=false -Dpipewire=false" 44EXTRA_OEMESON += "-Dbackend-default=auto -Dpipewire=false"
42 45
43PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl clients', '', d)} \ 46PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl clients', '', d)} \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \ 47 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \
@@ -64,6 +67,8 @@ PACKAGECONFIG[x11] = "-Dbackend-x11=true,-Dbackend-x11=false,virtual/libx11 libx
64PACKAGECONFIG[headless] = "-Dbackend-headless=true,-Dbackend-headless=false" 67PACKAGECONFIG[headless] = "-Dbackend-headless=true,-Dbackend-headless=false"
65# Weston on framebuffer 68# Weston on framebuffer
66PACKAGECONFIG[fbdev] = "-Dbackend-fbdev=true,-Dbackend-fbdev=false,udev mtdev" 69PACKAGECONFIG[fbdev] = "-Dbackend-fbdev=true,-Dbackend-fbdev=false,udev mtdev"
70# Weston on RDP
71PACKAGECONFIG[rdp] = "-Dbackend-rdp=true,-Dbackend-rdp=false,freerdp"
67# weston-launch 72# weston-launch
68PACKAGECONFIG[launch] = "-Dweston-launch=true,-Dweston-launch=false,drm" 73PACKAGECONFIG[launch] = "-Dweston-launch=true,-Dweston-launch=false,drm"
69# VA-API desktop recorder 74# VA-API desktop recorder
@@ -83,7 +88,7 @@ PACKAGECONFIG[colord] = "-Dcolor-management-colord=true,-Dcolor-management-color
83# Clients support 88# Clients support
84PACKAGECONFIG[clients] = "-Dsimple-clients=all -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false" 89PACKAGECONFIG[clients] = "-Dsimple-clients=all -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false"
85# Virtual remote output with GStreamer on DRM backend 90# Virtual remote output with GStreamer on DRM backend
86PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0" 91PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
87# Weston with PAM support 92# Weston with PAM support
88PACKAGECONFIG[pam] = "-Dpam=true,-Dpam=false,libpam" 93PACKAGECONFIG[pam] = "-Dpam=true,-Dpam=false,libpam"
89# Weston with screen-share support 94# Weston with screen-share support
@@ -114,6 +119,10 @@ do_install:append() {
114 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland 119 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland
115 fi 120 fi
116 121
122 if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then
123 install -Dm 644 ${WORKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify
124 fi
125
117 if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then 126 if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then
118 chmod u+s ${D}${bindir}/weston-launch 127 chmod u+s ${D}${bindir}/weston-launch
119 fi 128 fi
@@ -149,13 +158,11 @@ SUMMARY = "Weston, a Wayland compositor, i.MX fork"
149DEFAULT_PREFERENCE = "-1" 158DEFAULT_PREFERENCE = "-1"
150 159
151SRCBRANCH = "weston-imx-9.0" 160SRCBRANCH = "weston-imx-9.0"
152SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} \ 161SRC_URI:remove = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
153 file://weston.png \ 162 file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \
154 file://weston.desktop \
155 file://xwayland.weston-start \
156 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
157" 163"
158SRCREV = "230e9bc3d647e511e0601e3d45034f22495ed3c7" 164SRC_URI:prepend = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} "
165SRCREV = "26da63a46b926c8301d8c271f6869c893cc35afa"
159S = "${WORKDIR}/git" 166S = "${WORKDIR}/git"
160 167
161# Disable OpenGL for parts with GPU support for 2D but not 3D 168# Disable OpenGL for parts with GPU support for 2D but not 3D