summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston_9.0.0.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston_9.0.0.imx.bb')
-rw-r--r--recipes-graphics/wayland/weston_9.0.0.imx.bb48
1 files changed, 24 insertions, 24 deletions
diff --git a/recipes-graphics/wayland/weston_9.0.0.imx.bb b/recipes-graphics/wayland/weston_9.0.0.imx.bb
index 026f27ce..76296c8e 100644
--- a/recipes-graphics/wayland/weston_9.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_9.0.0.imx.bb
@@ -20,7 +20,7 @@ SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
20 file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \ 20 file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \
21" 21"
22 22
23SRC_URI_append_libc-musl = " file://dont-use-plane-add-prop.patch " 23SRC_URI:append:libc-musl = " file://dont-use-plane-add-prop.patch "
24 24
25SRC_URI[sha256sum] = "5cf5d6ce192e0eb15c1fc861a436bf21b5bb3b91dbdabbdebe83e1f83aa098fe" 25SRC_URI[sha256sum] = "5cf5d6ce192e0eb15c1fc861a436bf21b5bb3b91dbdabbdebe83e1f83aa098fe"
26 26
@@ -97,7 +97,7 @@ PACKAGECONFIG[shell-ivi] = "-Dshell-ivi=true,-Dshell-ivi=false"
97# JPEG image loading support 97# JPEG image loading support
98PACKAGECONFIG[image-jpeg] = "-Dimage-jpeg=true,-Dimage-jpeg=false, jpeg" 98PACKAGECONFIG[image-jpeg] = "-Dimage-jpeg=true,-Dimage-jpeg=false, jpeg"
99 99
100do_install_append() { 100do_install:append() {
101 # Weston doesn't need the .la files to load modules, so wipe them 101 # Weston doesn't need the .la files to load modules, so wipe them
102 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la 102 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la
103 103
@@ -122,23 +122,23 @@ do_install_append() {
122PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \ 122PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \
123 libweston-${WESTON_MAJOR_VERSION} ${PN}-examples" 123 libweston-${WESTON_MAJOR_VERSION} ${PN}-examples"
124 124
125FILES_${PN}-dev += "${libdir}/${BPN}/libexec_weston.so" 125FILES:${PN}-dev += "${libdir}/${BPN}/libexec_weston.so"
126FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so* ${datadir}" 126FILES:${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so* ${datadir}"
127 127
128FILES_libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so" 128FILES:libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so"
129SUMMARY_libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'." 129SUMMARY:libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'."
130 130
131FILES_${PN}-examples = "${bindir}/*" 131FILES:${PN}-examples = "${bindir}/*"
132 132
133FILES_${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so" 133FILES:${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so"
134RDEPENDS_${PN}-xwayland += "xwayland" 134RDEPENDS:${PN}-xwayland += "xwayland"
135 135
136RDEPENDS_${PN} += "xkeyboard-config" 136RDEPENDS:${PN} += "xkeyboard-config"
137RRECOMMENDS_${PN} = "weston-init liberation-fonts" 137RRECOMMENDS:${PN} = "weston-init liberation-fonts"
138RRECOMMENDS_${PN}-dev += "wayland-protocols" 138RRECOMMENDS:${PN}-dev += "wayland-protocols"
139 139
140USERADD_PACKAGES = "${PN}" 140USERADD_PACKAGES = "${PN}"
141GROUPADD_PARAM_${PN} = "--system weston-launch" 141GROUPADD_PARAM:${PN} = "--system weston-launch"
142 142
143########### End of OE-core copy ########### 143########### End of OE-core copy ###########
144 144
@@ -160,23 +160,23 @@ S = "${WORKDIR}/git"
160 160
161# Disable OpenGL for parts with GPU support for 2D but not 3D 161# Disable OpenGL for parts with GPU support for 2D but not 3D
162REQUIRED_DISTRO_FEATURES = "opengl" 162REQUIRED_DISTRO_FEATURES = "opengl"
163REQUIRED_DISTRO_FEATURES_imxgpu2d = "" 163REQUIRED_DISTRO_FEATURES:imxgpu2d = ""
164REQUIRED_DISTRO_FEATURES_imxgpu3d = "opengl" 164REQUIRED_DISTRO_FEATURES:imxgpu3d = "opengl"
165PACKAGECONFIG_OPENGL = "opengl" 165PACKAGECONFIG_OPENGL = "opengl"
166PACKAGECONFIG_OPENGL_imxgpu2d = "" 166PACKAGECONFIG_OPENGL:imxgpu2d = ""
167PACKAGECONFIG_OPENGL_imxgpu3d = "opengl" 167PACKAGECONFIG_OPENGL:imxgpu3d = "opengl"
168 168
169PACKAGECONFIG_remove = "wayland x11" 169PACKAGECONFIG:remove = "wayland x11"
170PACKAGECONFIG_append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}" 170PACKAGECONFIG:append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}"
171 171
172PACKAGECONFIG_remove_imxfbdev = "kms" 172PACKAGECONFIG:remove:imxfbdev = "kms"
173PACKAGECONFIG_append_imxfbdev = " fbdev clients" 173PACKAGECONFIG:append:imxfbdev = " fbdev clients"
174PACKAGECONFIG_append_imxgpu = " imxgpu" 174PACKAGECONFIG:append:imxgpu = " imxgpu"
175PACKAGECONFIG_append_imxgpu2d = " imxg2d" 175PACKAGECONFIG:append:imxgpu2d = " imxg2d"
176 176
177# Clients support 177# Clients support
178SIMPLE_CLIENTS = "all" 178SIMPLE_CLIENTS = "all"
179SIMPLE_CLIENTS_imxfbdev = "damage,im,egl,shm,touch,dmabuf-v4l" 179SIMPLE_CLIENTS:imxfbdev = "damage,im,egl,shm,touch,dmabuf-v4l"
180PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false,libxcursor" 180PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false,libxcursor"
181PACKAGECONFIG[clients] = "-Dsimple-clients=${SIMPLE_CLIENTS} -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false" 181PACKAGECONFIG[clients] = "-Dsimple-clients=${SIMPLE_CLIENTS} -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false"
182# Weston with i.MX GPU support 182# Weston with i.MX GPU support