summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston_2.0.0.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston_2.0.0.bbappend')
-rw-r--r--recipes-graphics/wayland/weston_2.0.0.bbappend36
1 files changed, 0 insertions, 36 deletions
diff --git a/recipes-graphics/wayland/weston_2.0.0.bbappend b/recipes-graphics/wayland/weston_2.0.0.bbappend
deleted file mode 100644
index 7d0e589d..00000000
--- a/recipes-graphics/wayland/weston_2.0.0.bbappend
+++ /dev/null
@@ -1,36 +0,0 @@
1SUMMARY_append = " (with i.MX support)"
2
3DEPENDS_append_imxgpu2d = " virtual/libg2d"
4
5# Use i.MX fork of weston for customizations.
6SRC_URI_remove_imxgpu2d = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
7SRC_URI_prepend_imxgpu2d = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=weston-imx-2.0 "
8SRCREV_imxgpu2d = "506dc2d69b7cf7b7e7d1ea94ce29c8203215a67e"
9S_imxgpu2d = "${WORKDIR}/git"
10
11# Define RECIPE_SYSROOT since it doesn't exist in morty
12# for this backported recipe
13RECIPE_SYSROOT = "${STAGING_DIR}/${MACHINE}"
14
15EXTRA_OECONF_IMX_COMMON = "WESTON_NATIVE_BACKEND=fbdev-backend.so"
16EXTRA_OECONF_IMX = ""
17EXTRA_OECONF_IMX_imxpxp = "${EXTRA_OECONF_IMX_COMMON}"
18EXTRA_OECONF_IMX_imxgpu2d = "${EXTRA_OECONF_IMX_COMMON}"
19EXTRA_OECONF_append = " ${EXTRA_OECONF_IMX}"
20
21# Disable OpenGL for parts with GPU support for 2D but not 3D
22IMX_REQUIRED_DISTRO_FEATURES_REMOVE = ""
23IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu2d = "opengl"
24IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu3d = ""
25REQUIRED_DISTRO_FEATURES_remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}"
26IMX_EXTRA_OECONF_OPENGL = ""
27IMX_EXTRA_OECONF_OPENGL_imxgpu2d = " --disable-opengl"
28IMX_EXTRA_OECONF_OPENGL_imxgpu3d = ""
29EXTRA_OECONF_append = "${IMX_EXTRA_OECONF_OPENGL}"
30
31PACKAGECONFIG_append_imxgpu3d = " cairo-glesv2"
32
33# Append EGL_CFLAGS to CFLAGS for imxgpu2d
34CFLAGS_append_imxgpu2d = "-DLINUX -DEGL_API_FB -DWL_EGL_PLATFORM"
35
36RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-loginuid', '', d)}"