summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston-init.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston-init.bbappend')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 6a5ede37..7aceb6b1 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -6,19 +6,19 @@ IMX_REQUIRED_DISTRO_FEATURES_REMOVE:imxgpu2d = "opengl"
6IMX_REQUIRED_DISTRO_FEATURES_REMOVE:imxgpu3d = "" 6IMX_REQUIRED_DISTRO_FEATURES_REMOVE:imxgpu3d = ""
7REQUIRED_DISTRO_FEATURES:remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}" 7REQUIRED_DISTRO_FEATURES:remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}"
8 8
9SRC_URI:append:mx6sl = " file://weston.config" 9SRC_URI:append:mx6sl-nxp-bsp = " file://weston.config"
10 10
11# To customize weston.ini, start by setting the desired assignment in weston.ini, 11# To customize weston.ini, start by setting the desired assignment in weston.ini,
12# commented out. For example: 12# commented out. For example:
13# #xwayland=true 13# #xwayland=true
14# Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS. 14# Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS.
15INI_UNCOMMENT_ASSIGNMENTS:append:imx = " \ 15INI_UNCOMMENT_ASSIGNMENTS:append:imx-nxp-bsp = " \
16 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \ 16 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \
17" 17"
18INI_UNCOMMENT_ASSIGNMENTS:append:mx8 = " \ 18INI_UNCOMMENT_ASSIGNMENTS:append:mx8-nxp-bsp = " \
19 repaint-window=16 \ 19 repaint-window=16 \
20" 20"
21INI_UNCOMMENT_ASSIGNMENTS:append:mx8mq = " \ 21INI_UNCOMMENT_ASSIGNMENTS:append:mx8mq-nxp-bsp = " \
22 gbm-format=argb8888 \ 22 gbm-format=argb8888 \
23 \\[shell\\] \ 23 \\[shell\\] \
24 size=1920x1080 \ 24 size=1920x1080 \
@@ -28,8 +28,8 @@ INI_UNCOMMENT_ASSIGNMENTS:append:mx8mq = " \
28# Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest 28# Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest
29# rendering code. 29# rendering code.
30INI_UNCOMMENT_USE_G2D:imxgpu2d ?= "use-g2d=1" 30INI_UNCOMMENT_USE_G2D:imxgpu2d ?= "use-g2d=1"
31INI_UNCOMMENT_USE_G2D:mx8qm = "" 31INI_UNCOMMENT_USE_G2D:mx8qm-nxp-bsp = ""
32INI_UNCOMMENT_USE_G2D:mx8qxp = "" 32INI_UNCOMMENT_USE_G2D:mx8qxp-nxp-bsp = ""
33INI_UNCOMMENT_ASSIGNMENTS:append:imxgpu2d = " \ 33INI_UNCOMMENT_ASSIGNMENTS:append:imxgpu2d = " \
34 ${INI_UNCOMMENT_USE_G2D} \ 34 ${INI_UNCOMMENT_USE_G2D} \
35" 35"