summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-gpu-viv
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-gpu-viv')
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc53
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb7
2 files changed, 44 insertions, 16 deletions
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
index e353b553..055ce263 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
@@ -25,6 +25,8 @@ DEPENDS:append:mx8-nxp-bsp = " patchelf-native"
25# We depend on mesa to fill in what is missing. 25# We depend on mesa to fill in what is missing.
26DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa', '', d)}" 26DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa', '', d)}"
27 27
28DEPENDS:append:libc-musl = " gcompat"
29
28PROVIDES += " \ 30PROVIDES += " \
29 imx-gpu-viv \ 31 imx-gpu-viv \
30 libgal-imx \ 32 libgal-imx \
@@ -69,8 +71,6 @@ PACKAGECONFIG ?= ""
69PACKAGECONFIG[valgrind] = "" 71PACKAGECONFIG[valgrind] = ""
70 72
71# Note : If you add a package here, to prevent a naming conflict see the python_anonymous() futher below 73# Note : If you add a package here, to prevent a naming conflict see the python_anonymous() futher below
72IMX_PACKAGES_GBM = ""
73IMX_PACKAGES_GBM:mx8-nxp-bsp = "libgbm-imx libgbm-imx-dev"
74PACKAGES =+ "libclc-imx libclc-imx-dev \ 74PACKAGES =+ "libclc-imx libclc-imx-dev \
75 libgl-imx libgl-imx-dev \ 75 libgl-imx libgl-imx-dev \
76 libgles1-imx libgles1-imx-dev \ 76 libgles1-imx libgles1-imx-dev \
@@ -83,13 +83,18 @@ PACKAGES =+ "libclc-imx libclc-imx-dev \
83 libegl-imx libegl-imx-dev \ 83 libegl-imx libegl-imx-dev \
84 libgal-imx libgal-imx-dev \ 84 libgal-imx libgal-imx-dev \
85 libvsc-imx \ 85 libvsc-imx \
86 ${IMX_PACKAGES_GBM} \ 86 ${PACKAGES_GBM} \
87 imx-gpu-viv-tools \ 87 imx-gpu-viv-tools \
88 imx-gpu-viv-demos \ 88 imx-gpu-viv-demos \
89 libvulkan-imx libvulkan-imx-dev \ 89 ${PACKAGES_VULKAN} \
90 libopenvx-imx libopenvx-imx-dev \ 90 libopenvx-imx libopenvx-imx-dev \
91 libnn-imx \ 91 libnn-imx \
92" 92"
93PACKAGES_GBM = ""
94PACKAGES_GBM:mx8-nxp-bsp = "libgbm-imx libgbm-imx-dev"
95PACKAGES_VULKAN = ""
96PACKAGES_VULKAN:aarch64 = "libvulkan-imx libvulkan-imx-dev"
97PACKAGES_VULKAN:mx8mm-nxp-bsp = ""
93python __anonymous () { 98python __anonymous () {
94 has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT') or '0') 99 has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT') or '0')
95 if has_vivante_kernel_driver_support != '1': 100 if has_vivante_kernel_driver_support != '1':
@@ -216,15 +221,19 @@ do_install () {
216 install -m 0644 ${S}/gpu-core/etc/Vivante.icd ${D}${sysconfdir}/OpenCL/vendors/Vivante.icd 221 install -m 0644 ${S}/gpu-core/etc/Vivante.icd ${D}${sysconfdir}/OpenCL/vendors/Vivante.icd
217 222
218 if [ "${IS_MX8}" = "1" ]; then 223 if [ "${IS_MX8}" = "1" ]; then
219 # Rename the vulkan implementation library which is wrapped by the vulkan-loader 224 if [ -n "${PACKAGES_VULKAN}" ]; then
220 # library of the same name 225 # Rename the vulkan implementation library which is wrapped by the vulkan-loader
221 MAJOR=${LIBVULKAN_VERSION_MAJOR} 226 # library of the same name
222 FULL=${LIBVULKAN_VERSION} 227 MAJOR=${LIBVULKAN_VERSION_MAJOR}
223 mv ${D}${libdir}/libvulkan.so.$FULL ${D}${libdir}/libvulkan_VSI.so.$FULL 228 FULL=${LIBVULKAN_VERSION}
224 patchelf --set-soname libvulkan_VSI.so.$MAJOR ${D}${libdir}/libvulkan_VSI.so.$FULL 229 mv ${D}${libdir}/libvulkan.so.$FULL ${D}${libdir}/libvulkan_VSI.so.$FULL
225 rm ${D}${libdir}/libvulkan.so.$MAJOR ${D}${libdir}/libvulkan.so 230 patchelf --set-soname libvulkan_VSI.so.$MAJOR ${D}${libdir}/libvulkan_VSI.so.$FULL
226 ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so.$MAJOR 231 rm ${D}${libdir}/libvulkan.so.$MAJOR ${D}${libdir}/libvulkan.so
227 ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so 232 ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so.$MAJOR
233 ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so
234 else
235 rm -f ${D}${libdir}/libvulkan.so* ${D}${libdir}/libSPIRV_viv${SOLIBS}*
236 fi
228 fi 237 fi
229 238
230 # FIXME: MX6SL does not have 3D support; hack it for now 239 # FIXME: MX6SL does not have 3D support; hack it for now
@@ -253,6 +262,24 @@ do_install () {
253 chown -R root:root "${D}" 262 chown -R root:root "${D}"
254} 263}
255 264
265do_install:append:libc-musl() {
266 # libs
267 for f in `find ${D}${libdir} -name '*.so*' -type f`
268 do
269 patchelf --add-needed libgcompat.so.0 $f
270 done
271 # binaries
272 for f in `find ${D}/opt ${D}${bindir} -name '*' -type f -executable`
273 do
274 # prune scripts
275 if `patchelf --print-interpreter $f 2>&1 > /dev/null`
276 then
277 patchelf --set-interpreter ${root_prefix}`patchelf --print-interpreter $f` $f
278 patchelf --add-needed libgcompat.so.0 $f
279 fi
280 done
281}
282
256ALLOW_EMPTY:${PN} = "1" 283ALLOW_EMPTY:${PN} = "1"
257 284
258FILES:libclc-imx = "${libdir}/libCLC${SOLIBS} ${includedir}/CL/cl_viv_vx_ext.h" 285FILES:libclc-imx = "${libdir}/libCLC${SOLIBS} ${includedir}/CL/cl_viv_vx_ext.h"
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
index bd584dbe..4136631b 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb
@@ -1,9 +1,10 @@
1require imx-gpu-viv-6.inc 1require imx-gpu-viv-6.inc
2 2
3DEPENDS:append:libc-musl = " gcompat"
4INSANE_SKIP:append:libc-musl = " file-rdeps"
5
6SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f" 3SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f"
7SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b" 4SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b"
8 5
6INSANE_SKIP:append:libc-musl = " file-rdeps"
7
9COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" 8COMPATIBLE_MACHINE = "(mx8-nxp-bsp)"
9
10RDEPENDS:${PN}:append:libc-musl = " gcompat"