summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p2.0.bb')
-rw-r--r--recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p2.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p2.0.bb b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p2.0.bb
new file mode 100644
index 00000000..3527a709
--- /dev/null
+++ b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p2.0.bb
@@ -0,0 +1,39 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and no DPU"
7LICENSE = "Proprietary"
8LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b"
9
10DEPENDS += "libgal-imx"
11PROVIDES += "virtual/libg2d"
12
13FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}"
14
15SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
16SRC_URI[aarch64.md5sum] = "baef64e3779f50098b7191e5246ce19f"
17SRC_URI[aarch64.sha256sum] = "2642a49e088daae4cf568a150d01e7c095995e8a6ff1883c02c3fa6d26d254b3"
18SRC_URI[arm.md5sum] = "865a92ddf68509a3cff5469536ff201a"
19SRC_URI[arm.sha256sum] = "39fe307916e19a0892a514621121086e276a43858af90230372a1344852116a2"
20
21S = "${WORKDIR}/${FSLBIN_NAME}"
22
23inherit fsl-eula-unpack
24
25do_install () {
26 install -d ${D}${libdir}
27 install -d ${D}${includedir}
28 cp ${S}/g2d/usr/lib/*.so* ${D}${libdir}
29 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
30 cp -r ${S}/gpu-demos/opt ${D}
31}
32
33FILES_${PN} = "${libdir}/libg2d* /opt"
34FILES_${PN}-dev = "${includedir}"
35INSANE_SKIP_${PN} = "ldflags"
36
37RDEPENDS_${PN} = "libgal-imx"
38
39COMPATIBLE_MACHINE = "(imxgpu2d)"