diff options
Diffstat (limited to 'recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p0.0.bb')
-rw-r--r-- | recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p0.0.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p0.0.bb b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p0.0.bb new file mode 100644 index 00000000..a19c926a --- /dev/null +++ b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.4.3.p0.0.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2018 NXP | ||
3 | # Copyright 2018 (C) O.S. Systems Software LTDA. | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | |||
6 | DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and no DPU" | ||
7 | LICENSE = "Proprietary" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=983e4c77621568488dd902b27e0c2143" | ||
9 | |||
10 | DEPENDS += "libgal-imx" | ||
11 | PROVIDES += "virtual/libg2d" | ||
12 | |||
13 | FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}" | ||
14 | |||
15 | SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true" | ||
16 | SRC_URI[aarch64.md5sum] = "38d161708c42bb01362b7ba7f91bb6b4" | ||
17 | SRC_URI[aarch64.sha256sum] = "97ee90c81fa0db88e3249cb7df77f17f816ceb9a40355e03f72df99e600d7331" | ||
18 | SRC_URI[arm.md5sum] = "0011979d36205b1a3f03b404d6af4085" | ||
19 | SRC_URI[arm.sha256sum] = "725ad2edd41661713540d5e32509c754cda452acc608955689b8a64977b26ced" | ||
20 | |||
21 | S = "${WORKDIR}/${FSLBIN_NAME}" | ||
22 | |||
23 | inherit fsl-eula-unpack | ||
24 | |||
25 | do_install () { | ||
26 | install -d ${D}${libdir} | ||
27 | install -d ${D}${includedir} | ||
28 | cp ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
29 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
30 | cp -r ${S}/gpu-demos/opt ${D} | ||
31 | } | ||
32 | |||
33 | FILES_${PN} = "${libdir}/libg2d* /opt" | ||
34 | FILES_${PN}-dev = "${includedir}" | ||
35 | INSANE_SKIP_${PN} = "ldflags" | ||
36 | |||
37 | RDEPENDS_${PN} = "libgal-imx" | ||
38 | |||
39 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||