summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb
new file mode 100644
index 00000000..1f3c2e60
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb
@@ -0,0 +1,33 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2022 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "G2D library using i.MX GPU"
7LICENSE = "Proprietary"
8LIC_FILES_CHKSUM = "file://COPYING;md5=be5ff43682ed6c57dfcbeb97651c2829"
9DEPENDS = "libgal-imx"
10PROVIDES = "virtual/libg2d"
11
12FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}"
13
14SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
15SRC_URI[aarch64.md5sum] = "b3b3c285796cd5d47841b73c4735e6bd"
16SRC_URI[aarch64.sha256sum] = "f2d592d1389be0c16f8dbe6374d480d674c2e31f4195916dbd6baf71473a0e60"
17SRC_URI[arm.md5sum] = "82f6a394505bc9d348a35f26cd02bd6a"
18SRC_URI[arm.sha256sum] = "96f0213009087de0842740401a67a19d70d5a7ae928843c9c9bee3f8f177b2a0"
19
20S = "${WORKDIR}/${FSLBIN_NAME}"
21
22inherit fsl-eula-unpack
23
24do_install () {
25 install -d ${D}${libdir}
26 install -d ${D}${includedir}
27 cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
28 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
29}
30
31INSANE_SKIP:${PN} = "ldflags"
32
33COMPATIBLE_MACHINE = "(imxgpu2d)"