summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb
new file mode 100644
index 00000000..8eaa0bb3
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb
@@ -0,0 +1,31 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "G2D library using i.MX GPU"
7LICENSE = "Proprietary"
8LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
9
10DEPENDS = "libgal-imx"
11PROVIDES = "virtual/libg2d"
12
13FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}"
14
15SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
16SRC_URI[aarch64.md5sum] = "9d64a9c4a870419607d9e47e832eb997"
17SRC_URI[aarch64.sha256sum] = "6065f545568e6cdc138f2d6e7cdcb525e477ce1d775c0ceabe2beb2eacf4eb5b"
18SRC_URI[arm.md5sum] = "4d6cb47f09f268533cc6a9a90cc87555"
19SRC_URI[arm.sha256sum] = "b298a38a16400e655ea46ab25b6261e602687e9970dd755594db343064a9ae53"
20
21S = "${WORKDIR}/${FSLBIN_NAME}"
22
23inherit fsl-eula-unpack
24
25do_install () {
26 cp -r -d --no-preserve=ownership ${S}/g2d/* ${D}
27}
28
29INSANE_SKIP:${PN} = "ldflags"
30
31COMPATIBLE_MACHINE = "(imxgpu2d)"