summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.2.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.2.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.2.bb
new file mode 100644
index 00000000..b9a7d938
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.11.p2.2.bb
@@ -0,0 +1,44 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2022 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "G2D library using i.MX GPU"
7LICENSE = "Proprietary"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2827219e81f28aba7c6a569f7c437fa7"
9DEPENDS = "libgal-imx"
10PROVIDES = "virtual/libg2d"
11
12SRC_URI = "${FSL_MIRROR}/${IMX_BIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
13IMX_BIN_NAME = "${BP}-${TARGET_ARCH}-${IMX_SRCREV_ABBREV}"
14IMX_SRCREV_ABBREV = "fd0148d"
15SRC_URI[aarch64.md5sum] = "ebc4cb8fdfa0b8ef9b11d7bb0fd4710f"
16SRC_URI[aarch64.sha256sum] = "1cedc606be965b01300613ccea81b4fd589d940306bb1caa30a37c41928616ec"
17SRC_URI[arm.md5sum] = "77233957a27ae4da3f01d33b3fbc69d9"
18SRC_URI[arm.sha256sum] = "bc168b19096a997251e7137f82ffcff404c61709cf5f227c53a099f631569f76"
19
20S = "${WORKDIR}/${IMX_BIN_NAME}"
21
22inherit fsl-eula-unpack
23
24SOC_INSTALL_DIR = "SOC_INSTALL_DIR_NOT_SET"
25SOC_INSTALL_DIR:mx8mm-nxp-bsp = "mx8mm"
26
27do_install () {
28 install -d ${D}${libdir}
29 install -d ${D}${includedir}
30 cp -d ${S}/g2d/usr/lib/*.so* ${D}${libdir}
31 if [ -d ${S}/g2d/usr/lib/${SOC_INSTALL_DIR} ]; then
32 cp -d ${S}/g2d/usr/lib/${SOC_INSTALL_DIR}/*.so* ${D}${libdir}
33 fi
34 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
35}
36
37# The packaged binaries have been stripped of debug info, so disable
38# operations accordingly.
39INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
40INHIBIT_PACKAGE_STRIP = "1"
41INHIBIT_SYSROOT_STRIP = "1"
42
43PACKAGE_ARCH = "${MACHINE_SOCARCH}"
44COMPATIBLE_MACHINE = "(imxgpu2d)"