summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-g2d-samples_git.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-g2d-samples_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb
new file mode 100644
index 00000000..8368aefc
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "i.MX G2D Samples"
2DESCRIPTION = "Set of sample applications for i.MX G2D"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91"
5
6DEPENDS = "virtual/libg2d cairo"
7
8PV = "2.1+git${SRCPV}"
9
10SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}"
11GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https"
12SRCBRANCH ?= "imx_2.1"
13SRCREV = "3268f291a15b2d8d5f650f627764a52eb0a8fc15"
14
15S = "${WORKDIR}/git"
16
17inherit pkgconfig
18
19PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
20
21PACKAGECONFIG[wayland] = "USE_WAYLAND=true,USE_WAYLAND=false,wayland-native wayland-protocols"
22
23EXTRA_OEMAKE += " \
24 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \
25 ${PACKAGECONFIG_CONFARGS} \
26"
27
28do_install() {
29 oe_runmake install DESTDIR=${D}
30}
31
32FILES:${PN} += "/opt"
33
34COMPATIBLE_MACHINE = "(imxgpu2d)"