summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb
new file mode 100644
index 00000000..9832aac2
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "i.MX G2D Samples"
2DESCRIPTION = "Set of sample applications for i.MX G2D"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91"
5
6DEPENDS = "virtual/libg2d"
7
8GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https"
9SRCBRANCH ?= "imx_2.0"
10SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}"
11SRCREV = "267af142881d350218c2c2cead8f304a28bbee07"
12
13S = "${WORKDIR}/git"
14
15inherit pkgconfig
16
17PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
18
19PACKAGECONFIG[wayland] = "USE_WAYLAND=true,USE_WAYLAND=false,wayland-native wayland-protocols"
20
21EXTRA_OEMAKE += " \
22 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \
23 ${PACKAGECONFIG_CONFARGS} \
24"
25
26do_install() {
27 oe_runmake install DESTDIR=${D}
28}
29
30FILES:${PN} += "/opt"
31
32COMPATIBLE_MACHINE = "(imxgpu2d)"