summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb
new file mode 100644
index 00000000..c340505e
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and DPU"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
8PROVIDES += "virtual/libg2d"
9
10SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
11SRC_URI[md5sum] = "0b7fc529b3af3ecc3087a99cca0c627d"
12SRC_URI[sha256sum] = "42d470373fd72b2e2aa8d8a226e133c61b0a88e4e5bddbfec9509f7d2764f206"
13
14inherit fsl-eula-unpack
15
16do_install () {
17 install -d ${D}${libdir}
18 install -d ${D}${includedir}
19 cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
20 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
21 cp -r ${S}/gpu-demos/opt ${D}
22}
23
24FILES:${PN} = "${libdir}/libg2d* /opt"
25FILES:${PN}-dev = "${libdir}/libg2d${SOLIBSDEV} ${includedir}"
26INSANE_SKIP:${PN} += "ldflags"
27
28RDEPENDS:${PN} = "libgal-imx libdrm libopencl-imx"
29
30# This is required to provide support for VPU Amphion HEVC tile format
31# From NXP [MGS-5547] (commit e175d6b4f78deab24d319b852998bef55cdecc99):
32# VPU Amphion HEVC tile support was added using OpenCL, so add a dependency on libopencl-imx.
33RDEPENDS:${PN} += "libopencl-imx"
34
35COMPATIBLE_MACHINE = "(imxdpu)"