diff options
Diffstat (limited to 'recipes-graphics/amd-gpu-x11-bin/libz160_11.09.01.bb')
-rw-r--r-- | recipes-graphics/amd-gpu-x11-bin/libz160_11.09.01.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-graphics/amd-gpu-x11-bin/libz160_11.09.01.bb b/recipes-graphics/amd-gpu-x11-bin/libz160_11.09.01.bb new file mode 100644 index 00000000..43b9f7ff --- /dev/null +++ b/recipes-graphics/amd-gpu-x11-bin/libz160_11.09.01.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | # Copyright (C) 2011-2015 O.S. Systems Software LTDA. | ||
2 | # Copyright (C) 2011, 2012 Freescale | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "AMD libz160 gpu driver" | ||
6 | LICENSE = "Proprietary" | ||
7 | SECTION = "libs" | ||
8 | DEPENDS = "amd-gpu-mx51" | ||
9 | |||
10 | PR = "r2" | ||
11 | |||
12 | #todo: Replace for correct AMD license | ||
13 | LIC_FILES_CHKSUM = "file://usr/include/z160.h;endline=28;md5=65dd44cd769091092f38e34cd52cc271" | ||
14 | |||
15 | SRC_URI = "${FSL_MIRROR}/libz160-bin-${PV}.bin;fsl-eula=true" | ||
16 | SRC_URI[md5sum] = "9a9c2c93f4b44e89316772d348eead7d" | ||
17 | SRC_URI[sha256sum] = "08767eb269a0a30ca0aa3d3b5aa9a53a2d17ed1c24651b7e8cefc7704b883f19" | ||
18 | |||
19 | inherit fsl-eula-unpack | ||
20 | |||
21 | do_install () { | ||
22 | install -d ${D}${libdir} | ||
23 | install -d ${D}${includedir} | ||
24 | install -m 0755 ${S}/usr/lib/* ${D}${libdir} | ||
25 | install -m 0644 ${S}/usr/include/* ${D}${includedir} | ||
26 | } | ||
27 | |||
28 | S = "${WORKDIR}/${PN}-bin-${PV}" | ||
29 | |||
30 | # Avoid QA Issue: No GNU_HASH in the elf binary | ||
31 | INSANE_SKIP_${PN} = "ldflags" | ||
32 | INSANE_SKIP_${PN}-dev = "ldflags" | ||
33 | FILES_${PN} = "${libdir}/*.so" | ||
34 | FILES_${PN}-dev = "${includedir}" | ||
35 | |||
36 | COMPATIBLE_MACHINE = "(mx5)" | ||