summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/dpdk/dpdk.inc9
-rw-r--r--recipes-extended/dpdk/dpdk/0001-Add-RTE_KERNELDIR_OUT.patch6
-rw-r--r--recipes-extended/dpdk/dpdk/0001-add-Wno-cast-function-type.patch7
-rw-r--r--recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch12
-rw-r--r--recipes-extended/dpdk/dpdk_18.11.bb8
-rw-r--r--recipes-extended/dpdk/dpdk_19.11-20.04.bb18
-rw-r--r--recipes-extended/vpp-core/dpdkvpp.bb2
-rw-r--r--recipes-extended/vpp-core/dpdkvpp/0001-Add-RTE_KERNELDIR_OUT.patch6
-rw-r--r--recipes-extended/vpp-core/dpdkvpp/0001-add-Wno-cast-function-type.patch7
-rw-r--r--recipes-extended/vpp-core/dpdkvpp/0004-update-WERROR_FLAGS.patch12
10 files changed, 43 insertions, 44 deletions
diff --git a/recipes-extended/dpdk/dpdk.inc b/recipes-extended/dpdk/dpdk.inc
index 71977bae..f5793a19 100644
--- a/recipes-extended/dpdk/dpdk.inc
+++ b/recipes-extended/dpdk/dpdk.inc
@@ -1,15 +1,6 @@
1DESCRIPTION = "Data Plane Development Kit" 1DESCRIPTION = "Data Plane Development Kit"
2HOMEPAGE = "http://dpdk.org" 2HOMEPAGE = "http://dpdk.org"
3LICENSE = "BSD-3-Clause & LGPLv2 & GPLv2" 3LICENSE = "BSD-3-Clause & LGPLv2 & GPLv2"
4LIC_FILES_CHKSUM = "file://license/README;md5=3383def2d4c82237df281174e981a492"
5
6SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobranch=1 \
7 file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
8 file://0001-add-Wno-cast-function-type.patch \
9 file://0001-Add-RTE_KERNELDIR_OUT.patch \
10 file://0004-update-WERROR_FLAGS.patch \
11"
12SRCREV = "a36da6a94243015b228c15b8b9aa1e650fd4b96d"
13 4
14DEPENDS = "virtual/kernel openssl" 5DEPENDS = "virtual/kernel openssl"
15DEPENDS_append_x86-64 = " numactl" 6DEPENDS_append_x86-64 = " numactl"
diff --git a/recipes-extended/dpdk/dpdk/0001-Add-RTE_KERNELDIR_OUT.patch b/recipes-extended/dpdk/dpdk/0001-Add-RTE_KERNELDIR_OUT.patch
index 64a6876f..5ee48a59 100644
--- a/recipes-extended/dpdk/dpdk/0001-Add-RTE_KERNELDIR_OUT.patch
+++ b/recipes-extended/dpdk/dpdk/0001-Add-RTE_KERNELDIR_OUT.patch
@@ -1,4 +1,4 @@
1From 4ea737c1d5a185d56ee1d6da18172b389ea90760 Mon Sep 17 00:00:00 2001 1From 9c2b840a1c8ac0fbb638b5cd481909a3f832eed4 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com> 2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Wed, 3 Jul 2019 08:50:45 +0200 3Date: Wed, 3 Jul 2019 08:50:45 +0200
4Subject: [PATCH] Add RTE_KERNELDIR_OUT 4Subject: [PATCH] Add RTE_KERNELDIR_OUT
@@ -9,7 +9,7 @@ Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
9 1 file changed, 1 insertion(+), 1 deletion(-) 9 1 file changed, 1 insertion(+), 1 deletion(-)
10 10
11diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile 11diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile
12index 282be7b..dfbebdc 100644 12index 595bac261..28a31f36a 100644
13--- a/kernel/linux/kni/Makefile 13--- a/kernel/linux/kni/Makefile
14+++ b/kernel/linux/kni/Makefile 14+++ b/kernel/linux/kni/Makefile
15@@ -20,7 +20,7 @@ MODULE_CFLAGS += -Wall -Werror 15@@ -20,7 +20,7 @@ MODULE_CFLAGS += -Wall -Werror
@@ -22,5 +22,5 @@ index 282be7b..dfbebdc 100644
22 MODULE_CFLAGS += -D"UBUNTU_KERNEL_CODE=UBUNTU_KERNEL_VERSION($(UBUNTU_KERNEL_CODE))" 22 MODULE_CFLAGS += -D"UBUNTU_KERNEL_CODE=UBUNTU_KERNEL_VERSION($(UBUNTU_KERNEL_CODE))"
23 endif 23 endif
24-- 24--
252.7.4 252.17.1
26 26
diff --git a/recipes-extended/dpdk/dpdk/0001-add-Wno-cast-function-type.patch b/recipes-extended/dpdk/dpdk/0001-add-Wno-cast-function-type.patch
index c074eac6..fa0eda87 100644
--- a/recipes-extended/dpdk/dpdk/0001-add-Wno-cast-function-type.patch
+++ b/recipes-extended/dpdk/dpdk/0001-add-Wno-cast-function-type.patch
@@ -1,16 +1,15 @@
1From beb13be8023beb68499c72e71a79b8f91784e484 Mon Sep 17 00:00:00 2001 1From 354c2d1570ddf83a99c4ac711c884644c6dd1cef Mon Sep 17 00:00:00 2001
2From: "C.r. Guo" <nxa13725@lsv07005.swis.us-cdc01.nxp.com> 2From: "C.r. Guo" <nxa13725@lsv07005.swis.us-cdc01.nxp.com>
3Date: Wed, 27 Mar 2019 09:35:43 +0100 3Date: Wed, 27 Mar 2019 09:35:43 +0100
4Subject: [PATCH] add -Wno-cast-function-type 4Subject: [PATCH] add -Wno-cast-function-type
5 5
6Upstream-Status: Inappropriate [configuration] 6Upstream-Status: Inappropriate [configuration]
7
8--- 7---
9 examples/cmdif/lib/Makefile | 2 +- 8 examples/cmdif/lib/Makefile | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-) 9 1 file changed, 1 insertion(+), 1 deletion(-)
11 10
12diff --git a/examples/cmdif/lib/Makefile b/examples/cmdif/lib/Makefile 11diff --git a/examples/cmdif/lib/Makefile b/examples/cmdif/lib/Makefile
13index d28badf..4e9851c 100644 12index 235c3adbf..230f17b0a 100644
14--- a/examples/cmdif/lib/Makefile 13--- a/examples/cmdif/lib/Makefile
15+++ b/examples/cmdif/lib/Makefile 14+++ b/examples/cmdif/lib/Makefile
16@@ -28,7 +28,7 @@ SRCS-y += server/cmdif_srv_gpp.c 15@@ -28,7 +28,7 @@ SRCS-y += server/cmdif_srv_gpp.c
@@ -23,5 +22,5 @@ index d28badf..4e9851c 100644
23 CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib/client 22 CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib/client
24 CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib/server 23 CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib/server
25-- 24--
262.7.4 252.17.1
27 26
diff --git a/recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch b/recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch
index 9249b2b5..61467377 100644
--- a/recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch
+++ b/recipes-extended/dpdk/dpdk/0004-update-WERROR_FLAGS.patch
@@ -1,4 +1,4 @@
1From 3828a36fa537a187127a1c9b82ce2f5959b88367 Mon Sep 17 00:00:00 2001 1From aa97b9162b68780ca912a226b5045a3ddab41d3c Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com> 2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Thu, 4 Jul 2019 08:03:56 +0200 3Date: Thu, 4 Jul 2019 08:03:56 +0200
4Subject: [PATCH] update WERROR_FLAGS 4Subject: [PATCH] update WERROR_FLAGS
@@ -10,12 +10,12 @@ Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
10 2 files changed, 2 insertions(+), 1 deletion(-) 10 2 files changed, 2 insertions(+), 1 deletion(-)
11 11
12diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile 12diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile
13index dfbebdc..8b5c13e 100644 13index 595bac261..a17939996 100644
14--- a/kernel/linux/kni/Makefile 14--- a/kernel/linux/kni/Makefile
15+++ b/kernel/linux/kni/Makefile 15+++ b/kernel/linux/kni/Makefile
16@@ -14,7 +14,7 @@ MODULE = rte_kni 16@@ -14,7 +14,7 @@ MODULE = rte_kni
17 MODULE_CFLAGS += -I$(SRCDIR) --param max-inline-insns-single=50 17 MODULE_CFLAGS += -I$(SRCDIR) --param max-inline-insns-single=50
18 MODULE_CFLAGS += -I$(RTE_OUTPUT)/include -I$(SRCDIR)/ethtool/ixgbe -I$(SRCDIR)/ethtool/igb 18 MODULE_CFLAGS += -I$(RTE_OUTPUT)/include
19 MODULE_CFLAGS += -include $(RTE_OUTPUT)/include/rte_config.h 19 MODULE_CFLAGS += -include $(RTE_OUTPUT)/include/rte_config.h
20-MODULE_CFLAGS += -Wall -Werror 20-MODULE_CFLAGS += -Wall -Werror
21+MODULE_CFLAGS += -Wall -Werror -Wno-missing-attributes 21+MODULE_CFLAGS += -Wall -Werror -Wno-missing-attributes
@@ -23,17 +23,17 @@ index dfbebdc..8b5c13e 100644
23 -include /etc/lsb-release 23 -include /etc/lsb-release
24 24
25diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk 25diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk
26index aa94344..81efa1c 100644 26index de5e0d24d..ca2cb5fcd 100644
27--- a/mk/toolchain/gcc/rte.vars.mk 27--- a/mk/toolchain/gcc/rte.vars.mk
28+++ b/mk/toolchain/gcc/rte.vars.mk 28+++ b/mk/toolchain/gcc/rte.vars.mk
29@@ -49,6 +49,7 @@ WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual 29@@ -49,6 +49,7 @@ WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual
30 WERROR_FLAGS += -Wformat-nonliteral -Wformat-security 30 WERROR_FLAGS += -Wformat-nonliteral -Wformat-security
31 WERROR_FLAGS += -Wundef -Wwrite-strings -Wdeprecated 31 WERROR_FLAGS += -Wundef -Wwrite-strings -Wdeprecated
32 WERROR_FLAGS += -Wno-error=pedantic 32 WERROR_FLAGS += -Wno-error=pedantic
33+WERROR_FLAGS += -Wno-address-of-packed-member 33+WERROR_FLAGS += -Wno-address-of-packed-member
34 34
35 ifeq ($(RTE_DEVEL_BUILD),y) 35 ifeq ($(RTE_DEVEL_BUILD),y)
36 WERROR_FLAGS += -Werror 36 WERROR_FLAGS += -Werror
37-- 37--
382.7.4 382.17.1
39 39
diff --git a/recipes-extended/dpdk/dpdk_18.11.bb b/recipes-extended/dpdk/dpdk_18.11.bb
deleted file mode 100644
index 1a6b927e..00000000
--- a/recipes-extended/dpdk/dpdk_18.11.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1include dpdk.inc
2
3
4do_install_append () {
5 # Remove the unneeded dir
6 rm -rf ${D}/${datadir}/${RTE_TARGET}/app
7}
8
diff --git a/recipes-extended/dpdk/dpdk_19.11-20.04.bb b/recipes-extended/dpdk/dpdk_19.11-20.04.bb
new file mode 100644
index 00000000..12b6d56e
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_19.11-20.04.bb
@@ -0,0 +1,18 @@
1LIC_FILES_CHKSUM = "file://license/README;md5=3383def2d4c82237df281174e981a492"
2
3SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobranch=1 \
4 file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
5 file://0001-add-Wno-cast-function-type.patch \
6 file://0001-Add-RTE_KERNELDIR_OUT.patch \
7 file://0004-update-WERROR_FLAGS.patch \
8"
9SRCREV = "4110a5fed09fa034963cfc246a6285911ecbd540"
10
11include dpdk.inc
12
13
14do_install_append () {
15 # Remove the unneeded dir
16 rm -rf ${D}/${datadir}/${RTE_TARGET}/app
17}
18
diff --git a/recipes-extended/vpp-core/dpdkvpp.bb b/recipes-extended/vpp-core/dpdkvpp.bb
index 78d166a4..8e8abe86 100644
--- a/recipes-extended/vpp-core/dpdkvpp.bb
+++ b/recipes-extended/vpp-core/dpdkvpp.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobr
9 file://0001-Add-RTE_KERNELDIR_OUT.patch \ 9 file://0001-Add-RTE_KERNELDIR_OUT.patch \
10 file://0004-update-WERROR_FLAGS.patch \ 10 file://0004-update-WERROR_FLAGS.patch \
11" 11"
12SRCREV = "a36da6a94243015b228c15b8b9aa1e650fd4b96d" 12SRCREV = "4110a5fed09fa034963cfc246a6285911ecbd540"
13 13
14DEPENDS = "virtual/kernel openssl" 14DEPENDS = "virtual/kernel openssl"
15DEPENDS_append_x86-64 = " numactl" 15DEPENDS_append_x86-64 = " numactl"
diff --git a/recipes-extended/vpp-core/dpdkvpp/0001-Add-RTE_KERNELDIR_OUT.patch b/recipes-extended/vpp-core/dpdkvpp/0001-Add-RTE_KERNELDIR_OUT.patch
index 64a6876f..5ee48a59 100644
--- a/recipes-extended/vpp-core/dpdkvpp/0001-Add-RTE_KERNELDIR_OUT.patch
+++ b/recipes-extended/vpp-core/dpdkvpp/0001-Add-RTE_KERNELDIR_OUT.patch
@@ -1,4 +1,4 @@
1From 4ea737c1d5a185d56ee1d6da18172b389ea90760 Mon Sep 17 00:00:00 2001 1From 9c2b840a1c8ac0fbb638b5cd481909a3f832eed4 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com> 2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Wed, 3 Jul 2019 08:50:45 +0200 3Date: Wed, 3 Jul 2019 08:50:45 +0200
4Subject: [PATCH] Add RTE_KERNELDIR_OUT 4Subject: [PATCH] Add RTE_KERNELDIR_OUT
@@ -9,7 +9,7 @@ Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
9 1 file changed, 1 insertion(+), 1 deletion(-) 9 1 file changed, 1 insertion(+), 1 deletion(-)
10 10
11diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile 11diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile
12index 282be7b..dfbebdc 100644 12index 595bac261..28a31f36a 100644
13--- a/kernel/linux/kni/Makefile 13--- a/kernel/linux/kni/Makefile
14+++ b/kernel/linux/kni/Makefile 14+++ b/kernel/linux/kni/Makefile
15@@ -20,7 +20,7 @@ MODULE_CFLAGS += -Wall -Werror 15@@ -20,7 +20,7 @@ MODULE_CFLAGS += -Wall -Werror
@@ -22,5 +22,5 @@ index 282be7b..dfbebdc 100644
22 MODULE_CFLAGS += -D"UBUNTU_KERNEL_CODE=UBUNTU_KERNEL_VERSION($(UBUNTU_KERNEL_CODE))" 22 MODULE_CFLAGS += -D"UBUNTU_KERNEL_CODE=UBUNTU_KERNEL_VERSION($(UBUNTU_KERNEL_CODE))"
23 endif 23 endif
24-- 24--
252.7.4 252.17.1
26 26
diff --git a/recipes-extended/vpp-core/dpdkvpp/0001-add-Wno-cast-function-type.patch b/recipes-extended/vpp-core/dpdkvpp/0001-add-Wno-cast-function-type.patch
index c074eac6..fa0eda87 100644
--- a/recipes-extended/vpp-core/dpdkvpp/0001-add-Wno-cast-function-type.patch
+++ b/recipes-extended/vpp-core/dpdkvpp/0001-add-Wno-cast-function-type.patch
@@ -1,16 +1,15 @@
1From beb13be8023beb68499c72e71a79b8f91784e484 Mon Sep 17 00:00:00 2001 1From 354c2d1570ddf83a99c4ac711c884644c6dd1cef Mon Sep 17 00:00:00 2001
2From: "C.r. Guo" <nxa13725@lsv07005.swis.us-cdc01.nxp.com> 2From: "C.r. Guo" <nxa13725@lsv07005.swis.us-cdc01.nxp.com>
3Date: Wed, 27 Mar 2019 09:35:43 +0100 3Date: Wed, 27 Mar 2019 09:35:43 +0100
4Subject: [PATCH] add -Wno-cast-function-type 4Subject: [PATCH] add -Wno-cast-function-type
5 5
6Upstream-Status: Inappropriate [configuration] 6Upstream-Status: Inappropriate [configuration]
7
8--- 7---
9 examples/cmdif/lib/Makefile | 2 +- 8 examples/cmdif/lib/Makefile | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-) 9 1 file changed, 1 insertion(+), 1 deletion(-)
11 10
12diff --git a/examples/cmdif/lib/Makefile b/examples/cmdif/lib/Makefile 11diff --git a/examples/cmdif/lib/Makefile b/examples/cmdif/lib/Makefile
13index d28badf..4e9851c 100644 12index 235c3adbf..230f17b0a 100644
14--- a/examples/cmdif/lib/Makefile 13--- a/examples/cmdif/lib/Makefile
15+++ b/examples/cmdif/lib/Makefile 14+++ b/examples/cmdif/lib/Makefile
16@@ -28,7 +28,7 @@ SRCS-y += server/cmdif_srv_gpp.c 15@@ -28,7 +28,7 @@ SRCS-y += server/cmdif_srv_gpp.c
@@ -23,5 +22,5 @@ index d28badf..4e9851c 100644
23 CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib/client 22 CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib/client
24 CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib/server 23 CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib/server
25-- 24--
262.7.4 252.17.1
27 26
diff --git a/recipes-extended/vpp-core/dpdkvpp/0004-update-WERROR_FLAGS.patch b/recipes-extended/vpp-core/dpdkvpp/0004-update-WERROR_FLAGS.patch
index 9249b2b5..61467377 100644
--- a/recipes-extended/vpp-core/dpdkvpp/0004-update-WERROR_FLAGS.patch
+++ b/recipes-extended/vpp-core/dpdkvpp/0004-update-WERROR_FLAGS.patch
@@ -1,4 +1,4 @@
1From 3828a36fa537a187127a1c9b82ce2f5959b88367 Mon Sep 17 00:00:00 2001 1From aa97b9162b68780ca912a226b5045a3ddab41d3c Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com> 2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Thu, 4 Jul 2019 08:03:56 +0200 3Date: Thu, 4 Jul 2019 08:03:56 +0200
4Subject: [PATCH] update WERROR_FLAGS 4Subject: [PATCH] update WERROR_FLAGS
@@ -10,12 +10,12 @@ Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
10 2 files changed, 2 insertions(+), 1 deletion(-) 10 2 files changed, 2 insertions(+), 1 deletion(-)
11 11
12diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile 12diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile
13index dfbebdc..8b5c13e 100644 13index 595bac261..a17939996 100644
14--- a/kernel/linux/kni/Makefile 14--- a/kernel/linux/kni/Makefile
15+++ b/kernel/linux/kni/Makefile 15+++ b/kernel/linux/kni/Makefile
16@@ -14,7 +14,7 @@ MODULE = rte_kni 16@@ -14,7 +14,7 @@ MODULE = rte_kni
17 MODULE_CFLAGS += -I$(SRCDIR) --param max-inline-insns-single=50 17 MODULE_CFLAGS += -I$(SRCDIR) --param max-inline-insns-single=50
18 MODULE_CFLAGS += -I$(RTE_OUTPUT)/include -I$(SRCDIR)/ethtool/ixgbe -I$(SRCDIR)/ethtool/igb 18 MODULE_CFLAGS += -I$(RTE_OUTPUT)/include
19 MODULE_CFLAGS += -include $(RTE_OUTPUT)/include/rte_config.h 19 MODULE_CFLAGS += -include $(RTE_OUTPUT)/include/rte_config.h
20-MODULE_CFLAGS += -Wall -Werror 20-MODULE_CFLAGS += -Wall -Werror
21+MODULE_CFLAGS += -Wall -Werror -Wno-missing-attributes 21+MODULE_CFLAGS += -Wall -Werror -Wno-missing-attributes
@@ -23,17 +23,17 @@ index dfbebdc..8b5c13e 100644
23 -include /etc/lsb-release 23 -include /etc/lsb-release
24 24
25diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk 25diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk
26index aa94344..81efa1c 100644 26index de5e0d24d..ca2cb5fcd 100644
27--- a/mk/toolchain/gcc/rte.vars.mk 27--- a/mk/toolchain/gcc/rte.vars.mk
28+++ b/mk/toolchain/gcc/rte.vars.mk 28+++ b/mk/toolchain/gcc/rte.vars.mk
29@@ -49,6 +49,7 @@ WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual 29@@ -49,6 +49,7 @@ WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual
30 WERROR_FLAGS += -Wformat-nonliteral -Wformat-security 30 WERROR_FLAGS += -Wformat-nonliteral -Wformat-security
31 WERROR_FLAGS += -Wundef -Wwrite-strings -Wdeprecated 31 WERROR_FLAGS += -Wundef -Wwrite-strings -Wdeprecated
32 WERROR_FLAGS += -Wno-error=pedantic 32 WERROR_FLAGS += -Wno-error=pedantic
33+WERROR_FLAGS += -Wno-address-of-packed-member 33+WERROR_FLAGS += -Wno-address-of-packed-member
34 34
35 ifeq ($(RTE_DEVEL_BUILD),y) 35 ifeq ($(RTE_DEVEL_BUILD),y)
36 WERROR_FLAGS += -Werror 36 WERROR_FLAGS += -Werror
37-- 37--
382.7.4 382.17.1
39 39