summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/dpdk/dpdk-20.11.inc15
-rw-r--r--recipes-extended/dpdk/dpdk-20.11/0001-Makefile-add-makefile.patch74
-rw-r--r--recipes-extended/dpdk/dpdk-20.11/0001-drivers-net-enetfec-enet_uio.c-fix-multiple-definiti.patch30
-rw-r--r--recipes-extended/dpdk/dpdk-20.11/0001-ifpga-meson-Fix-finding-librt-using-find_library.patch35
-rw-r--r--recipes-extended/dpdk/dpdk-20.11/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch38
-rw-r--r--recipes-extended/dpdk/dpdk-module_20.11.bb41
-rw-r--r--recipes-extended/dpdk/dpdk_20.11.bb93
-rw-r--r--recipes-extended/libpkcs11/libpkcs11_git.bb3
-rw-r--r--recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb48
-rw-r--r--recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb36
-rw-r--r--recipes-extended/pktgen-dpdk/files/fix-gcc11-mismatched-dealloc-error.patch72
-rw-r--r--recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb33
-rw-r--r--recipes-extended/pktgen-dpdk/pktgen-dpdk_21.05.0.bb37
-rw-r--r--recipes-extended/secure-obj/secure-obj.inc5
-rw-r--r--recipes-extended/secure-obj/secure-obj_git.bb1
-rw-r--r--recipes-extended/tsntool/tsntool_git.bb2
16 files changed, 477 insertions, 86 deletions
diff --git a/recipes-extended/dpdk/dpdk-20.11.inc b/recipes-extended/dpdk/dpdk-20.11.inc
new file mode 100644
index 00000000..00aed60d
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk-20.11.inc
@@ -0,0 +1,15 @@
1DESCRIPTION = "Data Plane Development Kit"
2HOMEPAGE = "http://dpdk.org"
3LICENSE = "BSD-3-Clause & LGPLv2.1 & GPLv2"
4LIC_FILES_CHKSUM = "file://license/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://license/lgpl-2.1.txt;md5=4b54a1fd55a448865a0b32d41598759d \
6 file://license/bsd-3-clause.txt;md5=0f00d99239d922ffd13cabef83b33444"
7
8SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobranch=1"
9SRCREV = "f74b8bd5ab1c6ff76e956fc202a56aea2d200270"
10
11S = "${WORKDIR}/git"
12
13COMPATIBLE_MACHINE = "(qoriq-arm64)"
14
15CVE_PRODUCT = "data_plane_development_kit"
diff --git a/recipes-extended/dpdk/dpdk-20.11/0001-Makefile-add-makefile.patch b/recipes-extended/dpdk/dpdk-20.11/0001-Makefile-add-makefile.patch
new file mode 100644
index 00000000..18b75fb6
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk-20.11/0001-Makefile-add-makefile.patch
@@ -0,0 +1,74 @@
1From 768cef60957d5e840071d1d6514d4add3f3c2904 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 14 Apr 2021 17:25:53 +0800
4Subject: [PATCH] Makefile: add makefile
5
6Current meson build for kernel module build does not fit in Yocto.
7So added Makefile to build rte_kni.ko
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
12---
13 kernel/linux/kni/Kbuild | 6 ------
14 kernel/linux/kni/Makefile | 35 +++++++++++++++++++++++++++++++++++
15 2 files changed, 35 insertions(+), 6 deletions(-)
16 delete mode 100644 kernel/linux/kni/Kbuild
17 create mode 100644 kernel/linux/kni/Makefile
18
19diff --git a/kernel/linux/kni/Kbuild b/kernel/linux/kni/Kbuild
20deleted file mode 100644
21index e5452d6c00..0000000000
22--- a/kernel/linux/kni/Kbuild
23+++ /dev/null
24@@ -1,6 +0,0 @@
25-# SPDX-License-Identifier: BSD-3-Clause
26-# Copyright(c) 2018 Luca Boccassi <bluca@debian.org>
27-
28-ccflags-y := $(MODULE_CFLAGS)
29-obj-m := rte_kni.o
30-rte_kni-y := $(patsubst $(src)/%.c,%.o,$(wildcard $(src)/*.c))
31diff --git a/kernel/linux/kni/Makefile b/kernel/linux/kni/Makefile
32new file mode 100644
33index 0000000000..19897ee06e
34--- /dev/null
35+++ b/kernel/linux/kni/Makefile
36@@ -0,0 +1,35 @@
37+#
38+# Makefile for building rte_kni.ko
39+#
40+MODULE_CFLAGS += -include $(S)/config/rte_config.h
41+MODULE_CFLAGS += -I$(S)/lib/librte_eal/include
42+MODULE_CFLAGS += -I$(S)/lib/librte_kni
43+MODULE_CFLAGS += -I$(S)/kernel/linux/kni
44+MODULE_CFLAGS += -I$(S)
45+MODULE_CFLAGS += -I$(STAGING_INCDIR)
46+
47+rte_kni-objs = kni_misc.o kni_net.o
48+
49+ccflags-y := $(MODULE_CFLAGS)
50+cflags-y := $(MODULE_CFLAGS)
51+obj-m := rte_kni.o
52+
53+
54+KERNEL_MAKE_OPTS := -C $(STAGING_KERNEL_DIR) M=$(CURDIR)
55+ifneq ($(ARCH),)
56+KERNEL_MAKE_OPTS += ARCH=$(ARCH)
57+endif
58+ifneq ($(CROSS_COMPILE),)
59+KERNEL_MAKE_OPTS += CROSS_COMPILE=$(CROSS_COMPILE)
60+endif
61+
62+build:
63+ $(MAKE) $(KERNEL_MAKE_OPTS) modules
64+
65+install: modules_install
66+
67+modules_install:
68+ $(MAKE) $(KERNEL_MAKE_OPTS) modules_install
69+
70+clean:
71+ $(MAKE) $(KERNEL_MAKE_OPTS) clean
72--
732.17.1
74
diff --git a/recipes-extended/dpdk/dpdk-20.11/0001-drivers-net-enetfec-enet_uio.c-fix-multiple-definiti.patch b/recipes-extended/dpdk/dpdk-20.11/0001-drivers-net-enetfec-enet_uio.c-fix-multiple-definiti.patch
new file mode 100644
index 00000000..f19b2b32
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk-20.11/0001-drivers-net-enetfec-enet_uio.c-fix-multiple-definiti.patch
@@ -0,0 +1,30 @@
1From 6fe85f3a12d15e25345ef0547035a929351a179c Mon Sep 17 00:00:00 2001
2From: Ting Liu <ting.liu@nxp.com>
3Date: Fri, 17 Sep 2021 12:53:53 +0530
4Subject: [PATCH] drivers/net/enetfec/enet_uio.c: fix multiple definition
5
6.../drivers/net/enetfec/enet_uio.c:22: multiple definition of `count';
7.../examples/flow_classify/flow_classify.c:170: first defined here
8collect2: error: ld returned 1 exit status
9
10Signed-off-by: Ting Liu <ting.liu@nxp.com>
11---
12 drivers/net/enetfec/enet_uio.c | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/drivers/net/enetfec/enet_uio.c b/drivers/net/enetfec/enet_uio.c
16index b64dc522e8..9e09f9beb6 100644
17--- a/drivers/net/enetfec/enet_uio.c
18+++ b/drivers/net/enetfec/enet_uio.c
19@@ -19,7 +19,7 @@
20 #include "enet_uio.h"
21
22 static struct uio_job enetfec_uio_job;
23-int count;
24+static int count;
25
26 /** @brief Reads first line from a file.
27 * Composes file name as: root/subdir/filename
28--
292.25.1
30
diff --git a/recipes-extended/dpdk/dpdk-20.11/0001-ifpga-meson-Fix-finding-librt-using-find_library.patch b/recipes-extended/dpdk/dpdk-20.11/0001-ifpga-meson-Fix-finding-librt-using-find_library.patch
new file mode 100644
index 00000000..4df28c40
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk-20.11/0001-ifpga-meson-Fix-finding-librt-using-find_library.patch
@@ -0,0 +1,35 @@
1From 308409d72671b7978b20d40748ad985a235b6c86 Mon Sep 17 00:00:00 2001
2From: Mohamad Noor Alim Hussin <mohamad.noor.alim.hussin@intel.com>
3Date: Thu, 24 Jun 2021 11:30:09 +0800
4Subject: [PATCH] ifpga/meson: Fix finding librt using find_library()
5
6Finding with "librt" keyword would give the output
7with full path of librt such as /usr/lib/librt.so
8instead of -lrt.
9
10Assume find_library() will prepend "lib", thus remove
11"lib" from "librt" keyword. The output will shows as
12-lrt.
13
14Upstream-Status: Submitted [https://mails.dpdk.org/archives/stable/2021-June/031840.html]
15
16Signed-off-by: Mohamad Noor Alim Hussin <mohamad.noor.alim.hussin@intel.com>
17---
18 drivers/raw/ifpga/base/meson.build | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/drivers/raw/ifpga/base/meson.build b/drivers/raw/ifpga/base/meson.build
22index da2d6e33c..949f7f127 100644
23--- a/drivers/raw/ifpga/base/meson.build
24+++ b/drivers/raw/ifpga/base/meson.build
25@@ -25,7 +25,7 @@ sources = [
26
27 rtdep = dependency('librt', required: false)
28 if not rtdep.found()
29- rtdep = cc.find_library('librt', required: false)
30+ rtdep = cc.find_library('rt', required: false)
31 endif
32 if not rtdep.found()
33 build = false
34--
352.32.0
diff --git a/recipes-extended/dpdk/dpdk-20.11/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch b/recipes-extended/dpdk/dpdk-20.11/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch
new file mode 100644
index 00000000..bef1f45b
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk-20.11/0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch
@@ -0,0 +1,38 @@
1From cf8f15824dc2dd306d9c7e111641bef045d623c2 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 14 Apr 2021 16:03:10 +0800
4Subject: [PATCH] meson.build:-march and -mcpu already passed by Yocto
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10 config/meson.build | 12 ++++++------
11 1 file changed, 6 insertions(+), 6 deletions(-)
12
13diff --git a/config/meson.build b/config/meson.build
14index 2f150de3b8..41bb3e9ec4 100644
15--- a/config/meson.build
16+++ b/config/meson.build
17@@ -94,12 +94,12 @@ dpdk_conf.set('RTE_MACHINE', machine)
18 machine_args = []
19
20 # ppc64 does not support -march= at all, use -mcpu and -mtune for that
21-if host_machine.cpu_family().startswith('ppc')
22- machine_args += '-mcpu=' + machine
23- machine_args += '-mtune=' + machine
24-else
25- machine_args += '-march=' + machine
26-endif
27+#if host_machine.cpu_family().startswith('ppc')
28+# machine_args += '-mcpu=' + machine
29+# machine_args += '-mtune=' + machine
30+#else
31+# machine_args += '-march=' + machine
32+#endif
33
34 toolchain = cc.get_id()
35 dpdk_conf.set_quoted('RTE_TOOLCHAIN', toolchain)
36--
372.17.1
38
diff --git a/recipes-extended/dpdk/dpdk-module_20.11.bb b/recipes-extended/dpdk/dpdk-module_20.11.bb
new file mode 100644
index 00000000..180b140b
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk-module_20.11.bb
@@ -0,0 +1,41 @@
1include dpdk-20.11.inc
2
3FILESEXTRAPATHS:prepend := "${THISDIR}/dpdk-${PV}:"
4
5SRC_URI += " \
6 file://0001-Makefile-add-makefile.patch \
7"
8
9inherit module
10
11#kernel module needs 'rte_build_config.h', which is generated at buid time
12DEPENDS += "dpdk"
13
14export S
15export STAGING_KERNEL_DIR
16export STAGING_INCDIR
17export INSTALL_MOD_DIR="dpdk"
18
19do_configure[noexec] = "1"
20
21do_compile() {
22 cd ${S}/kernel/linux/kni
23 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
24 oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
25 KERNEL_VERSION=${KERNEL_VERSION} \
26 CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
27 AR="${KERNEL_AR}" \
28 O=${STAGING_KERNEL_BUILDDIR} \
29 KBUILD_EXTRA_SYMBOLS="${KBUILD_EXTRA_SYMBOLS}" \
30 ${MAKE_TARGETS}
31}
32
33do_install() {
34 cd ${S}/kernel/linux/kni
35 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
36 oe_runmake DEPMOD=echo MODLIB="${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}" \
37 INSTALL_FW_PATH="${D}${nonarch_base_libdir}/firmware" \
38 CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
39 O=${STAGING_KERNEL_BUILDDIR} \
40 ${MODULES_INSTALL_TARGET}
41}
diff --git a/recipes-extended/dpdk/dpdk_20.11.bb b/recipes-extended/dpdk/dpdk_20.11.bb
new file mode 100644
index 00000000..2d27adc5
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_20.11.bb
@@ -0,0 +1,93 @@
1include dpdk-20.11.inc
2
3SRC_URI += " \
4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch \
5 file://0001-ifpga-meson-Fix-finding-librt-using-find_library.patch \
6 file://0001-drivers-net-enetfec-enet_uio.c-fix-multiple-definiti.patch \
7"
8
9MESON_BUILDTYPE = "release"
10
11# kernel module is provide by dpdk-module recipe, so disable here
12EXTRA_OEMESON = " -Denable_kmods=false \
13 -Dexamples=all \
14 -Doptimization=3 \
15"
16
17PACKAGECONFIG ??= "openssl"
18PACKAGECONFIG[afxdp] = ",,libbpf"
19PACKAGECONFIG[libvirt] = ",,libvirt"
20PACKAGECONFIG[openssl] = ",,openssl"
21
22RDEPENDS:${PN} += "bash pciutils python3-core"
23RDEPENDS:${PN}-examples += "bash"
24DEPENDS = "numactl"
25
26inherit meson
27
28INSTALL_PATH = "${prefix}/share/dpdk"
29
30do_configure:prepend() {
31 sed -i "/implementor_/d" ${WORKDIR}/meson.cross
32 sed -i "/\[properties]/aimplementor_id = 'dpaa'" ${WORKDIR}/meson.cross
33 sed -i "/\[properties]/aimplementor_pn = 'default'" ${WORKDIR}/meson.cross
34 sed -i "s/cpu =.*/cpu = 'armv8-a'/" ${WORKDIR}/meson.cross
35}
36
37do_install:append(){
38 # remove source files
39 rm -rf ${D}/${INSTALL_PATH}/examples/*
40
41 # Install examples
42 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
43 for dirname in ${B}/examples/dpdk-*
44 do
45 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
46 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
47 fi
48 done
49 cp -rf ${S}/nxp/* ${D}/${INSTALL_PATH}/
50}
51
52PACKAGES =+ "${PN}-tools ${PN}-examples ${PN}-misc"
53
54FILES:${PN}-tools = " \
55 ${bindir}/dpdk-testpmd \
56 ${INSTALL_PATH}/examples/dpdk-l2fwd \
57 ${INSTALL_PATH}/examples/dpdk-l2fwd-crypto \
58 ${INSTALL_PATH}/examples/dpdk-l3fwd \
59 ${INSTALL_PATH}/examples/dpdk-ipsec-secgw \
60"
61
62FILES:${PN}-examples = " \
63 ${bindir}/dpdk-proc-info \
64 ${bindir}/dpdk-test \
65 ${bindir}/dpdk-test-crypto-perf \
66 ${bindir}/dpdk-*.py \
67 ${INSTALL_PATH}/examples/dpdk-cmdif \
68 ${INSTALL_PATH}/examples/dpdk-cmdline \
69 ${INSTALL_PATH}/examples/dpdk-ethtool \
70 ${INSTALL_PATH}/examples/dpdk-ip_fragmentation \
71 ${INSTALL_PATH}/examples/dpdk-ip_reassembly \
72 ${INSTALL_PATH}/examples/dpdk-kni \
73 ${INSTALL_PATH}/examples/dpdk-l2fwd-keepalive \
74 ${INSTALL_PATH}/examples/dpdk-l2fwd-qdma \
75 ${INSTALL_PATH}/examples/dpdk-l3fwd-acl \
76 ${INSTALL_PATH}/examples/dpdk-link_status_interrupt \
77 ${INSTALL_PATH}/examples/dpdk-mp_client \
78 ${INSTALL_PATH}/examples/dpdk-mp_server \
79 ${INSTALL_PATH}/examples/dpdk-qdma_demo \
80 ${INSTALL_PATH}/examples/dpdk-simple_mp \
81 ${INSTALL_PATH}/examples/dpdk-symmetric_mp \
82 ${INSTALL_PATH}/examples/dpdk-symmetric_mp_qdma \
83 ${INSTALL_PATH}/examples/dpdk-timer \
84"
85
86FILES:${PN}-misc = " \
87 ${bindir}/dpdk-pdump \
88 ${bindir}/dpdk-test-* \
89 ${bindir}/dpdk-*.py \
90 ${INSTALL_PATH}/examples/* \
91"
92
93INSANE_SKIP:${PN} = "dev-so"
diff --git a/recipes-extended/libpkcs11/libpkcs11_git.bb b/recipes-extended/libpkcs11/libpkcs11_git.bb
index 5496b09c..42b48779 100644
--- a/recipes-extended/libpkcs11/libpkcs11_git.bb
+++ b/recipes-extended/libpkcs11/libpkcs11_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=803852533e29eb1d6d5e55ad3078b625"
5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/libpkcs11;nobranch=1 \ 5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/libpkcs11;nobranch=1 \
6 file://0001-fix-multiple-definition-error.patch \ 6 file://0001-fix-multiple-definition-error.patch \
7" 7"
8SRCREV = "a243fb21772f1bd434d8bc1ac45feb36571afadb" 8SRCREV = "8d85182b7a7cd393ab6dd72930f8d1b69468f741"
9 9
10DEPENDS = "openssl secure-obj" 10DEPENDS = "openssl secure-obj"
11 11
@@ -30,6 +30,7 @@ do_install(){
30 mkdir -p ${D}/${includedir} ${D}/${bindir} 30 mkdir -p ${D}/${includedir} ${D}/${bindir}
31 cp ${S}/out/export/lib/libpkcs11.so ${D}/${libdir} 31 cp ${S}/out/export/lib/libpkcs11.so ${D}/${libdir}
32 cp ${S}/out/export/include/*.h ${D}/${includedir} 32 cp ${S}/out/export/include/*.h ${D}/${includedir}
33 rm -f ${D}${includedir}/pkcs11.h
33 cp ${S}/out/export/app/* ${D}/${bindir} 34 cp ${S}/out/export/app/* ${D}/${bindir}
34} 35}
35 36
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
deleted file mode 100644
index f9d32773..00000000
--- a/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
+++ /dev/null
@@ -1,48 +0,0 @@
1DESCRIPTION = "OVS DPDK"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
4
5DEPENDS = "dpdk python3-six-native coreutils-native"
6RDEPENDS:${PN} = "bash libcrypto libssl python3"
7
8inherit python3native
9
10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1"
11SRCREV = "072130412196029bcc284e353023d81019a8daa7"
12
13S = "${WORKDIR}/git"
14
15DPAA_VER ?= "dpaa"
16export RTE_TARGET = "${ARCH}-${DPAA_VER}-linuxapp-gcc"
17
18EXTRA_OEMAKE += 'ARCH="${ARCH}" CROSS="${TARGET_PREFIX}" \
19 CPU_CFLAGS="--sysroot=${STAGING_DIR_HOST}" RTE_SDK="${S}" \
20 OPENSSL_PATH="${STAGING_DIR_HOST}" RTE_KERNELDIR="${STAGING_KERNEL_DIR}" \
21 RTE_KERNELDIR_OUT="${STAGING_KERNEL_BUILDDIR}" \
22'
23
24do_configure() {
25 export SYSROOT_DPDK=${PKG_CONFIG_SYSROOT_DIR}
26 ${S}/boot.sh
27 ${S}/configure --host aarch64-fsl-linux --with-dpdk=${SYSROOT_DPDK}/usr/share/${RTE_TARGET} --with-openssl=${SYSROOT_DPDK}/usr CFLAGS="-g -Wno-cast-align -Ofast"
28}
29
30do_compile() {
31 oe_runmake O="${RTE_TARGET}" T="${RTE_TARGET}"
32}
33
34do_install() {
35 install -d ${D}${bindir}/ovs-dpdk
36 cp -rf ${S}/ovsdb/ovsdb-tool ${D}${bindir}/ovs-dpdk
37 cp -rf ${S}/ovsdb/ovsdb-server ${D}${bindir}/ovs-dpdk
38 cp -rf ${S}/vswitchd/vswitch.ovsschema ${D}${bindir}/ovs-dpdk
39 cp -rf ${S}/vswitchd/ovs-vswitchd ${D}${bindir}/ovs-dpdk
40 cp -rf ${S}/utilities/ovs-vsctl ${D}${bindir}/ovs-dpdk
41 cp -rf ${S}/utilities/ovs-ofctl ${D}${bindir}/ovs-dpdk
42 chmod 777 -R ${D}${bindir}/ovs-dpdk/*
43}
44
45ALLOW_EMPTY:${PN} = "1"
46INHIBIT_PACKAGE_STRIP = "1"
47PACKAGE_ARCH = "${MACHINE_ARCH}"
48COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb
new file mode 100644
index 00000000..fb41b457
--- /dev/null
+++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "OVS DPDK"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
4
5DEPENDS = "dpdk python3-six-native coreutils-native autoconf-native automake-native"
6RDEPENDS:${PN} = "bash libcrypto libssl python3"
7
8inherit python3native pkgconfig
9
10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1"
11SRCREV = "f2c0744d2f68c4cd2840d6e409d7b0520e4caf99"
12
13S = "${WORKDIR}/git"
14
15do_configure() {
16 export SYSROOT_DPDK=${PKG_CONFIG_SYSROOT_DIR}
17 ${S}/boot.sh
18 ${S}/configure --host aarch64-fsl-linux --with-dpdk=static --with-openssl=${SYSROOT_DPDK}/usr CFLAGS="-g -Wno-cast-align -Ofast"
19}
20
21do_install:append() {
22 install -d ${D}${bindir}/ovs-dpdk
23 cp -rf ${S}/ovsdb/ovsdb-tool ${D}${bindir}/ovs-dpdk
24 cp -rf ${S}/ovsdb/ovsdb-server ${D}${bindir}/ovs-dpdk
25 cp -rf ${S}/ovsdb/ovsdb-client ${D}${bindir}/ovs-dpdk
26 cp -rf ${S}/vswitchd/vswitch.ovsschema ${D}${bindir}/ovs-dpdk
27 cp -rf ${S}/vswitchd/ovs-vswitchd ${D}${bindir}/ovs-dpdk
28 cp -rf ${S}/utilities/ovs-vsctl ${D}${bindir}/ovs-dpdk
29 cp -rf ${S}/utilities/ovs-ofctl ${D}${bindir}/ovs-dpdk
30 chmod 777 -R ${D}${bindir}/ovs-dpdk/*
31}
32
33ALLOW_EMPTY:${PN} = "1"
34INHIBIT_PACKAGE_STRIP = "1"
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-extended/pktgen-dpdk/files/fix-gcc11-mismatched-dealloc-error.patch b/recipes-extended/pktgen-dpdk/files/fix-gcc11-mismatched-dealloc-error.patch
new file mode 100644
index 00000000..a2befbd6
--- /dev/null
+++ b/recipes-extended/pktgen-dpdk/files/fix-gcc11-mismatched-dealloc-error.patch
@@ -0,0 +1,72 @@
1From 530fbb2e2deb6b9214466933df221910c2c50b7c Mon Sep 17 00:00:00 2001
2From: Ting Liu <ting.liu@nxp.com>
3Date: Fri, 15 Oct 2021 08:01:15 +0530
4Subject: [PATCH] fix gcc11 mismatched-dealloc error
5
6Fix build error with gcc 11:
7| FAILED: lib/common/libcommon.a.p/lscpu.c.o
8| aarch64-poky-linux-gcc -fstack-protector-strong -O2 -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -Werror=format-security -Wdate-time --sysroot=/opt/ci/yocto/honister/build-lx2162aqds/tmp/work/lx2162aqds-poky-linux/pktgen-dpdk/21.05.0-r0/recipe-sysroot -Ilib/common/libcommon.a.p -Ilib/common -I../git/lib/common -fdiagnostics-color=always -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -Wextra -Wpedantic -Werror -O3 -DALLOW_EXPERIMENTAL_API -D_GNU_SOURCE -Wno-pedantic -Wno-format-truncation -DRTE_FORCE_INTRINSICS -fPIC -include rte_config.h -march=armv8-a+crc -moutline-atomics -MD -MQ lib/common/libcommon.a.p/lscpu.c.o -MF lib/common/libcommon.a.p/lscpu.c.o.d -o lib/common/libcommon.a.p/lscpu.c.o -c ../git/lib/common/lscpu.c
9| In function 'lscpu_info_get',
10| inlined from 'lscpu_info' at ../git/lib/common/lscpu.c:210:2:
11| ../git/lib/common/lscpu.c:167:9: error: 'fclose' called on pointer returned from a mismatched allocation function [-Werror=mismatched-dealloc]
12| 167 | fclose(f);
13| | ^~~~~~~~~
14| ../git/lib/common/lscpu.c: In function 'lscpu_info':
15| ../git/lib/common/lscpu.c:146:22: note: returned from 'popen'
16| 146 | FILE *f = popen(lscpu_path, "r");
17| | ^~~~~~~~~~~~~~~~~~~~~~
18| In function 'cpu_proc_info',
19| inlined from 'lscpu_info' at ../git/lib/common/lscpu.c:211:2:
20| ../git/lib/common/lscpu.c:195:9: error: 'fclose' called on pointer returned from a mismatched allocation function [-Werror=mismatched-dealloc]
21| 195 | fclose(f);
22| | ^~~~~~~~~
23| ../git/lib/common/lscpu.c: In function 'lscpu_info':
24| ../git/lib/common/lscpu.c:174:22: note: returned from 'popen'
25| 174 | FILE *f = popen(proc_path, "r");
26| | ^~~~~~~~~~~~~~~~~~~~~
27| cc1: all warnings being treated as errors
28
29Signed-off-by: Ting Liu <ting.liu@nxp.com>
30---
31 app/pktgen.h | 2 +-
32 lib/common/lscpu.c | 4 ++--
33 2 files changed, 3 insertions(+), 3 deletions(-)
34
35diff --git a/app/pktgen.h b/app/pktgen.h
36index 7c61fc8..2f24c65 100644
37--- a/app/pktgen.h
38+++ b/app/pktgen.h
39@@ -531,7 +531,7 @@ do_command(const char *cmd, int (*display)(char *, int)) {
40 i = display(line, i);
41
42 if (f)
43- fclose(f);
44+ pclose(f);
45 if (line)
46 free(line);
47
48diff --git a/lib/common/lscpu.c b/lib/common/lscpu.c
49index 8b56ccd..912c601 100644
50--- a/lib/common/lscpu.c
51+++ b/lib/common/lscpu.c
52@@ -164,7 +164,7 @@ lscpu_info_get(const char *lscpu_path)
53 }
54 }
55
56- fclose(f);
57+ pclose(f);
58 free(line);
59 }
60
61@@ -192,7 +192,7 @@ cpu_proc_info(const char *proc_path)
62 }
63 }
64
65- fclose(f);
66+ pclose(f);
67 free(line);
68 }
69
70--
712.25.1
72
diff --git a/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb b/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb
deleted file mode 100644
index 6a039129..00000000
--- a/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1DESCRIPTION = "PKTGEN DPDK"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=30ac8fa65a07ea7cc1c7ee84e1c80294"
4
5DEPENDS += "libpcap dpdk lua lua-native"
6
7SRC_URI = "git://dpdk.org/git/apps/pktgen-dpdk;protocol=https;nobranch=1 \
8"
9SRCREV = "7a61e4dfcdf037c31460b6c9bcb301797813036a"
10
11S = "${WORKDIR}/git"
12
13DPAA_VER ?= "dpaa"
14export RTE_TARGET = "arm64-${DPAA_VER}-linuxapp-gcc"
15export RTE_SDK = "${RECIPE_SYSROOT}/usr/share/"
16
17EXTRA_OEMAKE += 'CC="${CC}" LD="${LD}" RTE_SDK="${RECIPE_SYSROOT}/usr/share/" RTE_TARGET="arm64-${DPAA_VER}-linuxapp-gcc"'
18
19do_compile() {
20 oe_runmake
21}
22
23do_install() {
24 install -d ${D}${bindir}/
25 cp -f ${S}/app/arm64-dpaa-linuxapp-gcc/pktgen ${D}${bindir}/
26 cp -f ${S}/Pktgen.lua ${D}${bindir}/
27}
28
29INSANE_SKIP:${PN} = "ldflags"
30INHIBIT_PACKAGE_STRIP = "1"
31PACKAGE_ARCH = "${MACHINE_ARCH}"
32PARALLEL_MAKE = ""
33COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-extended/pktgen-dpdk/pktgen-dpdk_21.05.0.bb b/recipes-extended/pktgen-dpdk/pktgen-dpdk_21.05.0.bb
new file mode 100644
index 00000000..f04e1e9f
--- /dev/null
+++ b/recipes-extended/pktgen-dpdk/pktgen-dpdk_21.05.0.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "PKTGEN DPDK"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=0245ceedaef59ae0129500b0ce1e8a45"
4
5DEPENDS += "libpcap dpdk lua lua-native"
6
7SRC_URI = "git://dpdk.org/git/apps/pktgen-dpdk;protocol=https;nobranch=1 \
8 file://fix-gcc11-mismatched-dealloc-error.patch \
9"
10SRCREV = "3a09aa916597fb9a97ee8eec50044cbdb9c4abde"
11
12S = "${WORKDIR}/git"
13
14DPAA_VER ?= "dpaa"
15export RTE_TARGET = "arm64-${DPAA_VER}-linuxapp-gcc"
16export RTE_SDK = "${RECIPE_SYSROOT}/usr/share/dpdk"
17
18inherit meson pkgconfig
19
20MESON_BUILDTYPE = "release"
21EXTRA_OEMESON += '-Dc_args="-DRTE_FORCE_INTRINSICS"'
22
23do_configure:prepend() {
24 sed -i "/^add_project_arguments('-march=native'/s/^/#&/" ${S}/meson.build
25}
26
27do_install() {
28 install -d ${D}${bindir}/
29 install -m 0755 app/pktgen ${D}${bindir}/
30 install -m 0644 ${S}/Pktgen.lua ${D}${bindir}/
31}
32
33INSANE_SKIP:${PN} = "ldflags"
34INHIBIT_PACKAGE_STRIP = "1"
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36PARALLEL_MAKE = ""
37COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc
index 55f20ed5..2d26a7e9 100644
--- a/recipes-extended/secure-obj/secure-obj.inc
+++ b/recipes-extended/secure-obj/secure-obj.inc
@@ -10,9 +10,8 @@ inherit python3native
10 10
11LDFLAGS += "${TOOLCHAIN_OPTIONS}" 11LDFLAGS += "${TOOLCHAIN_OPTIONS}"
12 12
13SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1 \ 13SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1"
14" 14SRCREV = "5ff1231f74b4b01744be95a3137a14ad0a483e61"
15SRCREV = "71a6eb33b58a8578a60995da3896f8f2d638c916"
16 15
17WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 16WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
18export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" 17export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb
index 1fd1fea3..84ecea1e 100644
--- a/recipes-extended/secure-obj/secure-obj_git.bb
+++ b/recipes-extended/secure-obj/secure-obj_git.bb
@@ -13,6 +13,7 @@ export CROSS_COMPILE_HOST = "${CROSS_COMPILE}"
13export CROSS_COMPILE_TA = "${CROSS_COMPILE}" 13export CROSS_COMPILE_TA = "${CROSS_COMPILE}"
14ARCH:qoriq-arm64 = "aarch64" 14ARCH:qoriq-arm64 = "aarch64"
15ARCH:qoriq-arm = "arm" 15ARCH:qoriq-arm = "arm"
16CFLAGS += "${TOOLCHAIN_OPTIONS}"
16 17
17do_compile() { 18do_compile() {
18 unset LDFLAGS 19 unset LDFLAGS
diff --git a/recipes-extended/tsntool/tsntool_git.bb b/recipes-extended/tsntool/tsntool_git.bb
index f4f10938..f1ddbec8 100644
--- a/recipes-extended/tsntool/tsntool_git.bb
+++ b/recipes-extended/tsntool/tsntool_git.bb
@@ -8,7 +8,7 @@ DEPENDS = "cjson libnl readline"
8inherit pkgconfig 8inherit pkgconfig
9 9
10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/tsntool;protocol=https;nobranch=1" 10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/tsntool;protocol=https;nobranch=1"
11SRCREV = "3111f7f79e7d1b1a5e60f37fe76785559b2d0360" 11SRCREV = "b767c260b851aac94828ed26c6a9a327e4e98334"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14