diff options
Diffstat (limited to 'recipes-extended')
-rw-r--r-- | recipes-extended/secure-obj/secure-obj-module_git.bb | 11 | ||||
-rw-r--r-- | recipes-extended/secure-obj/secure-obj.inc | 27 | ||||
-rw-r--r-- | recipes-extended/secure-obj/secure-obj_git.bb | 37 |
3 files changed, 75 insertions, 0 deletions
diff --git a/recipes-extended/secure-obj/secure-obj-module_git.bb b/recipes-extended/secure-obj/secure-obj-module_git.bb new file mode 100644 index 00000000..3866dde4 --- /dev/null +++ b/recipes-extended/secure-obj/secure-obj-module_git.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | require secure-obj.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://../README;md5=82b72e88f23cded9dd23f0fb1790b8d2" | ||
4 | |||
5 | DEPENDS += "virtual/kernel" | ||
6 | |||
7 | inherit module | ||
8 | |||
9 | S = "${WORKDIR}/git/securekeydev" | ||
10 | |||
11 | EXTRA_OEMAKE += 'KERNEL_SRC="${STAGING_KERNEL_DIR}"' | ||
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc new file mode 100644 index 00000000..3fd70eb8 --- /dev/null +++ b/recipes-extended/secure-obj/secure-obj.inc | |||
@@ -0,0 +1,27 @@ | |||
1 | DESCRIPTION = "Secure Object" | ||
2 | LICENSE = "BSD" | ||
3 | |||
4 | DEPENDS = "openssl optee-os-qoriq optee-client-qoriq" | ||
5 | RDEPENDS_${PN} = "bash libcrypto libssl python" | ||
6 | |||
7 | DEPENDS += "python-pycrypto-native" | ||
8 | |||
9 | inherit pythonnative | ||
10 | |||
11 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" | ||
12 | |||
13 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1 \ | ||
14 | " | ||
15 | SRCREV = "74befe01bda41f1c27b197ef2ab66e475e9a81b3" | ||
16 | |||
17 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | ||
18 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" | ||
19 | export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" | ||
20 | |||
21 | EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"' | ||
22 | |||
23 | ALLOW_EMPTY_${PN} = "1" | ||
24 | INHIBIT_PACKAGE_STRIP = "1" | ||
25 | PARALLEL_MAKE = "" | ||
26 | INSANE_SKIP_${PN} = "ldflags" | ||
27 | COMPATIBLE_MACHINE = "(ls2080ardb|ls2084ardb|ls2088a|ls1043a|ls1046a|ls1088a)" | ||
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb new file mode 100644 index 00000000..103c089e --- /dev/null +++ b/recipes-extended/secure-obj/secure-obj_git.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | require secure-obj.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2" | ||
4 | |||
5 | S = "${WORKDIR}/git" | ||
6 | |||
7 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | ||
8 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" | ||
9 | export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" | ||
10 | export CROSS_COMPILE_HOST = "${CROSS_COMPILE}" | ||
11 | export CROSS_COMPILE_TA = "${CROSS_COMPILE}" | ||
12 | |||
13 | do_compile() { | ||
14 | unset LDFLAGS | ||
15 | export TA_DEV_KIT_DIR="${RECIPE_SYSROOT}/usr/include/optee/export-user_ta" | ||
16 | export CROSS_COMPILE="${WRAP_TARGET_PREFIX}" | ||
17 | export OPENSSL_PATH="${RECIPE_SYSROOT}/usr" | ||
18 | for APP in secure_storage_ta securekey_lib secure_obj-openssl-engine; do | ||
19 | cd ${APP} | ||
20 | oe_runmake | ||
21 | cd .. | ||
22 | done | ||
23 | } | ||
24 | |||
25 | do_install() { | ||
26 | install -d ${D}${bindir}/secure_obj | ||
27 | install -d ${D}${libdir}/secure_obj | ||
28 | install -d ${D}${includedir} | ||
29 | cp ${S}/secure_storage_ta/ta/b05bcf48-9732-4efa-a9e0-141c7c888c34.ta ${D}${bindir}/secure_obj | ||
30 | cp ${S}/securekey_lib/out/export/lib/libsecure_obj.so ${D}${libdir}/secure_obj | ||
31 | cp ${S}/secure_obj-openssl-engine/libeng_secure_obj.so ${D}${libdir}/secure_obj | ||
32 | cp ${S}/securekey_lib/out/export/app/* ${D}${bindir}/secure_obj | ||
33 | cp ${S}/securekey_lib/out/export/include/* ${D}${includedir} | ||
34 | cp ${S}/secure_obj-openssl-engine/app/sobj_eng_app ${D}${bindir}/secure_obj | ||
35 | } | ||
36 | |||
37 | FILES_${PN} += "${libdir}/secure_obj" | ||